OpenVZ Forum


Home » General » Support » *SOLVED* OpenVZ mount script works incorrectly
*SOLVED* OpenVZ mount script works incorrectly [message #37789] Thu, 22 October 2009 13:58 Go to previous message
cray is currently offline  cray
Messages: 11
Registered: October 2009
Junior Member
MySQL database works on host. I want to share /var/run/mysqld/ directory to guest system.

Here is my 101.mount script
#!/bin/bash
mount --bind -n /var/run/mysqld /home/vz/root/${VEID}/var/run/mysqld


When I run
vzctl start 101

it wipes whole host directory /var/run/mysqld, and mysql went down. So I have no '/var/run/mysqld' and no '/home/vz/root/${VEID}/var/run/mysqld'.

When I'm trying to mount this directory manually after the guest system was started - everything works fine.

What is wrong?

I'm running Debian Lenny Linux host 2.6.26-2-openvz-686 #1 SMP Wed Aug 19 07:30:34 UTC 2009 i686 GNU/Linux

vzctl --version
vzctl version 3.0.22

[Updated on: Thu, 22 October 2009 15:04] by Moderator

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Auditd and openz
Next Topic: Why umount script runs on VE start?
Goto Forum:
  


Current Time: Tue Jan 31 16:54:44 GMT 2023

Total time taken to generate the page: 0.00811 seconds