OpenVZ Forum


Home » International » German » openVPN bridging Multi-Singlepoint
openVPN bridging Multi-Singlepoint [message #36614] Sat, 04 July 2009 22:38 Go to previous message
pm27a is currently offline  pm27a
Messages: 2
Registered: July 2009
Junior Member
From: *static.84-253-39-110.cybernet.ch
Hallo Zusammen

Ich versuche seit einiger Zeit openVPN im Bridgingmodus in einer VM laufen lassen. OpenVPN selber läuft tadellos, nur eben das Bridging will nicht so recht.

Mein Ziel ist es OpenVPN nach dem Spezialfall "Multi-Singlepoint" einzurichten. Definition Anleitung

Hat das schon wer von euch realisiert und kann mir sagen, wie er vorgegangen ist?

Mein Vorgehen bis jetzt:
Host:
modprobe tun
vzctl set 101 --devices c:10:200:rw --save
vzctl set 101 --capability net_admin:on --save

vzctl exec 101 mkdir -p /dev/net
vzctl exec 101 mknod /dev/net/tun c 10 200
vzctl exec 101 chmod 600 /dev/net/tun


VM:
  • OpenVPN installiert und standard Routing konfiguriert

Danach versuchte ich das Bridging einzubauen. Dazu erstellte ich zuerst ein neues veth mit dem Namen vplan. Die Idee dahinter ist, dass später alle VPN-Clients in diesem LAN sind, da der Server selber keins hat. Ich bin mir nicht sicher, ob dies nötig und richtig ist.
vzctl set 101 --netif_add vplan

Danach wollte ich wie im Tutorial beschrieben tap mit vplan bridgen. Hier blieb ich aus folgenden Gründen stecken:
  1. /dev/tap0 existiert nicht (ist noch nachvollziehbar, leider kenne ich die Lösung noch nicht, evtl mknode?)
  2. brctl addbr br0 schlägt fehl

Ich habe gelesen, dass Bridges nur vom Host erstellt werden können. Wenn dies so ist, habe ich ein Problem, denn der Host sollte ja eigentlich /dev/tap0 von der VM nicht kennen.

Kann mir jemand von euch weiterhelfen?

Vielen Dank für eure Bemühungen
pm27a
 
Read Message
Read Message
Previous Topic: del
Next Topic: vzctl problem
Goto Forum:
  


Current Time: Tue Oct 20 02:37:34 GMT 2020