OpenVZ Forum

Home » General » Support » [SOLVED]: CentOS 5.2 HN and VPS - man and less problems in VPS
[SOLVED]: CentOS 5.2 HN and VPS - man and less problems in VPS [message #34878] Tue, 10 February 2009 11:18 Go to previous message
_sgb_ is currently offline  _sgb_
Messages: 3
Registered: February 2009
Junior Member
From: *
Hi all,

I can't run man or less inside a VPS. Piping the results of any command into less just returns to the command line, however 'more' works. Using the command 'man' returns the following error:

# man bash
Error executing formatting or display command.
System command (cd /usr/share/man && (echo ".ll 13.9i"; echo ".nr LL 13.9i"; echo ".pl 1100i"; /usr/bin/gunzip -c '/usr/share/man/man1/bash.1.gz'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c --legacy ISO-8859-1 -mandoc 2>/dev/null | /usr/bin/less -is) exited with status 256.
No manual entry for bash

Something that I suspect is related to the same problem; the -p switch on the mysql client does not prompt for a password:

# mysql -hlocalhost -uroot -p
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

However, specifying it on the command line works fine:

# mysql -hlocalhost -uroot -pMYSQLPASSWORD
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 49
Server version: 5.0.45 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.


I'm not entirely sure what will be relevant to the issue, so here's the background.
I am running CentOS 5.2 with kernel version 2.6.18-92.1.13.el5.028stab059.6PAE. I created my own CentOS 5.2 minimal template and followed the recommendations to disable the udev start in
I have made the dev files for null,ptmx,random,urandom, ttyp and ptyp and there seems to be no trouble there.

Networking is fine, updates and installs work fine from inside the VPS, websites are fine...

I would expect this to be something small that I have missed, and it's more of an annoyance than a problem. Has anyone any ideas?



[Updated on: Tue, 10 February 2009 15:32]

Report message to a moderator

Read Message
Read Message
Read Message
Read Message
Previous Topic: Problem VPS Could Not Start Vps, Reason: vzquota
Next Topic: Public/Private IP Configuration
Goto Forum:

Current Time: Wed May 22 04:39:02 GMT 2019