OpenVZ Forum

Home » General » Support » *SOLVED* debian etch ssh problem
*SOLVED* debian etch ssh problem [message #25487] Thu, 27 December 2007 15:14 Go to previous message
john.reddie is currently offline  john.reddie
Messages: 2
Registered: December 2007
Location: London
Junior Member
Hello all

A hopefully simple one from a complete newb...

I've successully set up a ve running debian etch, and can ssh to it without problems. At the moment I'm using root access and yes, I know, and I'll get ssh keys going soon!!! But at the moment I'm trying to get something just "working".

If I create a template of this ve and then start from that, assigning it ipadd, nameserver, hostname etc. then I can ping it, and ping out from it etc. But I can no longer ssh to it. I get

my_machine:~ john$ ssh -l root x.x.x.x
Connection closed by x.x.x.x

(x.x.x.x obviously has real ip address)

and that's it. ps ax on the ve suggests that ssh is running.

9354 ? Ss 0:00 /usr/sbin/sshd
The hardware node has 2 physical interfaces, as eth0 and eth1. eth1 has ip address on same subnet as x.x.x.x address in use on ve.

I have tweaked my sysctl (i think it's right) as recommended.

What I don't understand is why it works when running as a first-build ve, but not when templated and then run with the same info (and no, I'm not trying to run them both at the same time on the same settings!!!)

Any ideas? Am I missing something really obvious? I gave root a password and have not (as yet) disabled root login - though I will!


[Updated on: Thu, 27 December 2007 17:43] by Moderator

Report message to a moderator

Read Message
Read Message
Read Message
Previous Topic: *SOLVED* Xvfb could not open default font 'fixed'
Next Topic: *SOLVED* Trouble getting internet to VEs
Goto Forum:

Current Time: Tue Feb 27 08:11:48 GMT 2024

Total time taken to generate the page: 0.02737 seconds