OpenVZ Forum


Home » General » Support » *partially solved* startx - cannot open /dev/tty0
*partially solved* startx - cannot open /dev/tty0 [message #24027] Fri, 30 November 2007 11:44 Go to previous message
paul_xedos is currently offline  paul_xedos
Messages: 13
Registered: November 2007
Junior Member
Hi,
I'm running RHEL4U4 in a VE and attempting to startx in order to allow developers in India to display their desktops over a slow link using NoMachine (similar to VNC). A pre-req for doing this is that X is running.

[root@vz1 ~]# startx 

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-34.0.1.ELsmp i686 [ELF]
Current Operating System: Linux vz1 2.6.9-023stab044.11-enterprise #1 SMP Sun Sep 30 14:02:45 MSD 2007 i686
Build Date: 11 July 2006
Build Host: hs20-bc1-1.build.redhat.com

        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.9-023stab044.11-enterprise (root@rhel4-32) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 SMP Sun Sep 30 14:02:45 MSD 2007
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 30 11:26:15 2007
(==) Using config file: "/etc/X11/xorg.conf"
[B]
Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)[/B]


My dev/tty directory was created as follows
MAKEDEV tty pty
mknod -m 666 /dev/tty0 c 5 1
[root@vz1 ~]# ls -l /dev/tty*
-rw-r--r--  1 root root 5,  2 Nov 30 11:21 /dev/tty
crw-rw-rw-  1 root root 5,  1 Nov 30 11:39 /dev/tty0
crw-rw-rw-  1 root root 5,  0 Nov 27 17:31 /dev/ttyp
crw-rw-rw-  1 root tty  3, 48 Nov 30 11:25 /dev/ttys0
crw-rw-rw-  1 root tty  3, 49 Nov 30 11:25 /dev/ttys1
   :                   :                 :         
crw-rw-rw-  1 root tty  3, 63 Nov 30 11:25 /dev/ttysf


I'm beginning to wonder whether the "cannot open /dev/tty0" is not actually the problem and really X is failing for some other reason

Thanks
Paul

[Updated on: Fri, 30 November 2007 18:13] by Moderator

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Rough Copy Box
Next Topic: OpenVZ - Cent OS - Install Problem
Goto Forum:
  


Current Time: Mon Mar 04 05:58:06 GMT 2024

Total time taken to generate the page: 0.02458 seconds