OpenVZ Forum


Home » General » Support » FUSE not working in container on Debian7 x64 (FATAL: Module fuse not found.)
FUSE not working in container on Debian7 x64 [message #50953] Tue, 10 December 2013 19:06 Go to previous message
webs1821 is currently offline  webs1821
Messages: 2
Registered: December 2013
Location: Poland
Junior Member
Hi!
I've got a problem with running Fuse on container with Debian 7 x64.
First I read openvz.org/FUSE and asked my VPS provider to enable Fuse, he did it and I got fuse in /dev/ but it still doesn't work.
I asked my provider for a help but he told me that this is how it looks in this virtualization and fuse will not work.
Please, tell me if is it true and what can be wrong?
I tried to run fuse on debian7 x64 and x86, fedora 19 x64 and debian6 x64.
I tried also compile fuse from source.
Below I show my steps on fresh debian7 x64:
root@vps:~# apt-get update
root@vps:~# apt-get upgrade
root@vps:~# apt-get install libfuse2 fuse curlftpfs
root@vps:~# reboot
root@vps:~# curlftpfs -o user=login:pass ftp.server.com /mnt
fuse: device not found, try 'modprobe fuse' first
root@vps:~# modprobe fuse
libkmod: ERROR ../libkmod/libkmod.c:505 kmod_lookup_alias_from_builtin_file: could not open builtin file '/lib/modules/2.6.32-042stab083.2/modules.builtin.bin'
FATAL: Module fuse not found.
root@vps:~# ls -la /lib/modules/2.6.32-042stab083.2/
total 36
drwxr-xr-x 2 root root 4096 Dec 10 04:11 .
drwxr-xr-x 3 root root 4096 Dec 10 04:11 ..
-rw-r--r-- 1 root root   45 Dec 10 04:11 modules.alias
-rw-r--r-- 1 root root   12 Dec 10 04:11 modules.alias.bin
-rw-r--r-- 1 root root    0 Dec 10 04:11 modules.builtin.bin
-rw-r--r-- 1 root root    0 Dec 10 04:11 modules.dep
-rw-r--r-- 1 root root   12 Dec 10 04:11 modules.dep.bin
-rw-r--r-- 1 root root   52 Dec 10 04:11 modules.devname
-rw-r--r-- 1 root root  131 Dec 10 04:11 modules.softdep
-rw-r--r-- 1 root root   49 Dec 10 04:11 modules.symbols
-rw-r--r-- 1 root root   12 Dec 10 04:11 modules.symbols.bin
root@vps:~# ls -la /dev/fuse*
crw-rw---T 1 root fuse 10, 229 Dec 10 04:11 /dev/fuse
root@vps:~# uname -a
Linux vps 2.6.32-042stab083.2 #1 SMP Fri Nov 8 18:08:40 MSK 2013 x86_64 GNU/Linux

 
Read Message
Read Message
Read Message
Previous Topic: VPS load 13.00 (two cpus aloted), SSH timeout, websites OK, unable fork
Next Topic: OpenVZ kernel reliability - production ready?
Goto Forum:
  


Current Time: Tue Jul 16 13:21:51 GMT 2024

Total time taken to generate the page: 0.02887 seconds