OpenVZ Forum


Home » General » Support » Ploop error
Ploop error [message #50627] Wed, 25 September 2013 00:08 Go to previous message
zgvtee1oqw
Messages: 3
Registered: September 2013
Junior Member
Hi,

Trying to figure out why Ploop fails to run properly on Proxmox (Debian based).

Installed version 1.9 of ploop and ploop-lib using alien from the RPM packages.

# uname -a
Linux openvz 2.6.32-24-pve #1 SMP Fri Sep 13 07:29:30 CEST 2013 x86_64 GNU/Linux

# mount |grep /mnt
/dev/mapper/openvz-openvz on /mnt type ext4 rw,relatime,barrier=1,nodelalloc,data=journal)

# lsmod |grep ploop
pfmt_ploop1 6384 0
ploop 112977 4 pfmt_ploop1,pfmt_raw,pio_direct,pio_nfs

# ploop init -s 10M -t ext4 /mnt/test.img
Creating delta /mnt/test.img bs=2048 size=20480 sectors v1
Error in create_empty_delta (ploop.c:339): Can't open /mnt/test.img: Invalid argument

# strace ploop init -s 10M -t ext4 /mnt/test.img
...
...
stat("/mnt/test.img", 0x7fff955cc590) = -1 ENOENT (No such file or directory)
stat("/mnt/DiskDescriptor.xml", 0x7fff955cc590) = -1 ENOENT (No such file or directory)
mmap(NULL, 1056768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd53a5f8000
fstat(1, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 2), ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd53a70a000
write(1, "Creating delta /mnt/test.img bs="..., 59Creating delta /mnt/test.img bs=2048 size=20480 sectors v1
) = 59
open("/mnt/test.img", O_RDWR|O_CREAT|O_EXCL|O_DIRECT, 0600) = -1 EINVAL (Invalid argument)
write(2, "Error in create_empty_delta (plo"..., 86Error in create_empty_delta (ploop.c:339): Can't open /mnt/test.img: Invalid argument
) = 86
munmap(0x7fd53a5f8000, 1056768) = 0
unlink("/mnt/test.img") = 0
exit_group(1)

Any ideas?
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: Can i "service network restart" on dedi?
Next Topic: Containers won't start
Goto Forum:
  


Current Time: Wed Jun 19 14:31:04 GMT 2024

Total time taken to generate the page: 0.03396 seconds