OpenVZ Forum


Home » International » German » 2 NIC Routing Problem
2 NIC Routing Problem [message #49212] Tue, 09 April 2013 13:48 Go to previous message
afaber is currently offline  afaber
Messages: 7
Registered: September 2009
Junior Member
From: *dip0.t-ipconnect.de
Hallo zusammen,

ich habe folgendes Problem bei diesem ich nicht weiter komme.

OpenVZ Server (Proxmox)
eth0 - Internes Netzwerk 10.0.15.x
eth1 - extern 80.190.x.x

Eine VM ist mit den IPs
IP_ADDRESS="80.190.1xx.x 10.0.15.88"
konfiguriert.

Innerhalb der VM:


Ping zu google.de und z.B. 10.0.15.21 (interner Webserver) funktioniert.
Lynx www.web.de - funktioniert
Lynx 10.0.15.21 - geht nicht! (Webserver ist aber 100% erreichbar), slogin etc. geht auch nicht

root@blog:/# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default * 0.0.0.0 U 0 0 0 venet0


Auf dem Host:
gehen beide Lynx aufrufe.

ci.xxxxxxxxx. * 255.255.255.255 UH 0 0 0 venet0
80.190.xxx.xx * 255.255.255.128 U 0 0 0 eth1
10.0.15.0 * 255.255.255.0 U 0 0 0 eth0
default gw.xxxx.xx 0.0.0.0 UG 0 0 0 eth1

Ändere ich die IP-Reihenfolge in der Konfiguration IP_ADDRESS="10.0.15.88 80.190.1xx.x " klappt der interne Lynx Aufruf nur alles andere wie DNS halt nicht.

Vermutlich muss ich venet0 noch die zweite Route beibringen.
Aber wie kann ich das machen?
Zwei default Gateways?

gruß,
Andy
 
Read Message
Read Message
Previous Topic: Iptables openvz Host
Next Topic: VPS startet aber irgendwie auch nicht
Goto Forum:
  


Current Time: Fri Sep 20 12:36:09 GMT 2019