OpenVZ Forum


Home » General » Support » Installing Freeside on CentOS 4.4 VE
Installing Freeside on CentOS 4.4 VE [message #25503] Thu, 27 December 2007 21:31 Go to previous message
johan_hammy is currently offline  johan_hammy
Messages: 99
Registered: December 2005
Member
I'm following http://www.sisd.com/mediawiki/index.php/Freeside:1.7:Documen tation:InstallingOnCentOS4.4 with exceptions where necessary for my virtual server. I'm no expert on the virtual server, nor Linux overall.

I downloaded the file in both my host server and virtual server.

from the virtual server:
Quote:

[root@freeside-centos4 ~]# rpm -ivh /tmp/rpmforge-release-0.3.6-1.el4.rf.i386.rpm
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
warning: /tmp/rpmforge-release-0.3.6-1.el4.rf.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages database in /var/lib/rpm



from the host server:
Quote:

[root@Char ~]# vzrpm 114 -ivh /tmp/rpmforge-release-0.3.6-1.el4.rf.i386.rpm
exec /bin/rpm --root /vz/root/114 -ivh /tmp/rpmforge-release-0.3.6-1.el4.rf.i386.rpm
warning: /tmp/rpmforge-release-0.3.6-1.el4.rf.i386.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
Preparing... ########################################### [100%]
1:rpmforge-release ########################################### [100%]
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag: import failed.
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dries: import failed.
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-matthias: import failed.


Ideas?
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: *SOLVED* Trouble getting internet to VEs
Next Topic: *SOLVED* which distr is prefer to use as base system?
Goto Forum:
  


Current Time: Sat Apr 13 01:34:26 GMT 2024

Total time taken to generate the page: 0.01601 seconds