OpenVZ Forum


Home » International » French » créer une VM depuis une image RAW exportée de VirtualBox
créer une VM depuis une image RAW exportée de VirtualBox [message #42739] Tue, 17 May 2011 10:55 Go to next message
Cyrille37 is currently offline  Cyrille37
Messages: 6
Registered: April 2011
Location: Tours, France
Junior Member
Salut,

OpenVZ est vraiment facile d'utilisation quand on utilise les templates, mais pour le reste j'ai vraiment du mal à trouver de la doc.

Avez vous une idée/solution pour créer une VM OpenVZ à partir d'une image RAW générée en exportant une VM VirtualBox ?

En détail:

En fait je souhaite faire tourner Tiles@Home, mais il n'est fourni qu'une VM VirtualBox : wiki.openstreetmap.org/wiki/Virtual_Tiles@Home_-_Ubuntu

Je l'ai installée et faire un "clonehd --format RAW", mais maintenant que faire pour la faire tourner avec OpenVZ ?

Merci d'avance,
Cyrille.
Re: créer une VM depuis une image RAW exportée de VirtualBox [message #42740 is a reply to message #42739] Wed, 18 May 2011 06:45 Go to previous messageGo to next message
Cyrille37 is currently offline  Cyrille37
Messages: 6
Registered: April 2011
Location: Tours, France
Junior Member
Pour l'instant j'ai trouvé ce Tuto (en anglais):

"Physical to container": wiki.openvz.org/Physical_to_container
Re: créer une VM depuis une image RAW exportée de VirtualBox [message #42750 is a reply to message #42740] Thu, 19 May 2011 15:08 Go to previous messageGo to next message
nyquist is currently offline  nyquist
Messages: 27
Registered: June 2010
Location: 44 - France
Junior Member
le tuto est un très bon début sinon j'ai déjà donnée une procédure a effectuer depuis un serveur démarré. (j'ai déjà utilisé cette procédure mais je ne garantis rien, a adapter a ton cas d'utilisation. Regarde le message dans le forum intitulé : server physique vers openvz proxmox.

A ma connaissance il n'y pas d'outils de migration d'une image vbox en openvz.
Re: créer une VM depuis une image RAW exportée de VirtualBox [message #42751 is a reply to message #42750] Thu, 19 May 2011 15:28 Go to previous message
Cyrille37 is currently offline  Cyrille37
Messages: 6
Registered: April 2011
Location: Tours, France
Junior Member
En fait, après lecture du tuto, j'ai fait un peu différemment.

J'ai d'abord créé la VM avec Proxmox et vérifié qu'elle tournait bien.
Ensuite j'ai fait un rsync de l'autre serveur en excluant les répertoires /etc /boot /var /lost+found /proc /dev et quelques autres trucs.
Puis j'ai démarré l'appli concernée, et vu les erreurs.
C'était essentiellement des problèmes liés à l'exclusion du répertoire /etc. J'ai corrigé ces erreurs à la mano.
Et hop, ça roule.

Merci de ta réponse
Cyrille.
Previous Topic: Open VNC Consol vide
Next Topic: vps en français
Goto Forum:
  


Current Time: Tue Dec 06 17:30:58 GMT 2022

Total time taken to generate the page: 0.02099 seconds