OpenVZ Forum

Home » Mailing lists » Users » (no subject)
(no subject) [message #42621] Fri, 06 May 2011 17:53
foxb is currently offline  foxb
Messages: 12
Registered: December 2009
Junior Member
From: 216.191.245*

I have following issue.
My Host is running CentOS
cat /etc/redhat-release
CentOS release 5.6 (Final)

uname -a
Linux server 2.6.18-238.9.1.el5.028stab089.1PAE #1 SMP Thu Apr 14 14:38:02 MSD 2011 i686 athlon i386 GNU/Linux

and some guests are Debian

cat /etc/debian_version

Upgraded to Squeeze

cat /etc/apt/sources.list
deb squeeze main contrib non-free
deb squeeze/updates main contrib non-free
deb unstable main non-free contrib
#deb squeeze-backports main contrib non-free
deb squeeze-updates main contrib
============================================================ ================

When I try to upgrade I get following

============================================================ ================
apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc-dev-bin : Depends: libc6 (> 2.13) but 2.11.2-11 is installed
libc6 : Depends: libc-bin (= 2.11.2-11) but 2.13-2 is installed
libc6-dev : Depends: libc6 (= 2.13-2) but 2.11.2-11 is installed
locales : Depends: glibc-2.13-1
nscd : Depends: libc6 (> 2.13) but 2.11.2-11 is installed
E: Unmet dependencies. Try using -f.
============================================================ ===============

When using -f I get

============================================================ ==============
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.13-2_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
============================================================ ================

So how to fix that?
CentOS does not have more recent kernel (official/stable)?!

Previous Topic: HELP:How can one VM interrupt another running VM ??
Next Topic: (no subject)
Goto Forum:

Current Time: Fri May 24 03:23:57 GMT 2019