OpenVZ Forum


Home » Mailing lists » Users » FATAL: Error inserting loop module after Squeeze kernel update
FATAL: Error inserting loop module after Squeeze kernel update [message #42268] Tue, 29 March 2011 08:12 Go to next message
Marc Olive is currently offline  Marc Olive
Messages: 7
Registered: March 2011
Junior Member
From: *parallels.com
Hello,

I've just updated a Debian Squeeze server with linux-image-2.6-openvz-amd64
package, and after reboot I cannot mount throught /dev/loop1:

.- The mount command says "/dev/loop1: File or directory not found".
.- I've checked /dev/loopX and there's aren't any loop devices.
.- The "loop" kernel module is not loaded.
.- When I try to load it with "modprobe loop" I get "FATAL: Error inserting
loop (/lib/modules/2.6.32-5-openvz-amd64/updates/loop.ko): Invalid module
format".

How can I solve it? Thanks,

--

Marc Olivé
Blau Advisors

marc.olive@blauadvisors.com

C/ Molí de Guasch, 10 baixos 1a,
43440 L’Espluga de Francolí (Tarragona)
Tel. +34 977 870 702
Tel i Fax. + 34 977 870 507

www.blauadvisors.com
Re: FATAL: Error inserting loop module after Squeeze kernel update [message #42285 is a reply to message #42268] Wed, 30 March 2011 08:57 Go to previous message
Marc Olive is currently offline  Marc Olive
Messages: 7
Registered: March 2011
Junior Member
From: *parallels.com
Hello,

It's solved.
The problem was the old "loop" module not properly updated by module-
assistant.
Carefully removing old package made with m-a and rebuilding worked for me.

Regards,

--

Marc Olivé
Blau Advisors

marc.olive@blauadvisors.com

C/ Molí de Guasch, 10 baixos 1a,
43440 L’Espluga de Francolí (Tarragona)
Tel. +34 977 870 702
Tel i Fax. + 34 977 870 507

www.blauadvisors.com
Previous Topic: Assign a container to a dedicated CPU core?
Next Topic: SOLVED --->. tar.gz.tar.gz not found while trying to create a container
Goto Forum:
  


Current Time: Sat Nov 17 20:11:55 GMT 2018