OpenVZ Forum


Home » International » Russian » Тормозит контейнер без видимых причин ! (Или какие проблемы есть с OpenVZ на CENTOS ?)
Тормозит контейнер без видимых причин ! [message #42256] Sat, 26 March 2011 16:36 Go to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
Коллеги, чтобы быть кратким: необходимый опыт имеется.

Суть проблемы такая: одна и та же нода, но в разных средах работает по-разному. Да, это вроде было бы нормально, если бы она на более мощном железе работала лучше, так нет же - в 100 раз медленее !

Кто-нибудь знает что-то про проблемы в работе OpenVZ на CENTOS 5.5 x_85-64 ? Все в норме (диск, память, CPU), но на старом барахле нода летает, на новеньком железе - даже визуально тормозит. Конфиги одинаковые (за исключением путей, разумеется). В топе одни и те же задачи просто больше жрут памяти и процессора, чем на старом физическом железе. Как такое может быть ?

Третью ночь не сплю, какого черта ... Точно ведь кто-то сталкивался с такой бедой. А мне на будущей неделе надо 10-ок VPS-ок развернуть, в офисе на старом железе давно юзаем OpenVZ (ASPLinux, FEDORA), но почему-же на новом железе такие тормоза ... ПАМАГИИТЕ! Свои идеи кончились уже.
Re: Тормозит контейнер без видимых причин ! [message #42422 is a reply to message #42256] Fri, 15 April 2011 05:57 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 512
Registered: January 2006
Location: Moscow, Russia
Senior Member
From: *sw.ru
День добрый.

Два вопроса:
1) какое ядро используете?
2) какое железо на новом сервере (в первую очередь - CPU)?

--
Константин


If you problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: Тормозит контейнер без видимых причин ! [message #42425 is a reply to message #42256] Fri, 15 April 2011 12:55 Go to previous messageGo to next message
sHaggY_caT is currently offline  sHaggY_caT
Messages: 144
Registered: August 2008
Location: Moscow, Russian Federatio...
Senior Member

From: *p-t-k.net
Попробуйте просто переставить старые HDD в новый сервер временно, что бы исключить софтовые проблемы.

Да и привидите какую-нибудь диагностику: по какому критерию тормозит? много iowait, мало idle?


IT-outsource for UNIX servers,
http://ha-systems.ru
Re: Тормозит контейнер без видимых причин ! [message #42467 is a reply to message #42256] Wed, 20 April 2011 10:30 Go to previous messageGo to next message
geomaster
Messages: 4
Registered: April 2011
Junior Member
From: *KMZ-NET.mts-nn.ru
Не буду начинать новую тему, а спрошу в этой.

HN с такой конфигурацией:
CPU: 2 x Xeon E5430 2.66 MHz
RAM: 8 GB
HDD: soft RAID1 (2x250GB под систему + 2x750 отдельно под /vz)
OS : CentOS 5.6 (Linux 2.6.18-238.5.1.el5.028stab085.3 #1 SMP Mon Mar 21 21:02:08 MSK 2011 i686 i686 i386 GNU/Linux)
Kernel: ovzkernel-2.6.18-238.5.1.el5.028stab085.3
Сеть на HN гигабитная.
Проблема:
Отдача файлов по SMB ОЧЕНЬ медленная 1-2MB/sec. Проверял скачиванием файла на 1 Гб. Этот же файл, но по HTTP - 10MB/sec
wget:
2011-04-20 14:18:16 (10,9 MB/s) - «test.1G» saved [1073741824/1073741824]
smbget:
[test.1G] 486,63Mb of 1024,00Mb (47,52%) at 1,82Mb/s


iperf показывает следующее:
1. HN -> Клиент (1Gbps): 0.0-60.0 sec 6.22 GBytes 891 Mbits/sec
2. HN -> VE: 0.0-60.0 sec 10.9 GBytes 1.57 Gbits/sec
3. VE -> Клиент (1Gbps): 0.0-60.0 sec 1.81 GBytes 259 Mbits/sec

iostat на HN:
avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           4,38    0,03    1,87    1,21    0,00   92,50

Device:         rrqm/s   wrqm/s   r/s   w/s   rsec/s   wsec/s avgrq-sz avgqu-sz   await  svctm  %util
md4               0,00     0,00  6,05 292,52   245,71  2340,20     8,66     0,00    0,00   0,00   0,00
md3               0,00     0,00  2,49 69,91   127,61   559,26     9,49     0,00    0,00   0,00   0,00


vzctl exec 10020 cat /proc/user_beancounters 
Version: 2.5
       uid  resource           held    maxheld    barrier      limit    failcnt
    10020:  kmemsize        8998299   11094768   27301888   31397888          0
            lockedpages           0          0       1039       1039          0
            privvmpages      221846     347569     512000     614400          0
            shmpages            995       1331     124528     124528          0
            dummy                 0          0          0          0          0
            numproc              98        117        500        500          0
            physpages        119303     246584          0 2147483647          0
            vmguarpages           0          0     464916 2147483647          0
            oomguarpages     119303     246584     771811 2147483647          0
            numtcpsock           18         37       1000       1000          0
            numflock             18         36        828        910          0
            numpty                2          3        100        100          0
            numsiginfo            0          8       1024       1024          0
            tcpsndbuf        337472    2600640    4096000    7095296          0
            tcprcvbuf        284608    3104384    4096000    7095296          0
            othersockbuf     352640     612288    2048000    4608000          0
            dgramrcvbuf           0      12160    1499648    1499648          0
            numothersock        190        291       1000       1000          0
            dcachesize       538386     752452    4634842    4773888          0
            numfile            2399       3551       8288       8288          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            numiptent            19         19        200        200          0


Может быть, какие-то настройки сделать в smb.conf специально для VE? С другой стороны, iperf тоже показывает низкую производительность...
На ноде всего 5 VE с почти аналогичными параметрами.
vzcpucheck -v
VEID            CPUUNITS
-------------------------
0               1000
10085           55555
10075           35714
10080           250000
10020           250000
10010           166666
Current CPU utilization: 758935
Power of the node: 1066425

Подтормаживают все, но особенно 10080 и 10020
Re: Тормозит контейнер без видимых причин ! [message #42513 is a reply to message #42467] Mon, 25 April 2011 19:01 Go to previous messageGo to next message
sHaggY_caT is currently offline  sHaggY_caT
Messages: 144
Registered: August 2008
Location: Moscow, Russian Federatio...
Senior Member

From: *p-t-k.net
Я бы, если есть возможность,

1) Провела бы тест на _другом_ железе (возьмите просто первый попавшийся PC-к с гигабитным интерфейсом на нормальном чипсете)
2) На текущем остановила все контейнеры, кроме проблемного
3) попробовала бы пересоздать данный контейнер.

В общем, метод исключения рулит)


IT-outsource for UNIX servers,
http://ha-systems.ru
Re: Тормозит контейнер без видимых причин ! [message #42520 is a reply to message #42422] Tue, 26 April 2011 07:44 Go to previous messageGo to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
finist wrote on Fri, 15 April 2011 09:57

1) какое ядро используете?
2) какое железо на новом сервере (в первую очередь - CPU)?


Ядро внутри контейнера: 2.6.18-238.5.1.e15.028stab085.3
CPU на хосте: XEON 2,4 (4 ядра)
Re: Тормозит контейнер без видимых причин ! [message #42521 is a reply to message #42425] Tue, 26 April 2011 07:45 Go to previous messageGo to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
sHaggY_caT wrote on Fri, 15 April 2011 16:55
Попробуйте просто переставить старые HDD в новый сервер временно, что бы исключить софтовые проблемы.


На старом железе IDE, а новое уже SATA.
Re: Тормозит контейнер без видимых причин ! [message #42523 is a reply to message #42513] Tue, 26 April 2011 08:09 Go to previous messageGo to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
sHaggY_caT wrote on Mon, 25 April 2011 23:01
Я бы, если есть возможность,

1) Провела бы тест на _другом_ железе (возьмите просто первый попавшийся PC-к с гигабитным интерфейсом на нормальном чипсете)
2) На текущем остановила все контейнеры, кроме проблемного
3) попробовала бы пересоздать данный контейнер.

В общем, метод исключения рулит)


На другом железе все работает отлично. Проблема в новом железе и в новом ядре. Контейнер всего один. Переустановил его уже раз 100, причем последовательно экспериментировал с настройками контейнера.

Все больше склоняюсь к проблемам ядра (см. выше), апгрейд до 085.5 ничего не дало, ситуация та же.
Re: Тормозит контейнер без видимых причин ! [message #42525 is a reply to message #42523] Tue, 26 April 2011 09:06 Go to previous messageGo to next message
sHaggY_caT is currently offline  sHaggY_caT
Messages: 144
Registered: August 2008
Location: Moscow, Russian Federatio...
Senior Member

From: *p-t-k.net
sHaggY_caT wrote on Mon, 25 April 2011 23:01
Я бы, если есть возможность,

1) Провела бы тест на _другом_ железе (возьмите просто первый попавшийся PC-к с гигабитным интерфейсом на нормальном чипсете)
2) На текущем остановила все контейнеры, кроме проблемного
3) попробовала бы пересоздать данный контейнер.

В общем, метод исключения рулит)


netbyte wrote on Tue, 26 April 2011 04:09

На другом железе все работает отлично.


Вот и вставьте в то железо эти же диски, и посмотрите, что будет


netbyte wrote on Tue, 26 April 2011 04:09

Проблема в новом железе и в новом ядре.


Имхо, это очень просто выяснить эксперементально.

netbyte wrote on Tue, 26 April 2011 04:09

Контейнер всего один. Переустановил его уже раз 100, причем последовательно экспериментировал с настройками контейнера.


Из разных темплейтов?

netbyte wrote on Tue, 26 April 2011 04:09

Все больше склоняюсь к проблемам ядра (см. выше), апгрейд до 085.5 ничего не дало, ситуация та же.


Поставьте, наоборот, несколько старых ядер, с интервалом в пол-года год во времени релиза.


IT-outsource for UNIX servers,
http://ha-systems.ru
Re: Тормозит контейнер без видимых причин ! [message #42526 is a reply to message #42525] Tue, 26 April 2011 09:09 Go to previous messageGo to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
[quote title=sHaggY_caT wrote on Tue, 26 April 2011 13:06]sHaggY_caT wrote on Mon, 25 April 2011 23:01
Поставьте, наоборот, несколько старых ядер, с интервалом в пол-года год во времени релиза.


Да, вот как раз думаю начать с того, что википедии написано:

"ovzkernel-2.6.18-194.8.1.el5.028stab070.4 -- основанная на патчсетах RHEL5.5 ядро. Стабильное, рекомендовано для промышленного использования, поддерживаемое. Основное."

Оно правда от 27 августа прошлого года, но если оно работает ... да будет мне щастье ! Прямо сразу! Very Happy
Re: Тормозит контейнер без видимых причин ! [message #42603 is a reply to message #42256] Thu, 05 May 2011 17:58 Go to previous messageGo to next message
geomaster
Messages: 4
Registered: April 2011
Junior Member
From: *dynamic.mts-nn.ru
Установка последнего ядра (ovzkernel-2.6.18-238.9.1.el5.028stab089.1) решило проблему. Самба и мускуль теперь будто на стероидах (по сравнению с ядром 85.3)

Ubi nihil, nihil
icon14.gif  Re: Тормозит контейнер без видимых причин ! [message #42614 is a reply to message #42603] Fri, 06 May 2011 13:07 Go to previous messageGo to next message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: *122.245.104.zelenaya.net
geomaster wrote on Thu, 05 May 2011 21:58
Установка последнего ядра (ovzkernel-2.6.18-238.9.1.el5.028stab089.1) решило проблему. Самба и мускуль теперь будто на стероидах (по сравнению с ядром 85.3)


Я в итоге поставил старое ядро и проблема полностью решилась. 83.5 сильно тормозило мускул. Самбу не пользовал на этом ядре.

Хммм ... ладно, спасибо за информацию! Попробую поюзать 9.1 Smile
Re: Тормозит контейнер без видимых причин ! [message #42703 is a reply to message #42614] Thu, 12 May 2011 21:31 Go to previous messageGo to next message
andreyb is currently offline  andreyb
Messages: 25
Registered: February 2008
Junior Member
From: 89.248.181*
netbyte wrote on Fri, 06 May 2011 17:07

Хммм ... ладно, спасибо за информацию! Попробую поюзать 9.1 Smile

И каков результат?
Re: Тормозит контейнер без видимых причин ! [message #42708 is a reply to message #42703] Fri, 13 May 2011 11:39 Go to previous message
netbyte is currently offline  netbyte
Messages: 13
Registered: March 2011
Location: ул. Доваторце...
Junior Member
From: 83.239.90*
Да пока никакой: я в отпуске.
Previous Topic: Использование процессорного времени.
Next Topic: CENTOS - какую версию ядра ovzkernel МОЖНО использовать ?
Goto Forum:
  


Current Time: Fri Aug 23 06:28:54 GMT 2019