OpenVZ Forum


Home » International » French » Acquérir une IP par un serveur DHCP dans un VE ? (Possible ou pas ? ou comment arriver à entrer un VE dans les equipement d'une livebox )
Acquérir une IP par un serveur DHCP dans un VE ? [message #41541] Sun, 06 February 2011 14:49 Go to next message
JMaN is currently offline  JMaN
Messages: 1
Registered: February 2011
Location: /France/Bordeaux
Junior Member
From: *w86-210.abo.wanadoo.fr
Bonjour à tous et toutes !

Je suis un nouvel utilisateur de OpenVZ et donc nouveaux sur ce forum !

Je me suis monter ce week-end mon petit serveur OpenVZ sur une Debian et j'ai créer ma template pour mes VE sur Gentoo et la arrive le problème auquel je n'avais pas pensé : ma Livebox et son $%!£X de système d'équipements.

Pour ceux qui ne connaissent pas, la Livebox enregistre les machines sur le réseau après une attribution d'IP par le serveur DHCP de la Livebox. Ce qui permet par la suite de faire différentes configurations plus ou moins utiles comme le forward des ports. Et bien sur aucun moyen de déclarer manuellement une machine dans la Livebox (ce serait trop facile sinon ! Mad )

Donc je ne m'étais pas trop occupé de ce problème jusqu'à y être confronter, et la je ne vois pas comment faire et en cherchant un peu je n'ai pas l'impression que ce soit possible.

Donc si quelqu'un à une solution ce serait vraiment sympathique !

J'imagine qu'en faisant un spoof MAC Address je doit pouvoir finter le système (vue que je pense que la livebox enregistre le noms dns et l'addresse mac pour pouvoir la gérer) mais je doute que cette solution tienne (et en plus visiblement à chaque mise a jours de la LB la config saute ... ca va etre vite lourd donc ...)

Donc pour résumer est il possible d'utiliser une attribution automatique d'IP via un serveur DHCP depuis un VE ?? sinon comment puis-je contourner ce problème ?
Re: Acquérir une IP par un serveur DHCP dans un VE ? [message #42116 is a reply to message #41541] Tue, 01 March 2011 18:10 Go to previous message
nyquist is currently offline  nyquist
Messages: 27
Registered: June 2010
Location: 44 - France
Junior Member
From: *fbx.proxad.net
Salut,

pas simple de te répondre sans livebox et sans le même problème que toi... Ma première intention serai de te dire de mettre ta livebox en bridge et de t'acheter un VRAI routeur mais c'est peut être un peut facile.

2emement je n'utilise pas les interfaces veth mais du venet qui semble plus simple, je te conseille de jeter un œil a cette page qui te donnera toutes les indications nécessaires :
wiki.openvz.org/Veth#Adding_veth_to_a_CT

en gros :
vzctl set 1060 --netif_add venet1,00:01:2e:2b:16:d2
Configure veth devices: veth1060.1
WARNING: Settings were not saved and will be reset to original values at the next start (use --save flag)
vzctl exec 1060 ifconfig -a
[...]

venet1 Link encap:Ethernet HWaddr 00:01:2e:2b:16:d2
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


bon le DHCP après n'a pas marcher mais je ne suis pas sur d'être dans la config adéquate (et je ne vais pas tous casser pour tester).
Personnellement je préfère les IP fixes Smile

PS : il y a un lien vers la mailing list dans le lien que je t'ai donné qui parle de dhcp dans un conteneur avec dhclient

openvz.org/pipermail/users/2005-November/000020.html
Previous Topic: partitions dans un VE
Next Topic: Auto Eth0 ne fonctionne plus après Mise à jour
Goto Forum:
  


Current Time: Wed Oct 17 13:35:58 GMT 2018