OpenVZ Forum


Home » International » German » IP-forwarding off after kernel update
icon8.gif  IP-forwarding off after kernel update [message #36569] Wed, 01 July 2009 13:08 Go to next message
Gabor_Laszlo is currently offline  Gabor_Laszlo
Messages: 11
Registered: October 2008
Location: Munich, Germany
Junior Member
From: *customer.m-online.net
After updating linux-image-2.6.26-2-openvz-amd64 from 2.6.26-15lenny3 to 2.6.26-17 and rebooting the HN, /proc/sys/net/ipv4/ip_forward was on 0. Doing
echo 1 > /proc/sys/net/ipv4/ip_forward
fixed it in a hurry, but this should NOT happen.

[Updated on: Wed, 01 July 2009 13:09]

Report message to a moderator

Re: IP-forwarding off after kernel update [message #36571 is a reply to message #36569] Wed, 01 July 2009 13:23 Go to previous messageGo to next message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: 80.122.194*
Hi,

You are posting in the German part of the forum?

@Topic:

Sorry, but I think you should review your /etc/sysctl.conf settings!

This file is usually read at startup and should have the following content -> http://wiki.openvz.org/Quick_installation#sysctl

There you can set your parameter "net.ipv4.ip_forward = 1".

Could it be, that there was an update from your distribution? Are you using a central management software like puppet ore cfenginge which watch for changes on this file?

Regards,

Mario

[Updated on: Wed, 01 July 2009 13:23]

Report message to a moderator

Re: IP-forwarding off after kernel update [message #36575 is a reply to message #36571] Wed, 01 July 2009 14:26 Go to previous messageGo to next message
Gabor_Laszlo is currently offline  Gabor_Laszlo
Messages: 11
Registered: October 2008
Location: Munich, Germany
Junior Member
From: *customer.m-online.net
Hmm, this was part of the regular system update it's possible some other pkg messed with the sysctl.conf...
Re: IP-forwarding off after kernel update [message #36576 is a reply to message #36575] Wed, 01 July 2009 14:53 Go to previous message
notbuu is currently offline  notbuu
Messages: 34
Registered: June 2009
Member
From: 80.122.194*
Maybe this was the problem.....

Cu, Mario
Previous Topic: vzyum error
Next Topic: del
Goto Forum:
  


Current Time: Fri Sep 21 21:25:28 GMT 2018