OpenVZ Forum


Home » International » Russian » 2 Линка, надо пробросить по роутингу.
2 Линка, надо пробросить по роутингу. [message #36319] Tue, 09 June 2009 21:07 Go to next message
ItMan is currently offline  ItMan
Messages: 3
Registered: June 2009
Junior Member
From: *rev.domonet.ru
Ситуация:

HN имеет 2 линка:
eth0. Хаб - 10.0.10.1 (100 Mbit)
eth1. Файловый сервер NFS - 10.0.10.40 (1Gbs)

На HN машине все как нужно. Для связи с файлом сервером идем через eth1, а со всем остальным по eth0.

В любой VPS работает все, кроме 10.0.10.40. Такое ощущение, что его не пускают по eth1.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

10.0.10.160   *               255.255.255.255 UH    0      0        0 venet0
10.0.10.181   *               255.255.255.255 UH    0      0        0 venet0
10.0.10.180   *               255.255.255.255 UH    0      0        0 venet0
10.0.10.171   *               255.255.255.255 UH    0      0        0 venet0
10.0.10.170   *               255.255.255.255 UH    0      0        0 venet0
10.0.10.0     *               255.255.255.192 U     0      0        0 eth1
10.0.10.0     *               255.255.255.0   U     0      0        0 eth0
default         10.0.10.1     0.0.0.0         UG    0      0        0 eth0




Возможно eth1 выделить в отдельную сеть. В ней заработает?
Куда рыть?

Re: 2 Линка, надо пробросить по роутингу. [message #36320 is a reply to message #36319] Tue, 09 June 2009 21:13 Go to previous messageGo to next message
ItMan is currently offline  ItMan
Messages: 3
Registered: June 2009
Junior Member
From: *rev.domonet.ru
Если выделить в отдельную сеть, то ситуация точно такая же.

Re: 2 Линка, надо пробросить по роутингу. [message #36321 is a reply to message #36320] Tue, 09 June 2009 23:52 Go to previous message
ItMan is currently offline  ItMan
Messages: 3
Registered: June 2009
Junior Member
From: *rev.domonet.ru
Помогло создать мост и воткнуть в них.

Проблема была с ARP он попадал в таблицу при запроса из VE и через некоторое время отваливался. Победить так и не удалось.

Перешел на veth + vzbr0 все само завелось.
Previous Topic: Сеть не работает на VE
Next Topic: [extreme kernel: ioctl32] Unknown cmd fd
Goto Forum:
  


Current Time: Mon Jun 24 14:16:28 GMT 2019