OpenVZ Forum


Home » General » Support » limitation on useradd
limitation on useradd [message #35681] Wed, 15 April 2009 05:26 Go to next message
lonea is currently offline  lonea
Messages: 2
Registered: April 2009
Junior Member
From: *dsl.teksavvy.com
I am getting this issue when trying to do a useradd

The quotauidlimit is already set at 1000 and the VPS has been rebooted.

Anybody got any ideas ?

# UBC parameters (in form of barrier:limit)
# Primary parameters
AVNUMPROC="40:40"
NUMPROC="999999:999999"
NUMTCPSOCK="7999992:7999992"
NUMOTHERSOCK="7999992:7999992"
VMGUARPAGES="640000:2147483647"
# Secondary parameters
KMEMSIZE="2147483646:2147483646"
TCPSNDBUF="524288000:706314240"
TCPRCVBUF="524288000:706314240"
OTHERSOCKBUF="524288000:706314240"
DGRAMRCVBUF="524288000:706314240"
OOMGUARPAGES="640000:2147483647"
# Auxiliary parameters
LOCKEDPAGES="999999:999999"
SHMPAGES="640000:640000"
PRIVVMPAGES="896000:896000"
NUMFILE="23999976:23999976"
NUMFLOCK="999999:999999"
NUMPTY="500000:500000"
NUMSIGINFO="999999:999999"
DCACHESIZE="2147483646:2147483646"

PHYSPAGES="0:2147483647"
NUMIPTENT="1000:1000"

# Disk quota parameters (in form of softlimit:hardlimit)
DISKSPACE="204800000:204800000"
DISKINODES="102400000:102400000"
QUOTATIME="0"

# CPU fair sheduler parameter
CPUUNITS="1000"
VE_ROOT="/vz/root/$VEID"
VE_PRIVATE="/home/$VEID"
OSTEMPLATE="centos-5-i386-cPanel-11.23.x"
ORIGIN_SAMPLE="vps.basic"
IP_ADDRESS=""
QUOTAUGIDLIMIT="1000"
HOSTNAME=""
NAMESERVER="4.2.2.1 4.2.2.2"
CPULIMIT="400"
MEMINFO="pages:896000"
IPTABLES="ip_tables iptable_filter iptable_mangle ipt_limit ipt_multiport ipt_tos ipt_TOS ipt_REJECT ipt_TCPMSS ipt_tcpmss ipt_ttl ipt_LOG ipt_length ip_conntrack ip_conntrack_ftp ipt_state iptable_nat ip_nat_ftp "




Quote:

useradd a
Setting mailbox file permissions: Disk quota exceeded




df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/simfs            196G  106G   91G  54% /



df -i
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/simfs           60422584 3436088 56986496    6% /


cat /etc/passwd  | wc
    284     298   17884


Re: limitation on useradd [message #35711 is a reply to message #35681] Thu, 16 April 2009 13:00 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
From: *sw.ru
Hello,

Quote:


I am getting this issue when trying to do a useradd


the problem occurs after adding QUOTAUGIDLIMIT variable, doesn't it? And if the second-level quota is off this problem doesn't occur, doest it?

Does the problem go away if the QUOTAUGIDLIMIT variable is set to the value that is more than 1000?


Re: limitation on useradd [message #35715 is a reply to message #35711] Thu, 16 April 2009 20:02 Go to previous messageGo to next message
lonea is currently offline  lonea
Messages: 2
Registered: April 2009
Junior Member
From: *dsl.teksavvy.com
Well, what I did is set the limit to 3000 and the shut off the vps then restart the vz service completely on the main node. then it started working again...

so not completely sure if it was the actual limit or the vz didnt recognized the new limit from the first restart
Re: limitation on useradd [message #51058 is a reply to message #35681] Mon, 13 January 2014 21:50 Go to previous message
bbrown is currently offline  bbrown
Messages: 1
Registered: January 2014
Junior Member
From: *cdrr.qwest.net
We have a VPS with HostGator and were getting this same error about quota from /usr/sbin/useradd. I found this thread helpful in identifying the problem. However, quotaugidlimit had to be set on the physical node and the machine restarted. This was not an environment variable that could be set in the VPS using WHM but rather something that the hosting company had to assign. This might be obvious to members of this forum, but it wasn't to me when a search brought me here. Thought I'd share in case it smooths the path for the next stumbler.
Previous Topic: Backing up OpenVZ important files
Next Topic: SLIP module
Goto Forum:
  


Current Time: Thu Sep 20 00:50:55 GMT 2018