OpenVZ Forum


Home » International » German » eth0 Konfiguration nach reboot weg
eth0 Konfiguration nach reboot weg [message #35435] Wed, 25 March 2009 12:15 Go to next message
mh04 is currently offline  mh04
Messages: 1
Registered: March 2009
Junior Member
From: 94.245.219*
Hallo!

Ich habe auf meinen Instanzen standard venet Devices.
Zusätzlich hab ich für jede Instanz noch ein veth angelegt (=eth0 auf der Instanz).

Ich will jeder Instanz noch eine interne IP geben.

Konfiguriert hab ich ich lt. OpenVZ-Wiki:

Configure devices in CT0
[host-node]# ifconfig veth101.0 0
[host-node]# echo 1 > /proc/sys/net/ipv4/conf/veth101.0/forwarding
[host-node]# echo 1 > /proc/sys/net/ipv4/conf/veth101.0/proxy_arp
[host-node]# echo 1 > /proc/sys/net/ipv4/conf/eth0/forwarding
[host-node]# echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp

Configure device in CT
[host-node]# vzctl enter 101
[ve-101]# ifconfig eth0 10.250.1.247
[ve-101]# ....meine route....

Nach einem Reboot sind die Einstellungen allerdings verflogen.

Ich habe ebenso versucht in der /etc/network/interfaces die Einstellungen vorzunehmen, allerdings ist nach dem Reboot ebenso alles weg.

Wenn ich "IP_ADDRESS=""" in der 101.conf entferne, wird die Konfig nicht überschrieben, allerdings funktioniert mein venet Interface nicht.

Ich kenn mich leider noch nicht so gut aus mit OpenVZ, gibts eine Möglichkeit mein venet zu behalten und zusätzlich mein veth (eth0) manuell in der /etc/network/interfaces zu konfigurieren, so dass das Interface nach einem Neustart die Einstellungen nicht verliert?

Danke.

lg

edit:
falls wichtig: verwende vzctl 3.0.23 und 2.6.26-1-openvz-686

edit 2:
problem gelöst mit interfaces.template

[Updated on: Wed, 25 March 2009 22:43]

Report message to a moderator

Re: eth0 Konfiguration nach reboot weg [message #35599 is a reply to message #35435] Wed, 08 April 2009 00:05 Go to previous message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *sys3.org
Hi,

warum venet(work) und veth(net) gleichzeitig nutzen ?

Alle veth Einstellungen werden nicht über den vzctl Befehl eingestellt, sondern müssen immer per Hand/script neu gesetzt werden.
(siehe -> http://wiki.openvz.org/Veth#Making_a_veth-device_persistent )

Setzt du die venet Netzwerk Einstellungen, wird beim Start des Containers die Default Route/IP gesetzt, wenn keine IP in der Container Konfig eingetragen, werden auch keine Netzwerk Konfigurationen gesetzt.

Gruß,
Thorsten
Previous Topic: OpenVZ Kernel 2.6.18-14 erkennt eth0 nicht
Next Topic: Einsteigerfrage: Verzeichnisse verschieben, vzquota
Goto Forum:
  


Current Time: Tue Nov 20 08:13:47 GMT 2018