OpenVZ Forum


Home » International » French » Problème de réseau entre machines virtuelles
icon5.gif  Problème de réseau entre machines virtuelles [message #35079] Wed, 25 February 2009 13:56 Go to next message
kaliban47 is currently offline  kaliban47
Messages: 1
Registered: February 2009
Junior Member
From: *laas.fr
Bonjour,

J'utilise openVz sur Ubuntu 8.04, et je dois créé 8 machines virtuelles. Je n'ai pas eu de problème pour ça, j'ai assigné une adresse IP à chacun, j'ai créé une interface veth pour chacune des machines virtuelles.
Jusque là, la machine physique arrive à envoyer un ping vers les machines virtuelles, mais les machines virtuelles ne peuvent envoyer un ping ni entre elles ni à la machine physique .
Et là je suis bloqué.

J'aurais besoin d'un coup de pouce!
je vous remercie
Adrien
Re: Problème de réseau entre machines virtuelles [message #35433 is a reply to message #35079] Wed, 25 March 2009 11:33 Go to previous messageGo to next message
teflonpo is currently offline  teflonpo
Messages: 3
Registered: February 2009
Junior Member
From: 129.102.242*
Bonjour Adrien,

As-tu essayé de rattacher les interfaces ethernet veth à un pont ethernet que tu configures sur la machine hôte ?
Re: Problème de réseau entre machines virtuelles [message #43331 is a reply to message #35079] Thu, 25 August 2011 12:22 Go to previous message
vinek is currently offline  vinek
Messages: 4
Registered: August 2011
Location: France
Junior Member

From: *dualis.fr
Bonjour,

J'ai un doute sur un point de ta configuration, as tu pensé a bridger tes interfaces pour qu'elles se voient.

Je pense que si tu mets un bridge, tes interfaces devraient se voir.

Pour créer le bridge :

# installation
apt-get install bridge-utils

# ajout d'un bridge
brctl addbr br0

# ajout des interfaces dans le bridge
brctl addif br0 eth0 vethX.0

Une fois fait ton conteneur devrait pinger l'hôte et inversement.


Previous Topic: Montage cifs dans container
Next Topic: Problème réseau
Goto Forum:
  


Current Time: Fri May 26 16:56:26 GMT 2017