OpenVZ Forum


Home » International » German » [Gelöst: ] zweite NIC für VE
[Gelöst: ] zweite NIC für VE [message #34562] Sun, 18 January 2009 11:58 Go to next message
digidax is currently offline  digidax
Messages: 30
Registered: March 2008
Member
From: *celebraterecords.com
Hallo,

auf einer VE möchte ich mit iptables experimentieren um später einen Router mit NAT zu betreiben. eth0 auf dem VH wird als venet0:0 und dem dazugehörigen Subnetz in der VE bereitgestellt. Ping auf die IP der VE sowie von der VE auf eine IP in diesem Netz funktioniert.

Nun habe ich eine zweite NIC eingebaut (eth1), IP in der VH vergeben und eine weitere IP aus diesem neuen Subnetz per --ipadd der VE zugewiesen. In der VE erscheint nun venet0:1 mit der neuen IP.

Ping von VE auf HN (venet0:1 auf eth1) funktioniert.
Ping von einer IP aus Subnetz in der sich eth1 (und venet0:1) befinden auf IP von venet0:1 funktioniert.
Jedoch Ping von venet0:1 auf eine IP (außer eth1) in das neue Subnetz geht nicht. Warum? Müßte nicht eigentlich, da ich über eth1 gehen möchte es venet1:0 heißen?

vlg
Frank

[Updated on: Mon, 26 January 2009 06:46] by Moderator

Report message to a moderator

Gelöst: zweite NIC für VE [message #34570 is a reply to message #34562] Mon, 19 January 2009 07:56 Go to previous message
digidax is currently offline  digidax
Messages: 30
Registered: March 2008
Member
From: *celebraterecords.com
hatte vergessen, das Weiterleiten der Pakete über die neue eth1 ins LAN von der VE zu erlauben:

iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

vlg
Frank
Previous Topic: OpenVZ und IPtables
Next Topic: Problem mit Pound
Goto Forum:
  


Current Time: Mon Sep 16 22:44:43 GMT 2019