OpenVZ Forum


Home » International » Russian » Проблемы с LVM2
Проблемы с LVM2 [message #33998] Mon, 24 November 2008 20:47 Go to next message
Egenius is currently offline  Egenius
Messages: 21
Registered: September 2008
Junior Member
Обновился до ядра 2.6.18-92.1.13.el5.028stab059.6, перегрузил машину и получаю сообщение:
clvmd startup timeout

При этом не монтируется раздел с GFS, а команды vgscan, vgs и clvmd restart зависают в терминале и убиваются только через kill -9.
Посмотрел в лог yum.log и обнаружил что вместе с ядром обновился и пакет lvm2. Как всё вернуть в рабочее состояние ?
Помогите решить проблему !!!

PS. Понимаю что пишу не совсем в тот форум, но здесь всегда дают дельные советы. Надеюсь на вашу помощь.
Re: Проблемы с LVM2 [message #34002 is a reply to message #33998] Tue, 25 November 2008 08:49 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 532
Registered: January 2006
Location: Moscow, Russia
Senior Member
Уж не знаю, насколько совет дельный, но, может, попробовать вернуть обратно пакет lvm2 старый? А потом уже разбираться, почему он обновился и кому это было нужно. Smile

If your problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: Проблемы с LVM2 [message #34048 is a reply to message #34002] Thu, 27 November 2008 17:47 Go to previous messageGo to next message
Egenius is currently offline  Egenius
Messages: 21
Registered: September 2008
Junior Member
К сожалению, откат к предыдущей версии ничего не дал. Не понимаю вообще что происходит. У меня было подозрение что новая версия lvm2 не работает с ядром openvz, но я попробовал загрузиться в родное центовское ядро и получил тот-же результат. Даже не знаю что и делать. (
Re: Проблемы с LVM2 [message #34050 is a reply to message #34048] Thu, 27 November 2008 20:54 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 532
Registered: January 2006
Location: Moscow, Russia
Senior Member
Точно пробуйте сначала всё починить обратно, по-старому.
Ещё раз просмотрите лог yum-а, может, он чего ещё ставил.
Испортиться на файловой системе всё-таки не должно было - не win всё-таки, не будет на лету менять файловую систему при первом запуске...


If your problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: Проблемы с LVM2 [message #34054 is a reply to message #34050] Fri, 28 November 2008 13:12 Go to previous messageGo to next message
Egenius is currently offline  Egenius
Messages: 21
Registered: September 2008
Junior Member
Вот всё что обновил yum перед тем как всё перестало работать
vzquota - 3.0.12-1.x86_64
libxml2 - 2.6.26-2.1.2.7.x86_64
vzctl-lib - 3.0.23-1.x86_64
net-snmp-libs - 1:5.3.1-24.el5_2.2.x86_64
dmraid - 1.0.0.rc13-14.el5_2.1.x86_64
gnutls - 1.4.1-3.el5_2.1.x86_64
lvm2 - 2.02.32-4.el5_2.1.x86_64
nss - 3.12.1.1-3.el5.centos.x86_64
vzctl-lib - 3.0.23-1.i386
gnutls - 1.4.1-3.el5_2.1.i386
vzctl - 3.0.23-1.i386
vzctl - 3.0.23-1.x86_64
net-snmp - 1:5.3.1-24.el5_2.2.x86_64
libxml2-python - 2.6.26-2.1.2.7.x86_64
httpd - 2.2.3-11.el5_2.centos.4.x86_64
tzdata - 2008i-1.el5.noarch
ovzkernel - 2.6.18-92.1.13.el5.028stab059.6.x86_64

Уже перепробовал всё что можно, и грузился с родным ядром и откатил все пакеты, что юм установил, сверял конфиг обновлённого lvm с тем, что был до обновления - результат ноль. Уже и не знаю куда ещё копать.

[Updated on: Fri, 28 November 2008 13:15]

Report message to a moderator

Re: Проблемы с LVM2 [message #34446 is a reply to message #34054] Sat, 03 January 2009 16:35 Go to previous message
sHaggY_caT is currently offline  sHaggY_caT
Messages: 144
Registered: August 2008
Location: Moscow, Russian Federatio...
Senior Member

Если еще актуально, можно попробовать смонтировать раздел на другой физической машине, что бы исключить проблемы с ним.


Egenius wrote on Fri, 28 November 2008 08:12

Вот всё что обновил yum перед тем как всё перестало работать
vzquota - 3.0.12-1.x86_64
libxml2 - 2.6.26-2.1.2.7.x86_64
vzctl-lib - 3.0.23-1.x86_64
net-snmp-libs - 1:5.3.1-24.el5_2.2.x86_64
dmraid - 1.0.0.rc13-14.el5_2.1.x86_64
gnutls - 1.4.1-3.el5_2.1.x86_64
lvm2 - 2.02.32-4.el5_2.1.x86_64
nss - 3.12.1.1-3.el5.centos.x86_64
vzctl-lib - 3.0.23-1.i386
gnutls - 1.4.1-3.el5_2.1.i386
vzctl - 3.0.23-1.i386
vzctl - 3.0.23-1.x86_64
net-snmp - 1:5.3.1-24.el5_2.2.x86_64
libxml2-python - 2.6.26-2.1.2.7.x86_64
httpd - 2.2.3-11.el5_2.centos.4.x86_64
tzdata - 2008i-1.el5.noarch
ovzkernel - 2.6.18-92.1.13.el5.028stab059.6.x86_64

Уже перепробовал всё что можно, и грузился с родным ядром и откатил все пакеты, что юм установил, сверял конфиг обновлённого lvm с тем, что был до обновления - результат ноль. Уже и не знаю куда ещё копать.



IT-outsource for UNIX servers,
http://ha-systems.ru
Previous Topic: scratchbox в VE
Next Topic: Тормоза на виртуальной машине
Goto Forum:
  


Current Time: Fri Feb 03 17:24:29 GMT 2023

Total time taken to generate the page: 0.00840 seconds