OpenVZ Forum


Home » International » French » Probleme de reseau pour les CT
Probleme de reseau pour les CT [message #33608] Fri, 24 October 2008 20:07 Go to next message
thibautm is currently offline  thibautm
Messages: 5
Registered: October 2008
Junior Member
Bonjour,
j'ai une dedibox pro avec la distrib lenny (update a partir de debian etch) avec le kernel 2.6.24-6-fza-amd64

Je souhaiterai avoir la config suivante:
HN: Accessible depuis l'extérieur juste sur les ports pour ssh et webz pour l'administration

CT 101: puisse disposer de 1 (voir 2) adresse public soit une interface eth1 par exemple, afin d'y installer un panel pour mes sites web (dtc-admin ou virtualmin)
+ dialogue possible avec les autres VE
J'aimerai pouvoir l'administrer comme si c'était mon serveur principal donc les ports pour le web, mail, dns accessible directement

pour cela j'ai teste: vzctl set 101 --netdev_add eth1 --save

l'initialisation parait bien se passer tout se configure normalement, mais bon je n'ai pas de reseau dans la VE 101


CT 10* : utilise pour separer les services: ex mysql, mail, dns... donc accessible en local , plus NAT des ports utiles suivant les services

Elles doivent pouvoir dialoguer avec CT 101 (VE principale)


Donc pour recapitulser je n'ai que deux ip public chacune liée a une interface (eth0 et eth1), et j'aimerai les utiliser pour ma VE principale (serveur web) et pour les autres en faisant du nat sur certain ports

Est-ce possible une telle configuration? et Avez-vous des pistes?


ps: sur dedibox , je ne peux pas faire de bridge.

Merci d'avance
Thibaut
Re: Probleme de reseau pour les CT [message #33722 is a reply to message #33608] Mon, 03 November 2008 16:16 Go to previous message
jeff0210 is currently offline  jeff0210
Messages: 4
Registered: September 2008
Location: French
Junior Member
Bonjour Thibaut,

Après lecture de ton message j'ai remarqué :

vzctl set 101 --netdev_add eth0 --save

essaye plutôt avec la commande :
vzctl set 101 --netif_add eth1 --save

en suite contrôle que dans fichier de conf du VE tu dois avoir la ligne suivante à la fin du fichier :
netif= eth0 .... / veth101.0 .....

Normalement en suite su tu démarres le VE, tu peux contrôler avec ifconfig sur ton serveur hôte (HN) que l'interface veth101.0 est up.

Maintenant tu rentres dans la VE avec la cmde :
HN# vzctl enter VEID

une fois dans le VE
VE# ifconfig eth0 up

tu dois avoir ton interface eth0 démarré, soit tu la paramètres avec la cmde ip ou le fichier /etc/network/interface

Pour le reste de ta configuration j'ai pas tout compris désolé.

Bonne fin de journée,
à bientôt.


OS : Ubuntu hardy heron (2.6.24-19)
OPenVZ version : 3.022
Et vive la virtualisation
Previous Topic: Redémarrer le VPS + Maj Plesk
Next Topic: Problème suppression serveur virtuel
Goto Forum:
  


Current Time: Thu Dec 01 16:52:04 GMT 2022

Total time taken to generate the page: 0.01884 seconds