OpenVZ Forum


Home » International » French » OpenVZ sur CentOS 5.0/OVH
OpenVZ sur CentOS 5.0/OVH [message #30582] Thu, 29 May 2008 09:21 Go to next message
uneame is currently offline  uneame
Messages: 2
Registered: May 2008
Junior Member
Bonjour,

J'ai installer un serveur pré-configuré avec OpenVZ de chez OVH et j'ai des problème avec le reseau. mon VPS ping l'hote mais l'inverse ne fonctionne pas (l'hote ne ping pas le VPS)

l'hote à 2 adresse (eth0 & eth0:1), l'une publique l'autre privée (meme zone d'adresse que le VPS)

SUR la MACHINEHOTE

/etc/sysctl
Quote:

# Kernel sysctl configuration file for Red Hat Linux
#
# For binary values, 0 is disabled, 1 is enabled. See sysctl(Cool and
# sysctl.conf(5) for more details.

# Controls IP packet forwarding
net.ipv4.ip_forward = 1
net.ipv4.conf.default.proxy_arp = 0
# Controls source route verification
net.ipv4.conf.default.rp_filter = 1

# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0

# Controls the System Request debugging functionality of the kernel
kernel.sysrq = 1

# Controls whether core dumps will append the PID to the core filename
# Useful for debugging multi-threaded applications
kernel.core_uses_pid = 1

# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1

# Controls the maximum size of a message, in bytes
kernel.msgmnb = 65536

# Controls the default maxmimum size of a mesage queue
kernel.msgmax = 65536

# Controls the maximum shared segment size, in bytes
kernel.shmmax = 4294967295

# Controls the maximum number of shared memory segments, in pages
kernel.shmall = 268435456

net.ipv4.conf.default.send_redirects = 1
net.ipv4.conf.all.send_redirects = 0



Quote:

MACHINEHOTE:~# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:19:D1:AE:E8:E7
inet addr:xxx.xxx.xxx.yyy; Bcast:91.121.87.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3698 errors:0 dropped:0 overruns:0 frame:0
TX packets:1863 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:311828 (304.5 KiB) TX bytes:181189 (176.9 KiB)
Interrupt:220

MACHINEHOTE:~# ifconfig eth0:1
eth0:1 Link encap:Ethernet HWaddr 00:19:D1:AE:E8:E7
inet addr:192.168.1.1 Bcast:192.168.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:220

MACHINEHOTE:~# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3010ms

MACHINEHOTE:~#


Quote:

ns352797:~# /sbin/route add -net 192.168.0.0 netmask 255.255.0.0 gw 192.168.1.1
ns352797:~# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
35 packets transmitted, 0 received, 100% packet loss, time 34010ms

MACHINEHOTE:~# /sbin/route add -net 192.168.0.0 netmask 255.255.0.0 gw 91.121.87.151
MACHINEHOTE:~# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
13 packets transmitted, 0 received, 100% packet loss, time 12010ms



Quote:


MACHINEHOTE:~# vzlist
VEID NPROC STATUS IP_ADDR HOSTNAME
101 3 running 192.168.0.1 -

MACHINEHOTE:~#



SUR le VPS
Quote:

entered into VE 101
root@localhost:/# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.035 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.014 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.014 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.014 ms

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2998ms
rtt min/avg/max/mdev = 0.014/0.019/0.035/0.009 ms


[Updated on: Thu, 29 May 2008 09:26]

Report message to a moderator

Re: OpenVZ sur CentOS 5.0/OVH [message #30583 is a reply to message #30582] Thu, 29 May 2008 09:56 Go to previous message
uneame is currently offline  uneame
Messages: 2
Registered: May 2008
Junior Member
J'ai finalement trouvé la solution sur le forum. le problème venait du fait que les subnets ne sont pas identiques 192.168.0.XXX
et 192.168.1.xxx bien qu'avec mon netmask à 255.255.0.0 il devrait etre reconu comme faisant parti du meme reseau. En utilisant l'un des deux le ping fonctionne dans les deux sens.

voila le post qui ma mi sur la voie http://forum.openvz.org/index.php?t=tree&th=6015&mid =29850&&rev=&reveal=

Previous Topic: Configuration réseau
Next Topic: Openvz kernel
Goto Forum:
  


Current Time: Thu Dec 01 15:46:25 GMT 2022

Total time taken to generate the page: 0.01792 seconds