OpenVZ Forum


Home » Mailing lists » Users » VLAN bug with 2.6.24
VLAN bug with 2.6.24 [message #30019] Tue, 06 May 2008 11:02 Go to next message
dietmar is currently offline  dietmar
Messages: 54
Registered: March 2007
Member
From: openvz.org
Tested wit openvz 2.6.24 from git and debian etch.

We normaly use a bridged network config (/etc/network/interfaces):

-------------------
auto vmbr0
iface vmbr0 inet static
        address  192.168.1.2
        netmask  255.255.255.0
        gateway  192.168.1.1
        bridge_ports eth0 
-------------------

To add vlan support we do (VLAN 5):

-------------------
auto vmbr0
iface vmbr0 inet static
        address  192.168.1.2
        netmask  255.255.255.0
        gateway  192.168.1.1
        bridge_ports eth0.5 
-------------------

This does not work on all machine we tested, and if we issue:

> vconfig add eth0 6

Network freezes on all machines tested. 

Ubuntu kernel (8.04 server) with the same hardware worked perfectly.

Andy idea whats wrong? Can somebody else reproduce the bug?

- Dietmar
AW: VLAN bug with 2.6.24 [message #30023 is a reply to message #30019] Tue, 06 May 2008 12:07 Go to previous message
dietmar is currently offline  dietmar
Messages: 54
Registered: March 2007
Member
From: openvz.org
Just tested with ubuntu server 8.04. Standard server kernel works, but with openvz kernel vlan does not work:

linux-image-2.6.24-17-openvz_2.6.24-17.31_amd64.deb 

- Dietmar


> -----Ursprüngliche Nachricht-----
> Von: users-bounces@openvz.org 
> [mailto:users-bounces@openvz.org] Im Auftrag von Dietmar Maurer
> Gesendet: Dienstag, 06. Mai 2008 13:03
> An: users@openvz.org
> Cc: James Oakley
> Betreff: [Users] VLAN bug with 2.6.24
> 
> Tested wit openvz 2.6.24 from git and debian etch.
Previous Topic: OpenVZ template confusion
Next Topic: GFS2 version?
Goto Forum:
  


Current Time: Tue Jul 23 12:10:01 GMT 2019