OpenVZ Forum


Home » Mailing lists » Users » 32bit vztools and 64bit kernel
32bit vztools and 64bit kernel [message #29687] Mon, 21 April 2008 14:42 Go to next message
Alexander GQ Gerasiov is currently offline  Alexander GQ Gerasiov
Messages: 8
Registered: April 2008
Junior Member
From: openvz.org
Hello again.

I'm experimenting with openvz and found one more issue.
I'm using 32bit system Debian Lenny i386. Kernel compiled for i686
processor with vz-tools for i386 arch works ok, but when I tried to
boot into x86_64 kernel (with the same 32bit userspace) vztools said
strange things:

root@vice:~# ls /var/lib/vzquota/
root@vice:~# vzctl --verbose start 1001
Starting VE ...
Initializing quota ...
VE is mounted
Error: kernel does not support user resources. Please, rebuild with
CONFIG_USER_RESOURCE=y
VE start failed
Received signal:  11 in /usr/sbin/vzquota
Error: Unable to apply new quota values quota not running
Received signal:  11 in /usr/sbin/vzquota
VE is unmounted

If I turn off vz's disk quotas I see

root@vice:~# vzctl --verbose start 1001
Starting VE ...
Initializing quota ...
VE is mounted
Error: kernel does not support user resources. Please, rebuild with
CONFIG_USER_RESOURCE=y
VE start failed
VE is unmounted


So I see 3 problems here:
1st. vzquota segfaults. Not really bad, but looks dirty a bit.
2nd. vzctl says something about CONFIG_USER_RESOURCE which is no longer
used as I can see (It's absent in any Kconfig, but still used in tcp
code patched with openvz patch)
3d. Finally 32bit userspace doesn't work with 64bit kernel. That's
terrible %)

Am I right? How should I submit it to bugzilla? 3 different bugs or a
single one?

-- 
Best regards,
 Alexander GQ Gerasiov

 Contacts:
 e-mail:    gq@cs.msu.su             Jabber:  gq@jabber.ru
 Homepage:  http://gq.net.ru         ICQ:     7272757
 PGP fingerprint: 0628 ACC7 291A D4AA 6D7D  79B8 0641 D82A E3E3 CE1D
Re: 32bit vztools and 64bit kernel [message #29688 is a reply to message #29687] Mon, 21 April 2008 14:53 Go to previous messageGo to next message
Alexander GQ Gerasiov is currently offline  Alexander GQ Gerasiov
Messages: 8
Registered: April 2008
Junior Member
From: openvz.org
Mon, 21 Apr 2008 18:42:40 +0400
Alexander GQ Gerasiov <gq@cs.msu.su> wrote:

> I'm experimenting with openvz and found one more issue.
> I'm using 32bit system Debian Lenny i386. Kernel compiled for i686
> processor with vz-tools for i386 arch works ok, but when I tried to
> boot into x86_64 kernel (with the same 32bit userspace) vztools said
 
gq@vice:~/adm/linux-source/linux-2.6$ /usr/sbin/vzctl --version
vzctl version 3.0.22

gq@vice:~/adm/linux-source/linux-2.6$ /usr/sbin/vzquota --version
Vzquota version 2.5.0
hmmm... strange, It's 3.0.11-1 package. Btw, I tried 3.0.12 from git
with the same result.

gq@vice:~/adm/linux-source/linux-2.6$ uname -a
Linux vice 2.6.24-1-openvz-amd64 #1 SMP Tue Apr 15 19:42:34 GMT 2008
x86_64 GNU/Linux



-- 
Best regards,
 Alexander GQ Gerasiov

 Contacts:
 e-mail:    gq@cs.msu.su             Jabber:  gq@jabber.ru
 Homepage:  http://gq.net.ru         ICQ:     7272757
 PGP fingerprint: 0628 ACC7 291A D4AA 6D7D  79B8 0641 D82A E3E3 CE1D
Re: 32bit vztools and 64bit kernel [message #29696 is a reply to message #29687] Mon, 21 April 2008 18:21 Go to previous message
Kirill Korotaev is currently offline  Kirill Korotaev
Messages: 137
Registered: January 2006
Senior Member
From: openvz.org
yes. it's known incompatibility. plz use 64bit tools with 64bit kernel.
there was a bug, but it's low priority, since not critical/major one.


Alexander GQ Gerasiov wrote:
> Hello again.
> 
> I'm experimenting with openvz and found one more issue.
> I'm using 32bit system Debian Lenny i386. Kernel compiled for i686
> processor with vz-tools for i386 arch works ok, but when I tried to
> boot into x86_64 kernel (with the same 32bit userspace) vztools said
> strange things:
> 
> root@vice:~# ls /var/lib/vzquota/
> root@vice:~# vzctl --verbose start 1001
> Starting VE ...
> Initializing quota ...
> VE is mounted
> Error: kernel does not support user resources. Please, rebuild with
> CONFIG_USER_RESOURCE=y
> VE start failed
> Received signal:  11 in /usr/sbin/vzquota
> Error: Unable to apply new quota values quota not running
> Received signal:  11 in /usr/sbin/vzquota
> VE is unmounted
> 
> If I turn off vz's disk quotas I see
> 
> root@vice:~# vzctl --verbose start 1001
> Starting VE ...
> Initializing quota ...
> VE is mounted
> Error: kernel does not support user resources. Please, rebuild with
> CONFIG_USER_RESOURCE=y
> VE start failed
> VE is unmounted
> 
> 
> So I see 3 problems here:
> 1st. vzquota segfaults. Not really bad, but looks dirty a bit.
> 2nd. vzctl says something about CONFIG_USER_RESOURCE which is no longer
> used as I can see (It's absent in any Kconfig, but still used in tcp
> code patched with openvz patch)
> 3d. Finally 32bit userspace doesn't work with 64bit kernel. That's
> terrible %)
> 
> Am I right? How should I submit it to bugzilla? 3 different bugs or a
> single one?
>
Previous Topic: [SOLVED] openvz kernel hangs on fujitsu-siemens blade rack
Next Topic: Change IP address inside VE
Goto Forum:
  


Current Time: Fri Nov 16 14:35:53 GMT 2018