OpenVZ Forum


Home » General » Discussions » I can't use Grub and LILO problems with debian OpenVZ packages
I can't use Grub and LILO problems with debian OpenVZ packages [message #28261] Wed, 12 March 2008 17:22 Go to next message
fenzen is currently offline  fenzen
Messages: 7
Registered: March 2008
Location: Madrid (Spain)
Junior Member

From: *Red-83-45-221.dynamicIP.rima-tde.net
I can't use grub bootloader.

I like install ovzkernel-2.6.18-smp or fzakernel-2.6.18-686 but get errors because post-scriopts install.

How can get any solution?

Debian Etch 4.0

Using mkinitramfs-kpkg to build the ramdisk.
Could not find postinst hook script [update-grub].
Looked in: '/bin', '/sbin', '/usr/bin', '/usr/sbin'
dpkg: error al procesar linux-image-2.6.18-fza-028stab053.5-686 (--configure):
 el subproceso post-installation script devolvi? el c?digo de salida de error 2
dpkg: problemas de dependencias impiden la configuraci?n de fzakernel-2.6.18-686:
 fzakernel-2.6.18-686 depende de linux-image-2.6.18-fza-028stab053.5-686; sin embargo:
 El paquete `linux-image-2.6.18-fza-028stab053.5-686' no est? configurado todav?a.
dpkg: error al procesar fzakernel-2.6.18-686 (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 linux-image-2.6.18-fza-028stab053.5-686
 fzakernel-2.6.18-686
E: Sub-process /usr/bin/dpkg returned an error code (1)


Carpe Diem...
Re: I can't use Grub and LILO problems with debian OpenVZ packages [message #28280 is a reply to message #28261] Thu, 13 March 2008 06:33 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hola,

* which bootloader is used boot a linux kernel on this server ?
* is lilo and/or grub installed ?

Re: I can't use Grub and LILO problems with debian OpenVZ packages [message #28285 is a reply to message #28280] Thu, 13 March 2008 08:19 Go to previous messageGo to next message
fenzen is currently offline  fenzen
Messages: 7
Registered: March 2008
Location: Madrid (Spain)
Junior Member

From: *Red-83-45-221.dynamicIP.rima-tde.net
LILO because system onf netboot and other tools of my ISP (OVH) are imcopatible wuth Grub

Carpe Diem...
Re: I can't use Grub and LILO problems with debian OpenVZ packages [message #28287 is a reply to message #28285] Thu, 13 March 2008 08:57 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *bisping.net
Please check /etc/kernel-img.conf;
update the postinst_hook and postrm_hook to update-lilo.
Re: I can't use Grub and LILO problems with debian OpenVZ packages [message #28289 is a reply to message #28287] Thu, 13 March 2008 09:01 Go to previous message
fenzen is currently offline  fenzen
Messages: 7
Registered: March 2008
Location: Madrid (Spain)
Junior Member

From: *Red-83-45-221.dynamicIP.rima-tde.net
Ooopsss

A lot of thanks


Carpe Diem...
Previous Topic: OpenVZ LiveCD with HDD support
Next Topic: High numiptent, any problems?
Goto Forum:
  


Current Time: Sat Dec 15 04:57:15 GMT 2018