OpenVZ Forum


Home » Mailing lists » Users » vzyum and Fedora 7+, Python 2.5 workaround anyone?
vzyum and Fedora 7+, Python 2.5 workaround anyone? [message #25504] Thu, 27 December 2007 21:29 Go to next message
mhw is currently offline  mhw
Messages: 12
Registered: March 2007
Junior Member
From: openvz.org
Hey all,

	There's a problem with vzyum on Fedora 7 or Fedora 8 due to Python 2.5.
This is the error:

ERROR: RPM python path not
found: /usr/share/vzpkgtools/vzrpm44/lib/python2.5/site-packages

	Looking in /usr/share/vzpkgtools/vzrpm4[34]/lib/ there is support only
for python2.3 and python2.4 and not python2.5.

	This is already been reported in bugzilla a couple of times, bugs 649
and dup 656.

	Anyone got any suggestions for workarounds?  I'm getting ready to
manually install yum (which is a pain and maybe I should have installed
yum into them all when I could still run vzyum) into each of my VMs
since I can't update anything in any of them as is.

	Mike
-- 
Michael H. Warfield (AI4NB) | (770) 985-6132 |  mhw@WittsEnd.com
   /\/\|=mhw=|\/\/          | (678) 463-0932 |  http://www.wittsend.com/mhw/
   NIC whois: MHW9          | An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471        | possible worlds.  A pessimist is sure of it!


--==
Re: vzyum and Fedora 7+, Python 2.5 workaround anyone? [message #25530 is a reply to message #25504] Sat, 29 December 2007 06:40 Go to previous message
Cliff Wells is currently offline  Cliff Wells
Messages: 30
Registered: June 2006
Member
From: openvz.org
On Thu, 2007-12-27 at 16:29 -0500, Michael H. Warfield wrote:
> Hey all,
> 
> 	There's a problem with vzyum on Fedora 7 or Fedora 8 due to Python 2.5.
> This is the error:
> 
> ERROR: RPM python path not
> found: /usr/share/vzpkgtools/vzrpm44/lib/python2.5/site-packages
> 
> 	Looking in /usr/share/vzpkgtools/vzrpm4[34]/lib/ there is support only
> for python2.3 and python2.4 and not python2.5.
> 
> 	This is already been reported in bugzilla a couple of times, bugs 649
> and dup 656.
> 
> 	Anyone got any suggestions for workarounds?  I'm getting ready to
> manually install yum (which is a pain and maybe I should have installed
> yum into them all when I could still run vzyum) into each of my VMs
> since I can't update anything in any of them as is.

Might I suggest Smart instead?  Frankly I can't see how anyone can stand
to use Fedora with yum (or even apt-rpm).  Smart is faster, has better
dependency resolution and can often fix the cyclic dependency hell
created by yum or apt-rpm (unlike those two package managers, smart can
intelligently downgrade packages as well).

I've fixed many a FC box that would have normally required an hour of
manually replacing RPM's with a simple "smart fix".

Usually you can just do "yum install smart" after a fresh Fedora
install, but if yum is broken, just install the smart rpm and the smart
config rpms from here:

FC8:
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/Packages/smart-0.51-49.fc8.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/Packages/fedora-package-config-smart-8-10.i386.rpm


FC7:
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/Fedora/smart-0.50-45.fc7.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/Fedora/fedora-package-config-smart-6.89-7.i386.rpm


Regards,
Cliff
Previous Topic: FC7
Next Topic: *SOLVED* no internet inside ve
Goto Forum:
  


Current Time: Sun Sep 22 16:14:25 GMT 2019