OpenVZ Forum


Home » Mailing lists » Users » Live Migration Fails
Live Migration Fails [message #25400] Sat, 22 December 2007 14:53 Go to next message
parturi is currently offline  parturi
Messages: 10
Registered: April 2006
Junior Member
From: openvz.org
Hello guys, does anyone knows why while trying to migrate a VE I get this
error?

root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251 111
OPT:-r
OPT:--online
OPT:--keep-dst
OPT:-v
OPT:10.0.10.251
Starting online migration of VE 111 on 10.0.10.251
OpenVZ is running...
    Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
    Check IPs on destination node: 190.2.55.204 10.0.10.204
Preparing remote node
    Copying config file
111.conf                                      100%  882     0.9KB/s   00:00
Saved parameters for VE 111
/usr/sbin/vzmigrate: line 382: [: missing `]'
    Creating remote VE root dir
    Creating remote VE private dir
    VZ disk quota disabled -- skipping quota migration
Syncing private
Live migrating VE
    Suspending VE
Setting up checkpoint...
        suspend...
        get context...
Checkpointing completed succesfully
    Dumping VE
Setting up checkpoint...
        join context..
        dump...
Can not dump VE: Invalid argument
iptables-save exited with 255
Checkpointing failed
Error:  Failed to dump VE
Resuming...
Running: /usr/lib/vzctl/scripts/vps-net_add
        put context
The migration is from root@localhost to root@ovz98

This is HWN configurations:

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.18-ovz028stab035.1-smp #1 SMP Sat Jun 9
12:15:32 MSD 2007 i686 i686 i386 GNU/Linux


[root@localhost ~]# rpm -qa | grep vz
vzrpm44-4.4.1-22.5
vzrpm43-python-4.3.3-7_nonptl.6
vzyum-2.4.0-11
vzpkg-2.7.0-18
vztmpl-fedora-core-3-2.0-2
vztmpl-fedora-core-5-2.0-2
vzctl-3.0.22-1
ovzkernel-smp-2.6.9-023stab032.1
ovzkernel-smp-2.6.16-026test020.1
vzrpm44-python-4.4.1-22.5
vzrpm43-4.3.3-7_nonptl.6
vztmpl-centos-4-2.0-2
vztmpl-fedora-core-4-2.0-2
kernel-smp-2.6.18-ovz028stab035.1
vzctl-lib-3.0.22-1
vzquota-3.0.11-1

[root@ovz98 ~]# uname -a
Linux ovz98.dnsba.com 2.6.18-53.el5.028stab051.1 #1 SMP Fri Nov 30 03:05:22
MSK 2007 i686 athlon i386 GNU/Linux

[root@ovz98 ~]# rpm -qa | grep vz
ovzkernel-2.6.18-8.1.4.el5.028stab035.1
vzrpm44-4.4.1-22.5
vzrpm43-python-4.3.3-7_nonptl.6
vzyum-2.4.0-11
vztmpl-centos-4-2.0-2
vztmpl-fedora-core-4-2.0-2
vzctl-3.0.22-1
ovzkernel-2.6.18-53.el5.028stab051.1
vzrpm44-python-4.4.1-22.5
vzrpm43-4.3.3-7_nonptl.6
vzpkg-2.7.0-18
vztmpl-fedora-core-3-2.0-2
vztmpl-fedora-core-5-2.0-2
vzctl-lib-3.0.22-1
vzquota-3.0.11-1



Any idea?
Re: Live Migration Fails [message #25405 is a reply to message #25400] Sat, 22 December 2007 20:27 Go to previous messageGo to next message
Thorsten Schifferdeck is currently offline  Thorsten Schifferdeck
Messages: 38
Registered: February 2006
Member
From: openvz.org
Hi Pablo,

yep, since the last git commit to vzmigrate (-> 
http://git.openvz.org/?p=vzctl;a=commitdiff;h=ebd5fb00a4eb0134d7ef4ebfdc0b6ae43d07d8fd 
), the extended test command was removed, so change at line 382:

if [ $? != 20 && $? != 21 && $? != 0 ]; then

to:
if [[ $? != 20 && $? != 21 && $? != 0 ]]; then

Bye,
  Thorsten




Pablo L. Arturi wrote:
> Hello guys, does anyone knows why while trying to migrate a VE I get this
> error?
> 
> root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251 111
> OPT:-r
> OPT:--online
> OPT:--keep-dst
> OPT:-v
> OPT:10.0.10.251
> Starting online migration of VE 111 on 10.0.10.251
> OpenVZ is running...
>     Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
>     Check IPs on destination node: 190.2.55.204 10.0.10.204
> Preparing remote node
>     Copying config file
> 111.conf                                      100%  882     0.9KB/s   00:00
> Saved parameters for VE 111
> /usr/sbin/vzmigrate: line 382: [: missing `]'
>     Creating remote VE root dir
>     Creating remote VE private dir
>     VZ disk quota disabled -- skipping quota migration
> Syncing private
> Live migrating VE
>     Suspending VE
> Setting up checkpoint...
>         suspend...
>         get context...
> Checkpointing completed succesfully
>     Dumping VE
> Setting up checkpoint...
>         join context..
>         dump...
> Can not dump VE: Invalid argument
> iptables-save exited with 255
> Checkpointing failed
> Error:  Failed to dump VE
> Resuming...
> Running: /usr/lib/vzctl/scripts/vps-net_add
>         put context
> The migration is from root@localhost to root@ovz98
> 
> This is HWN configurations:
> 
> [root@localhost ~]# uname -a
> Linux localhost.localdomain 2.6.18-ovz028stab035.1-smp #1 SMP Sat Jun 9
> 12:15:32 MSD 2007 i686 i686 i386 GNU/Linux
> 
> 
> [root@localhost ~]# rpm -qa | grep vz
> vzrpm44-4.4.1-22.5
> vzrpm43-python-4.3.3-7_nonptl.6
> vzyum-2.4.0-11
> vzpkg-2.7.0-18
> vztmpl-fedora-core-3-2.0-2
> vztmpl-fedora-core-5-2.0-2
> vzctl-3.0.22-1
> ovzkernel-smp-2.6.9-023stab032.1
> ovzkernel-smp-2.6.16-026test020.1
> vzrpm44-python-4.4.1-22.5
> vzrpm43-4.3.3-7_nonptl.6
> vztmpl-centos-4-2.0-2
> vztmpl-fedora-core-4-2.0-2
> kernel-smp-2.6.18-ovz028stab035.1
> vzctl-lib-3.0.22-1
> vzquota-3.0.11-1
> 
> [root@ovz98 ~]# uname -a
> Linux ovz98.dnsba.com 2.6.18-53.el5.028stab051.1 #1 SMP Fri Nov 30 03:05:22
> MSK 2007 i686 athlon i386 GNU/Linux
> 
> [root@ovz98 ~]# rpm -qa | grep vz
> ovzkernel-2.6.18-8.1.4.el5.028stab035.1
> vzrpm44-4.4.1-22.5
> vzrpm43-python-4.3.3-7_nonptl.6
> vzyum-2.4.0-11
> vztmpl-centos-4-2.0-2
> vztmpl-fedora-core-4-2.0-2
> vzctl-3.0.22-1
> ovzkernel-2.6.18-53.el5.028stab051.1
> vzrpm44-python-4.4.1-22.5
> vzrpm43-4.3.3-7_nonptl.6
> vzpkg-2.7.0-18
> vztmpl-fedora-core-3-2.0-2
> vztmpl-fedora-core-5-2.0-2
> vzctl-lib-3.0.22-1
> vzquota-3.0.11-1
> 
> 
> 
> Any idea?
>
Re: Live Migration Fails [message #25412 is a reply to message #25405] Sun, 23 December 2007 21:25 Go to previous messageGo to next message
parturi is currently offline  parturi
Messages: 10
Registered: April 2006
Junior Member
From: openvz.org
> Pablo L. Arturi wrote:
> > Hello guys, does anyone knows why while trying to migrate a VE I get
this
> > error?
> >
> > root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251
111
> > OPT:-r
> > OPT:--online
> > OPT:--keep-dst
> > OPT:-v
> > OPT:10.0.10.251
> > Starting online migration of VE 111 on 10.0.10.251
> > OpenVZ is running...
> >     Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
> >     Check IPs on destination node: 190.2.55.204 10.0.10.204
> > Preparing remote node
> >     Copying config file
> > 111.conf                                      100%  882     0.9KB/s
00:00
> > Saved parameters for VE 111
> > /usr/sbin/vzmigrate: line 382: [: missing `]'
> >     Creating remote VE root dir
> >     Creating remote VE private dir
> >     VZ disk quota disabled -- skipping quota migration
> > Syncing private
> > Live migrating VE
> >     Suspending VE
> > Setting up checkpoint...
> >         suspend...
> >         get context...
> > Checkpointing completed succesfully
> >     Dumping VE
> > Setting up checkpoint...
> >         join context..
> >         dump...
> > Can not dump VE: Invalid argument
> > iptables-save exited with 255
> > Checkpointing failed
> > Error:  Failed to dump VE
> > Resuming...
> > Running: /usr/lib/vzctl/scripts/vps-net_add
> >         put context
> > The migration is from root@localhost to root@ovz98
> >
> > This is HWN configurations:
> >
> > [root@localhost ~]# uname -a
> > Linux localhost.localdomain 2.6.18-ovz028stab035.1-smp #1 SMP Sat Jun 9
> > 12:15:32 MSD 2007 i686 i686 i386 GNU/Linux
> >
> >
> > [root@localhost ~]# rpm -qa | grep vz
> > vzrpm44-4.4.1-22.5
> > vzrpm43-python-4.3.3-7_nonptl.6
> > vzyum-2.4.0-11
> > vzpkg-2.7.0-18
> > vztmpl-fedora-core-3-2.0-2
> > vztmpl-fedora-core-5-2.0-2
> > vzctl-3.0.22-1
> > ovzkernel-smp-2.6.9-023stab032.1
> > ovzkernel-smp-2.6.16-026test020.1
> > vzrpm44-python-4.4.1-22.5
> > vzrpm43-4.3.3-7_nonptl.6
> > vztmpl-centos-4-2.0-2
> > vztmpl-fedora-core-4-2.0-2
> > kernel-smp-2.6.18-ovz028stab035.1
> > vzctl-lib-3.0.22-1
> > vzquota-3.0.11-1
> >
> > [root@ovz98 ~]# uname -a
> > Linux ovz98.dnsba.com 2.6.18-53.el5.028stab051.1 #1 SMP Fri Nov 30
03:05:22
> > MSK 2007 i686 athlon i386 GNU/Linux
> >
> > [root@ovz98 ~]# rpm -qa | grep vz
> > ovzkernel-2.6.18-8.1.4.el5.028stab035.1
> > vzrpm44-4.4.1-22.5
> > vzrpm43-python-4.3.3-7_nonptl.6
> > vzyum-2.4.0-11
> > vztmpl-centos-4-2.0-2
> > vztmpl-fedora-core-4-2.0-2
> > vzctl-3.0.22-1
> > ovzkernel-2.6.18-53.el5.028stab051.1
> > vzrpm44-python-4.4.1-22.5
> > vzrpm43-4.3.3-7_nonptl.6
> > vzpkg-2.7.0-18
> > vztmpl-fedora-core-3-2.0-2
> > vztmpl-fedora-core-5-2.0-2
> > vzctl-lib-3.0.22-1
> > vzquota-3.0.11-1
> >
> >
> >
> > Any idea?
> >
> Hi Pablo,
>
> yep, since the last git commit to vzmigrate (->
>
http://git.openvz.org/?p=vzctl;a=commitdiff;h=ebd5fb00a4eb0134d7ef4ebfdc0b6ae43d07d8fd
> ), the extended test command was removed, so change at line 382:
>
> if [ $? != 20 && $? != 21 && $? != 0 ]; then
>
> to:
> if [[ $? != 20 && $? != 21 && $? != 0 ]]; then
>
> Bye,
>   Thorsten

Hello Thorsten, thanks for your reply.

I changed the line 382 and the '/usr/sbin/vzmigrate: line 382: [: missing
`]' dissapeared. But I keep getting the other errors which doesn't let the
VE to be migrated.
Any other idea?

Thank you,
Pablo
Re: Live Migration Fails [message #25413 is a reply to message #25412] Sun, 23 December 2007 23:41 Go to previous messageGo to next message
parturi is currently offline  parturi
Messages: 10
Registered: April 2006
Junior Member
From: openvz.org
> > Pablo L. Arturi wrote:
> > > Hello guys, does anyone knows why while trying to migrate a VE I get
> this
> > > error?
> > >
> > > root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251
> 111
> > > OPT:-r
> > > OPT:--online
> > > OPT:--keep-dst
> > > OPT:-v
> > > OPT:10.0.10.251
> > > Starting online migration of VE 111 on 10.0.10.251
> > > OpenVZ is running...
> > >     Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
> > >     Check IPs on destination node: 190.2.55.204 10.0.10.204
> > > Preparing remote node
> > >     Copying config file
> > > 111.conf                                      100%  882     0.9KB/s
> 00:00
> > > Saved parameters for VE 111
> > > /usr/sbin/vzmigrate: line 382: [: missing `]'
> > >     Creating remote VE root dir
> > >     Creating remote VE private dir
> > >     VZ disk quota disabled -- skipping quota migration
> > > Syncing private
> > > Live migrating VE
> > >     Suspending VE
> > > Setting up checkpoint...
> > >         suspend...
> > >         get context...
> > > Checkpointing completed succesfully
> > >     Dumping VE
> > > Setting up checkpoint...
> > >         join context..
> > >         dump...
> > > Can not dump VE: Invalid argument
> > > iptables-save exited with 255
> > > Checkpointing failed
> > > Error:  Failed to dump VE
> > > Resuming...
> > > Running: /usr/lib/vzctl/scripts/vps-net_add
> > >         put context
> > > The migration is from root@localhost to root@ovz98
> > >
> > > This is HWN configurations:
> > >
> > > [root@localhost ~]# uname -a
> > > Linux localhost.localdomain 2.6.18-ovz028stab035.1-smp #1 SMP Sat Jun
9
> > > 12:15:32 MSD 2007 i686 i686 i386 GNU/Linux
> > >
> > >
> > > [root@localhost ~]# rpm -qa | grep vz
> > > vzrpm44-4.4.1-22.5
> > > vzrpm43-python-4.3.3-7_nonptl.6
> > > vzyum-2.4.0-11
> > > vzpkg-2.7.0-18
> > > vztmpl-fedora-core-3-2.0-2
> > > vztmpl-fedora-core-5-2.0-2
> > > vzctl-3.0.22-1
> > > ovzkernel-smp-2.6.9-023stab032.1
> > > ovzkernel-smp-2.6.16-026test020.1
> > > vzrpm44-python-4.4.1-22.5
> > > vzrpm43-4.3.3-7_nonptl.6
> > > vztmpl-centos-4-2.0-2
> > > vztmpl-fedora-core-4-2.0-2
> > > kernel-smp-2.6.18-ovz028stab035.1
> > > vzctl-lib-3.0.22-1
> > > vzquota-3.0.11-1
> > >
> > > [root@ovz98 ~]# uname -a
> > > Linux ovz98.dnsba.com 2.6.18-53.el5.028stab051.1 #1 SMP Fri Nov 30
> 03:05:22
> > > MSK 2007 i686 athlon i386 GNU/Linux
> > >
> > > [root@ovz98 ~]# rpm -qa | grep vz
> > > ovzkernel-2.6.18-8.1.4.el5.028stab035.1
> > > vzrpm44-4.4.1-22.5
> > > vzrpm43-python-4.3.3-7_nonptl.6
> > > vzyum-2.4.0-11
> > > vztmpl-centos-4-2.0-2
> > > vztmpl-fedora-core-4-2.0-2
> > > vzctl-3.0.22-1
> > > ovzkernel-2.6.18-53.el5.028stab051.1
> > > vzrpm44-python-4.4.1-22.5
> > > vzrpm43-4.3.3-7_nonptl.6
> > > vzpkg-2.7.0-18
> > > vztmpl-fedora-core-3-2.0-2
> > > vztmpl-fedora-core-5-2.0-2
> > > vzctl-lib-3.0.22-1
> > > vzquota-3.0.11-1
> > >
> > >
> > >
> > > Any idea?
> > >
> > Hi Pablo,
> >
> > yep, since the last git commit to vzmigrate (->
> >
>
http://git.openvz.org/?p=vzctl;a=commitdiff;h=ebd5fb00a4eb0134d7ef4ebfdc0b6ae43d07d8fd
> > ), the extended test command was removed, so change at line 382:
> >
> > if [ $? != 20 && $? != 21 && $? != 0 ]; then
> >
> > to:
> > if [[ $? != 20 && $? != 21 && $? != 0 ]]; then
> >
> > Bye,
> >   Thorsten
>
> Hello Thorsten, thanks for your reply.
>
> I changed the line 382 and the '/usr/sbin/vzmigrate: line 382: [: missing
> `]' dissapeared. But I keep getting the other errors which doesn't let the
> VE to be migrated.
> Any other idea?
>
> Thank you,
> Pablo

I have tried the offline migration (excluding --online) from the command
line, and the VE was migrated. But when I try to start it I get the
following error:

[root@ovz98 111]# vzctl restart 301
Restarting VE
Starting VE ...
VE is mounted
Adding IP address(es): NNN.NNN.NNN.NNN
bash: line 61: 29723 Segmentation fault      /bin/sed -e
"s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
 ERROR: Can't change file /etc/sysconfig/network
Setting CPU units: 41562
Configure meminfo: 145261
Set hostname: opertime.dnsba.com
bash: line 61: 29740 Segmentation fault      /bin/sed -e
"s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
 ERROR: Can't change file /etc/sysconfig/network
VE start in progress...
[root@ovz98 111]# vzlist -a

I tried also rsync-ing the entire private area with "rsync -avz", but the
same happens.

Any idea on this?

THank you,
Pablo
Re: Live Migration Fails [message #25417 is a reply to message #25413] Mon, 24 December 2007 09:05 Go to previous messageGo to next message
dev is currently offline  dev
Messages: 1693
Registered: September 2005
Location: Moscow
Senior Member

From: openvz.org
Can you post output of dmesg here plz?
Looks like your installation somehow broken.
I can hardly imagine why sed should normally  catch SIGSEGV.
Maybe it is compiled for some more modern CPU than you use on destinaton machine?
Or vice versa - maybe you use ancient distribution in VE?

So plz provide more info like what OS distribution is running inside VE,
dmesg output, and what other error you experienced during online migration
after fixed vzmigrate as Thorsten suggested?

Kirill


Pablo L. Arturi wrote:
>>>Pablo L. Arturi wrote:
>>>
>>>>Hello guys, does anyone knows why while trying to migrate a VE I get
>>
>>this
>>
>>>>error?
>>>>
>>>>root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251
>>
>>111
>>
>>>>OPT:-r
>>>>OPT:--online
>>>>OPT:--keep-dst
>>>>OPT:-v
>>>>OPT:10.0.10.251
>>>>Starting online migration of VE 111 on 10.0.10.251
>>>>OpenVZ is running...
>>>>    Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
>>>>    Check IPs on destination node: 190.2.55.204 10.0.10.204
>>>>Preparing remote node
>>>>    Copying config file
>>>>111.conf                                      100%  882     0.9KB/s
>>
>>00:00
>>
>>>>Saved parameters for VE 111
>>>>/usr/sbin/vzmigrate: line 382: [: missing `]'
>>>>    Creating remote VE root dir
>>>>    Creating remote VE private dir
>>>>    VZ disk quota disabled -- skipping quota migration
>>>>Syncing private
>>>>Live migrating VE
>>>>    Suspending VE
>>>>Setting up checkpoint...
>>>>        suspend...
>>>>        get context...
>>>>Checkpointing completed succesfully
>>>>    Dumping VE
>>>>Setting up checkpoint...
>>>>        join context..
>>>>        dump...
>>>>Can not dump VE: Invalid argument
>>>>iptables-save exited with 255
>>>>Checkpointing failed
>>>>Error:  Failed to dump VE
>>>>Resuming...
>>>>Running: /usr/lib/vzctl/scripts/vps-net_add
>>>>        put context
>>>>The migration is from root@localhost to root@ovz98
>>>>
>>>>This is HWN configurations:
>>>>
>>>>[root@localhost ~]# uname -a
>>>>Linux localhost.localdomain 2.6.18-ovz028stab035.1-smp #1 SMP Sat Jun
> 
> 9
> 
>>>>12:15:32 MSD 2007 i686 i686 i386 GNU/Linux
>>>>
>>>>
>>>>[root@localhost ~]# rpm -qa | grep vz
>>>>vzrpm44-4.4.1-22.5
>>>>vzrpm43-python-4.3.3-7_nonptl.6
>>>>vzyum-2.4.0-11
>>>>vzpkg-2.7.0-18
>>>>vztmpl-fedora-core-3-2.0-2
>>>>vztmpl-fedora-core-5-2.0-2
>>>>vzctl-3.0.22-1
>>>>ovzkernel-smp-2.6.9-023stab032.1
>>>>ovzkernel-smp-2.6.16-026test020.1
>>>>vzrpm44-python-4.4.1-22.5
>>>>vzrpm43-4.3.3-7_nonptl.6
>>>>vztmpl-centos-4-2.0-2
>>>>vztmpl-fedora-core-4-2.0-2
>>>>kernel-smp-2.6.18-ovz028stab035.1
>>>>vzctl-lib-3.0.22-1
>>>>vzquota-3.0.11-1
>>>>
>>>>[root@ovz98 ~]# uname -a
>>>>Linux ovz98.dnsba.com 2.6.18-53.el5.028stab051.1 #1 SMP Fri Nov 30
>>
>>03:05:22
>>
>>>>MSK 2007 i686 athlon i386 GNU/Linux
>>>>
>>>>[root@ovz98 ~]# rpm -qa | grep vz
>>>>ovzkernel-2.6.18-8.1.4.el5.028stab035.1
>>>>vzrpm44-4.4.1-22.5
>>>>vzrpm43-python-4.3.3-7_nonptl.6
>>>>vzyum-2.4.0-11
>>>>vztmpl-centos-4-2.0-2
>>>>vztmpl-fedora-core-4-2.0-2
>>>>vzctl-3.0.22-1
>>>>ovzkernel-2.6.18-53.el5.028stab051.1
>>>>vzrpm44-python-4.4.1-22.5
>>>>vzrpm43-4.3.3-7_nonptl.6
>>>>vzpkg-2.7.0-18
>>>>vztmpl-fedora-core-3-2.0-2
>>>>vztmpl-fedora-core-5-2.0-2
>>>>vzctl-lib-3.0.22-1
>>>>vzquota-3.0.11-1
>>>>
>>>>
>>>>
>>>>Any idea?
>>>>
>>>
>>>Hi Pablo,
>>>
>>>yep, since the last git commit to vzmigrate (->
>>>
> http://git.openvz.org/?p=vzctl;a=commitdiff;h=ebd5fb00a4eb0134d7ef4ebfdc0b6ae43d07d8fd
> 
>>>), the extended test command was removed, so change at line 382:
>>>
>>>if [ $? != 20 && $? != 21 && $? != 0 ]; then
>>>
>>>to:
>>>if [[ $? != 20 && $? != 21 && $? != 0 ]]; then
>>>
>>>Bye,
>>>  Thorsten
>>
>>Hello Thorsten, thanks for your reply.
>>
>>I changed the line 382 and the '/usr/sbin/vzmigrate: line 382: [: missing
>>`]' dissapeared. But I keep getting the other errors which doesn't let the
>>VE to be migrated.
>>Any other idea?
>>
>>Thank you,
>>Pablo
> 
> 
> I have tried the offline migration (excluding --online) from the command
> line, and the VE was migrated. But when I try to start it I get the
> following error:
> 
> [root@ovz98 111]# vzctl restart 301
> Restarting VE
> Starting VE ...
> VE is mounted
> Adding IP address(es): NNN.NNN.NNN.NNN
> bash: line 61: 29723 Segmentation fault      /bin/sed -e
> "s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
>  ERROR: Can't change file /etc/sysconfig/network
> Setting CPU units: 41562
> Configure meminfo: 145261
> Set hostname: opertime.dnsba.com
> bash: line 61: 29740 Segmentation fault      /bin/sed -e
> "s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
>  ERROR: Can't change file /etc/sysconfig/network
> VE start in progress...
> [root@ovz98 111]# vzlist -a
> 
> I tried also rsync-ing the entire private area with "rsync -avz", but the
> same happens.
> 
> Any idea on this?
> 
> THank you,
> Pablo
>
Re: Live Migration Fails [message #25431 is a reply to message #25417] Mon, 24 December 2007 16:16 Go to previous messageGo to next message
parturi is currently offline  parturi
Messages: 10
Registered: April 2006
Junior Member
From: openvz.org
Thanks Kirilll, this is the detailed information about the issue:

** After making changes suggested by Thorsten I got the following error:

/////////////////// VZMIGRATE OUTPUT START ///////////////////////
root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251 111
OPT:-r
OPT:--online
OPT:--keep-dst
OPT:-v
OPT:10.0.10.251
Starting online migration of VE 111 on 10.0.10.251
OpenVZ is running...
    Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
    Check IPs on destination node: 190.2.55.204 10.0.10.204
Preparing remote node
    Copying config file
111.conf                                      100%  882     0.9KB/s  00:00

Saved parameters for VE 111
/usr/sbin/vzmigrate: line 382: [: missing `]'
    Creating remote VE root dir
    Creating remote VE private dir
    VZ disk quota disabled -- skipping quota migration
Syncing private
Live migrating VE
    Suspending VE
Setting up checkpoint...
        suspend...
        get context...
Checkpointing completed succesfully
    Dumping VE
Setting up checkpoint...
        join context..
        dump...
Can not dump VE: Invalid argument
iptables-save exited with 255
Checkpointing failed
Error:  Failed to dump VE
Resuming...
Running: /usr/lib/vzctl/scripts/vps-net_add
        put context
/////////////////// VZMIGRATE OUTPUT END ///////////////////////

After this I tried changing the tmpve var inside vz.conf, just in case I
didn't have the proper user's rights in /tmp folder. Nothing changed, the
same errores came up.

Then, I tried an offline migration, and it did the migration but the VE
never started (because of networking not bein started). Actually there are
41 process running, but there is not networking configuration running.
The same happens if I just rsync the VE private area and ve.cofig file.
Exactly the same networking problem.

/////////////////////////  VZCTL START 111 /////////////////////////////

[root@ovz98 ~]# vzctl restart 111
Restarting VE
Stopping VE ...
VE was stopped
Running: /usr/lib/vzctl/scripts/vps-net_del
Running: /usr/sbin/vzquota stat 111 -f
VE is unmounted
Running: /usr/lib/vzctl/scripts/vps-stop
Starting VE ...
Mounting root: /vz/root/111 /vz/private/111
VE is mounted
Set iptables mask 0x000017bf
Set features mask 0000000000000000/0000000000000000
Adding IP address(es): 10.0.10.200
Running: /usr/lib/vzctl/scripts/vps-net_add
Running VE script: /etc/vz/dists/scripts/redhat-add_ip.sh
bash: line 61:  3793 Segmentation fault      /bin/sed -e
"s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
 ERROR: Can't change file /etc/sysconfig/network
Setting CPU units: 41562
Configure meminfo: 145261
Set hostname: hostname.domain.com
Running VE script: /etc/vz/dists/scripts/redhat-set_hostname.sh
bash: line 61:  3810 Segmentation fault      /bin/sed -e
"s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
 ERROR: Can't change file /etc/sysconfig/network
VE start in progress...

/////////////////////////  VZCTL START 111 END /////////////////////////////


////////////////// DMESG OUTPUT ////////////////////////

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE-MCP61: IDE controller at PCI slot 0000:00:06.0
NFORCE-MCP61: chipset revision 162
NFORCE-MCP61: not 100% native mode: will probe irqs later
NFORCE-MCP61: 0000:00:06.0 (rev a2) UDMA133 controller
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
Probing IDE interface ide0...
Probing IDE interface ide0...
Probing IDE interface ide1...
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
PNP: PS/2 controller doesn't have AUX irq; using default 12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
processors (2 cpu cores) (version 2.10.00)
powernow-k8: MP systems not supported by PSB BIOS structure
powernow-k8: MP systems not supported by PSB BIOS structure
Using IPI Shortcut mode
Freeing unused kernel memory: (0073a000-00775000) 236k freed
Write protecting the kernel read-only data: 403k
Time: hpet clocksource has been installed.
USB Universal Host Controller Interface driver v3.0
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [LUB0] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LUB0] -> GSI 11 (level, low) ->
IRQ 11
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:02.0: irq 11, io mem 0xdfeff000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
ACPI: PCI Interrupt Link [LUB2] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:02.1[B] -> Link [LUB2] -> GSI 10 (level, low) ->
IRQ 10
PCI: Setting latency timer of device 0000:00:02.1 to 64
ehci_hcd 0000:00:02.1: EHCI Host Controller
ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 2
ehci_hcd 0000:00:02.1: debug port 1
PCI: cache line size of 64 is not supported by device 0000:00:02.1
ehci_hcd 0000:00:02.1: irq 10, io mem 0xdfefec00
ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 8 ports detected
SCSI subsystem initialized
libata version 2.21 loaded.
sata_nv 0000:00:08.0: version 3.4
ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 15
PCI: setting IRQ 15 as level-triggered
ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LSA0] -> GSI 15 (level, low) ->
IRQ 15
PCI: Setting latency timer of device 0000:00:08.0 to 64
scsi0 : sata_nv
scsi1 : sata_nv
ata1: SATA max UDMA/133 cmd 0x0001d480 ctl 0x0001d402 bmdma 0x0001cc00 irq
15
ata2: SATA max UDMA/133 cmd 0x0001d080 ctl 0x0001d002 bmdma 0x0001cc08 irq
15
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: ATA-7: WDC WD2500KS-00MJB0, 02.01C03, max UDMA/133
ata1.00: 488397168 sectors, multi 16: LBA48
ata1.00: configured for UDMA/133
ata2: SATA link down (SStatus 0 SControl 300)
  Vendor: ATA       Model: WDC WD2500KS-00M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 sda4 < sda5 >
sd 0:0:0:0: Attached scsi disk sda
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
EDAC MC: Ver: 2.0.1 Nov 30 2007
EDAC MC0: Giving out device to k8_edac Athlon64/Opteron: DEV 0000:00:18.2
input: PC Speaker as /class/input/input0
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
8139cp 0000:01:06.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible
chip
8139cp 0000:01:06.0: Try the "8139too" driver instead.
Floppy drive(s): fd0 is 1.44M
8139too Fast Ethernet driver 0.9.27
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI Interrupt 0000:01:06.0[A] -> Link [LNKA] -> GSI 11 (level, low) ->
IRQ 11
eth0: RealTek RTL8139 at 0xf8942c00, 00:08:54:b0:a5:98, IRQ 11
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
FDC 0 is a post-1991 82077
sd 0:0:0:0: Attached scsi generic sg0 type 0
ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:05.0[B] -> Link [LAZA] -> GSI 11 (level, low) ->
IRQ 11
PCI: Setting latency timer of device 0000:00:05.0 to 64
lp0: using parport0 (interrupt-driven).
lp0: console ready
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
device-mapper: ioctl: 4.11.0-ioctl (2006-09-14) initialised:
dm-devel@redhat.com
EXT3 FS on sda2, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 4192956k swap on /dev/sda3.  Priority:-1 extents:1 across:4192956k
NET: Registered protocol family 10
IPv6 over IPv4 tunneling driver
process `sysctl' is using deprecated sysctl (syscall)
net.ipv6.neigh.lo.retrans_time; Use net.ipv6.neigh.lo.retrans_time_ms
instead.
eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Bluetooth: Core ver 2.10
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
ip_tables: (C) 2000-2006 Netfilter Core Team
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (8192 buckets, 65536 max) - 232 bytes per conntrack
VE: 106: started
eth1: no IPv6 routers present
VE: 108: started
VE: 112: started
VE: 113: started
VE: 114: started
VE: 115: started
VE: 500: started
VE: 900: started
VE: 901: star
...

Re: Live Migration Fails [message #25433 is a reply to message #25431] Mon, 24 December 2007 16:39 Go to previous message
parturi is currently offline  parturi
Messages: 10
Registered: April 2006
Junior Member
From: openvz.org
I could make it work manually, at least to pass chrismast at home :)
creating venet0:* devices and running ifup-route venet0. It just make it
work.

I know the probably better way to fix this would be installing the VE in a
new template, but I cound't think of anything I could do wrong regarding
only this VE.

Thanks and Merry Christmas to everyone.
Pablo


> Thanks Kirilll, this is the detailed information about the issue:
>
> ** After making changes suggested by Thorsten I got the following error:
>
> /////////////////// VZMIGRATE OUTPUT START ///////////////////////
> root@hostbw-253 ~]# vzmigrate -r no --online --keep-dst -v 10.0.10.251 111
> OPT:-r
> OPT:--online
> OPT:--keep-dst
> OPT:-v
> OPT:10.0.10.251
> Starting online migration of VE 111 on 10.0.10.251
> OpenVZ is running...
>     Loading /etc/vz/vz.conf and /etc/vz/conf/111.conf files
>     Check IPs on destination node: 190.2.55.204 10.0.10.204
> Preparing remote node
>     Copying config file
> 111.conf                                      100%  882     0.9KB/s  00:00
>
> Saved parameters for VE 111
> /usr/sbin/vzmigrate: line 382: [: missing `]'
>     Creating remote VE root dir
>     Creating remote VE private dir
>     VZ disk quota disabled -- skipping quota migration
> Syncing private
> Live migrating VE
>     Suspending VE
> Setting up checkpoint...
>         suspend...
>         get context...
> Checkpointing completed succesfully
>     Dumping VE
> Setting up checkpoint...
>         join context..
>         dump...
> Can not dump VE: Invalid argument
> iptables-save exited with 255
> Checkpointing failed
> Error:  Failed to dump VE
> Resuming...
> Running: /usr/lib/vzctl/scripts/vps-net_add
>         put context
> /////////////////// VZMIGRATE OUTPUT END ///////////////////////
>
> After this I tried changing the tmpve var inside vz.conf, just in case I
> didn't have the proper user's rights in /tmp folder. Nothing changed, the
> same errores came up.
>
> Then, I tried an offline migration, and it did the migration but the VE
> never started (because of networking not bein started). Actually there are
> 41 process running, but there is not networking configuration running.
> The same happens if I just rsync the VE private area and ve.cofig file.
> Exactly the same networking problem.
>
> /////////////////////////  VZCTL START 111 /////////////////////////////
>
> [root@ovz98 ~]# vzctl restart 111
> Restarting VE
> Stopping VE ...
> VE was stopped
> Running: /usr/lib/vzctl/scripts/vps-net_del
> Running: /usr/sbin/vzquota stat 111 -f
> VE is unmounted
> Running: /usr/lib/vzctl/scripts/vps-stop
> Starting VE ...
> Mounting root: /vz/root/111 /vz/private/111
> VE is mounted
> Set iptables mask 0x000017bf
> Set features mask 0000000000000000/0000000000000000
> Adding IP address(es): 10.0.10.200
> Running: /usr/lib/vzctl/scripts/vps-net_add
> Running VE script: /etc/vz/dists/scripts/redhat-add_ip.sh
> bash: line 61:  3793 Segmentation fault      /bin/sed -e
> "s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
>  ERROR: Can't change file /etc/sysconfig/network
> Setting CPU units: 41562
> Configure meminfo: 145261
> Set hostname: hostname.domain.com
> Running VE script: /etc/vz/dists/scripts/redhat-set_hostname.sh
> bash: line 61:  3810 Segmentation fault      /bin/sed -e
> "s|^$name=.*|$name=\"$value\"|" <${file} >${file}.$$
>  ERROR: Can't change file /etc/sysconfig/network
> VE start in progress...
>
> /////////////////////////  VZCTL START 111 END
/////////////////////////////
>
>
> ////////////////// DMESG OUTPUT ////////////////////////
>
> ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
> NFORCE-MCP61: IDE controller at PCI slot 0000:00:06.0
> NFORCE-MCP61: chipset revision 162
> NFORCE-MCP61: not 100% native mode: will probe irqs later
> NFORCE-MCP61: 0000:00:06.0 (rev a2) UDMA133 controller
>     ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
> Probing IDE interface ide0...
> Probing IDE interface ide0...
> Probing IDE interface ide1...
> ide-floppy driver 0.99.newide
> usbcore: registered new driver hiddev
> usbcore: registered new driver usbhid
> drivers/usb/input/hid-core.c: v2.6:USB HID core driver
> PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
> PNP: PS/2 controller doesn't have AUX irq; using default 12
> serio: i8042 KBD port at 0x60,0x64 irq 1
> serio: i8042 AUX port at 0x60,0x64 irq 12
> mice: PS/2 mouse device common for all mice
> md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
> md: bitmap version 4.39
> TCP bic registered
> Initializing IPsec netlink socket
> NET: Registered protocol family 1
> NET: Registered protocol family 17
> powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
> processors (2 cpu cores) (version 2.10.00)
> powernow-k8: MP systems not supported by PSB BIOS structure
> powernow-k8: MP systems not supported by PSB BIOS structure
> Using IPI Shortcut mode
> Freeing unused kernel memory: (0073a000-00775000) 236k freed
> Write protecting the kernel read-only data: 403k
> Time: hpet clocksource has been installed.
> USB Universal Host Controller Interface driver v3.0
> ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
> ACPI: PCI Interrupt Link [LUB0] enabled at IRQ 11
> PCI: setting IRQ 11 as level-triggered
> ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LUB0] -> GSI 11 (level,
low) ->
> IRQ 11
> PCI: Setting latency timer of device 0000:00:02.0 to 64
> ohci_hcd 0000:00:02.0: OHCI Host Controller
> ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
> ohci_hcd 0000:00:02.0: irq 11, io mem 0xdfeff000
> usb usb1: configuration #1 chosen from 1 choice
> hub 1-0:1.0: USB hub found
> hub 1-0:1.0: 8 ports detected
> ACPI: PCI Interrupt Link [LUB2] enabled at IRQ 10
> PCI: setting IRQ 10 as level-triggered
> ACPI: PCI Interrupt 0000:00:02.1[B] -> Link [LUB2] -> GSI 10 (level,
low) ->
> IRQ 10
> PCI: Setting latency timer of device 0000:00:02.1 to 64
> ehci_hcd 0000:00:02.1: EHCI Host Controller
> ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 2
> ehci_hcd 0000:00:02.1: debug port 1
> PCI: cache line size of 64 is not supported by device 0000:00:02.1
> ehci_hcd 0000:00:02.1: irq 10, io mem 0xdfefec00
> ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
> usb usb2: configuration #1 chosen from 1 choice
> hub 2-0:1.0: USB hub found
> hub 2-0:1.0: 8 ports detected
> SCSI subsystem initialized
> libata version 2.21 loaded.
> sata_nv 0000:00:08.0: version 3.4
> ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 15
> PCI: setting IRQ 15 as level-triggered
> ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LSA0] -> GSI 15 (level,
low) ->
> IRQ 15
> PCI: Setting latency timer of device 0000:00:08.0 to 64
> scsi0 : sata_nv
> scsi1 : sata_nv
> ata1: SATA max UDMA/133 cmd 0x0001d480 ctl 0x0001d402 bmdma 0x0001cc00 irq
> 15
> ata2: SATA max UDMA/133 cmd 0x0001d080 ctl 0x0001d002 bmdma 0x0001cc08 irq
> 15
> ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
> ata1.00: ATA-7: WDC WD2500KS-00MJB0, 02.01C03, max UDMA/133
> ata1.00: 488397168 sectors, multi 16: LBA48
> ata1.00: configured for UDMA/133
> ata2: SATA link down (SStatus 0 SControl 300)
>   Vendor: ATA       Model: WDC WD2500KS-00M  Rev: 02.0
>   Type:   Direct-Access                      ANSI SCSI revision: 05
> SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
> sda: Write Protect is off
> sda: Mode Sense: 00 3a 00 00
> SCSI device sda: drive cache: write back
> SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
> sda: Write Protect is off
> sda: Mode Sense: 00 3a 00 00
> SCSI device sda: drive cache: write back
>  sda: sda1 sda2 sda3 sda4 < sda5 >
> sd 0:0:0:0: Attached scsi disk sda
> kjournald starting.  Commit interval 5 seconds
> EXT3-fs: mounted filesystem with ordered data mode.
> EDAC MC: Ver: 2.0.1 Nov 30 2007
> EDAC MC0: Giving out device to k8_edac Athlon64/Opteron: DEV 0000:00:18.2
> input: PC Speaker as /class/input/input0
> parport: PnPBIOS parport detected.
> parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
> 8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
> 8139cp 0000:01:06.0: This (id 10ec:8139 rev 10) is not an 8139C+
compatible
> chip
> 8139cp 0000:01:06.0: Try the "8139too" driver instead.
> Floppy drive(s): fd0 is 1.44M
> 8139too Fast Ethernet driver 0.9.27
> ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
> ACPI: PCI Interrupt 0000:01:06.0[A] -> Link [LNKA] -> GSI 11 (level,
low) ->
> IRQ 11
> eth0: RealTek RTL8139 at 0xf8942c00, 00:08:54:b0:a5:98, IRQ 11
> eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
> FDC 0 is a post-1991 82077
> sd 0:0:0:0: Attached scsi generic sg0 type 0
> ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 11
> ACPI: PCI Interrupt 0000:00:05.0[B] -> Link [LAZA] -> GSI 11 (level,
low) ->
> IRQ 11
> PCI: Setting latency timer of device 0000:00:05.0 to 64
> lp0: using parport0 (interrupt-driven).
> lp0: console ready
> ACPI: Power Button (FF) [PWRF]
> ACPI: Power Button (CM) [PWRB]
> ibm_acpi: ec object not found
> md: Autodetecting RAID arrays.
> md: autorun ...
> md: ... autorun DONE.
> device-mapper: ioctl: 4.11.0-ioctl (2006-09-14) initialised:
> dm-devel@redhat.com
> EXT3 FS on sda2, internal jou
...

Previous Topic: 64-bit host, 32-bit guests and iptables
Next Topic: How to set resource quota of other process
Goto Forum:
  


Current Time: Mon Jul 23 13:11:43 GMT 2018