OpenVZ Forum


Home » International » Russian » Проблемы с рестартом сетевых интерфейсов
Проблемы с рестартом сетевых интерфейсов [message #24601] Thu, 06 December 2007 16:35 Go to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
Приветствую!
Суть проблемы:
на ноде - /etc/init.d/networking restart
и VPS не видны из сети (из vps можно пропинговать ноду а с ноды vps ,дальше ноды не видит)
в чём косяк может быть ?

Заранее спасибо!

[Updated on: Thu, 06 December 2007 16:40]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24608 is a reply to message #24601] Thu, 06 December 2007 18:00 Go to previous messageGo to next message
Valmont is currently offline  Valmont
Messages: 225
Registered: September 2005
Senior Member
From: *dialup.corbina.ru
можно посмотреть вывод команды
ip r l на ноде?

У меня что-то подобное было - слетал роутинг, только vps'ы после слета настроек роутинга не были совсем доступны.

[Updated on: Thu, 06 December 2007 18:04]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24614 is a reply to message #24601] Thu, 06 December 2007 19:56 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
Запросто:
192.168.0.9 dev venet0 scope link
192.168.0.15 dev venet0 scope link
192.168.0.14 dev venet0 scope link
192.168.0.6 dev venet0 scope link
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.2
default via 192.168.0.1 dev eth0

причём и до рестарта и после одно и тоже.
В первом посте я ошибся чуть чуть - после рестарта интерфейсов если зайти в vps с ноды и пингануть из неё в сеть то пинг проходит а вот
из сети vps'ку не пингует (помогаеть только /etc/init.d/vz restart и ручками стартовать vps'ки)

[Updated on: Thu, 06 December 2007 19:57]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24617 is a reply to message #24614] Thu, 06 December 2007 20:57 Go to previous messageGo to next message
Valmont is currently offline  Valmont
Messages: 225
Registered: September 2005
Senior Member
From: *dialup.corbina.ru
После обычного чрута в каталог смена сетевых настроек не происходит. Через vzctl похоже, делается какая-то дополнительная инициализация, поэтому наверно, если через ssh зайти в vps, то результаты теста будут теми же.

Странно, что оно так односторонне недоступно. Я б попробовал посмотреть по tcpdump, что происходит после рестарта сети. На ноде и в vps.


Уточните, на всякий случай, версию ядра и какая система на node/vps (centos?). Может разработчики что еще порекомендуют для диагностики.
Re: Проблемы с рестартом сетевых интерфейсов [message #24618 is a reply to message #24601] Thu, 06 December 2007 21:41 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
2.6.18-openvz-686
система Debian
tcpdump не чего дельного не показываеться (просто нет ответов и всё)
Re: Проблемы с рестартом сетевых интерфейсов [message #24620 is a reply to message #24618] Thu, 06 December 2007 22:20 Go to previous messageGo to next message
Valmont is currently offline  Valmont
Messages: 225
Registered: September 2005
Senior Member
From: *dialup.corbina.ru
2.6.18 это не совсем точный ответ. Ядер на основе 2.6.18 было много.

# uname -r
2.6.18-8.1.15.el5.028stab049.1


А последнее
http://openvz.org/download/kernel/2.6.18/
latest is 2.6.18-ovz028stab051.1
Re: Проблемы с рестартом сетевых интерфейсов [message #24621 is a reply to message #24620] Thu, 06 December 2007 22:42 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
не забываем мне rpm не нужны Smile
2.6.18-ovz-028stab048.1 (из портов дебиана последнее)
Re: Проблемы с рестартом сетевых интерфейсов [message #24647 is a reply to message #24621] Fri, 07 December 2007 08:37 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
Ответов нет и на внешнем интефесе?
или они там есть, но до venet не доходят?
Re: Проблемы с рестартом сетевых интерфейсов [message #24650 is a reply to message #24618] Fri, 07 December 2007 08:49 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
in-system wrote on Fri, 07 December 2007 00:41

tcpdump не чего дельного не показываеться (просто нет ответов и всё)


Пожалуйста пояните про какие ответы идет речь?
Насколько я понял внутри VE все вроде как работает. пинг идет в сеть и получает ответы.
А когда снаружи пингуют -- то что просходит-то?
- arp запрос приходит на внешний интерфейс?
- нода отвечает?
- пинг на внешний интерфейс приходит?
- На venet со стороны hardware nod он есть?
- внутри VE входящий пинг виден?
- ответ внутри ve виден?
- на venet со стороны HWnode ответ ve есть?
- на внешний интерфейс этот ответ ушел?

Все вроде спрсил Smile
Re: Проблемы с рестартом сетевых интерфейсов [message #24669 is a reply to message #24650] Fri, 07 December 2007 15:50 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
vaverin wrote on Fri, 07 December 2007 03:49

in-system wrote on Fri, 07 December 2007 00:41

tcpdump не чего дельного не показываеться (просто нет ответов и всё)


Пожалуйста пояните про какие ответы идет речь?
Насколько я понял внутри VE все вроде как работает. пинг идет в сеть и получает ответы.
А когда снаружи пингуют -- то что просходит-то?
- arp запрос приходит на внешний интерфейс?
- нода отвечает?
- пинг на внешний интерфейс приходит?
- На venet со стороны hardware nod он есть?
- внутри VE входящий пинг виден?
- ответ внутри ve виден?
- на venet со стороны HWnode ответ ve есть?
- на внешний интерфейс этот ответ ушел?

Все вроде спрсил Smile


-До venet не доходят
-Да совершенно верно из VE пропинговать сеть можно а из сети VE нет
-Нода пингуеться при любом раскладе
-Нет в VE не виден входящий пинг
-Ответов в VE нету
-Пропинговать из VE ноду и наоборот получаеться (всё гуд) ответы есть
-Ответов ваще нет от VE если из сети пинговать!

[Updated on: Fri, 07 December 2007 15:51]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24736 is a reply to message #24669] Sat, 08 December 2007 21:26 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *rev.domonet.ru
Пожалуйста ответьте таки на мои вопросы:
когда VE снаружи пингуют -- что просходит?
- arp запрос приходит на внешний интерфейс?
перед посылкой пакетов на чужой IP адрес внешняя нода должна узнать MAC и спросить где находится VE-шкин IP. То есть на ноду извне должен прийти arp запрос. Он приходит?

- нода отвечает?
после принятия arp запроса VE должна на него ответить. Это ответ должен: a) уйти с ноды наружу и б) дойти до внешней ноды
arp запросы можно отлично ловятся tcpdump-ом.

- пинг на внешний интерфейс приходит?
Если на ноду не приходят ни arp ни icmp -- то дело скорее всего в роутинге проставленном где-то на пути проходждения этих пакетов. либо их внешняя нода куда-то не туда послала, либо какй-нить промежуточный роутер завернул их куда-нить не туда, либо их вообще подропали по дороге. В любом случае openvz нода тут не при чем.

- На venet со стороны hardware nod он есть?
если пакеты таки видны на внешнем интерфейсе, но до venet не дошли -- их могли подропали iptables, rp_filter или форвардинг на HW node выключен.

- внутри VE входящий пинг виден?
если пакет дошел до внешнего venet, но внутрь не попал -- вероятнее всего VE не хватило ресурсов. смотрите failconters на tcprcvbuf в /proc/user_beancounters (или возможно какие-нить другие ресурсы)

- ответ внутри ve виден?
приняли но не ответили? -- помимо нехватки ресурсов возможно ответ подропали в стеке. (например iptables внутри VE)

- на venet со стороны HWnode ответ ve есть?
venet не пропускает наружу пакетов с "чужим" src IP.

- на внешний интерфейс этот ответ ушел?
Если пакет наружу не ушел -- надо смотреть роутинг и iptables на HW node.

Если же ответ наружу ушел, но до пункта назначения почему-то не добрался -- это уже не проблемы данной ноды. ищите на других нодах, где теряется пакет.

С уважением,
Василий Аверин.
Re: Проблемы с рестартом сетевых интерфейсов [message #24738 is a reply to message #24736] Sat, 08 December 2007 23:55 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
с любого компьютера в сети - ping 192.168.0.9
далее на ноде tcpdump -i eth0 host 192.168.0.9 (это VPS) - arp есть ответов на них нет!
далее tcpdump -i venet0 host 192.168.0.9 - глухо как в танке (не запросов не ответов)
естесно в самой vps нет ни запросов ни ответов

повторюсь это всё происходит после рестарта сетевых интервейсов (/etc/init.d/networking restart), что бы всё опять заработало надо рестартовать vz (/etc/init.d/vz restart), по другому не подымаеться!
что то мне кажеться что это venet или роутинг к нему (хотя всё правельно), но не фаер это точно (ибо для теста из фаера потёр всё, и в FORWARD cстоит ACCEPT)

[Updated on: Sat, 08 December 2007 23:58]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24745 is a reply to message #24738] Sun, 09 December 2007 10:35 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *rev.domonet.ru
При старте VE на ноде создается permanent arp entry -- с тем чтобы нода отвечала на приходящий снаружи arp что мол "знаю я где этот IP, шлите эти пакеты ко мне".
Вполне допускаю что после рестарта всей сети эти ARP entries сбрасываются.

Re: Проблемы с рестартом сетевых интерфейсов [message #24753 is a reply to message #24745] Sun, 09 December 2007 15:26 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
Да это понятно что при рестарте что то сбрасываеться
но вопрос в другом - как этот arp entry прописать по новой что бы не рестартить vz?
Re: Проблемы с рестартом сетевых интерфейсов [message #24820 is a reply to message #24753] Tue, 11 December 2007 05:37 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
С происходящим мы вроде бы разобрались:
service network restart сносит permanent arp entries на HW node.
Как мы видим это приводит к наружению доступа к VE.

Предотвратить эту проблему IMHO просто -- не передергивать сервис.

Если же избежать этого не удается -- то наиболее простой и полностью корректный способ востановить работоспособность VE -- тупо их заребутить. или весь сервис зарестартовать. Другого способа я на ныншений момент не знаю.

Теоретически наверное можно обойтись без рестарта VE -- как-то обойти все работающие VE и повторить их действия по настройке сети на HW node. Если эта функциональность критична для Вас -- попробуйте ее реализовать.

С уважением,
Василий Аверин
Re: Проблемы с рестартом сетевых интерфейсов [message #24831 is a reply to message #24820] Tue, 11 December 2007 08:26 Go to previous messageGo to next message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
Пипец блин!
Вы что прётесь что ли ?
Я и сам знал эти решения (предыдушие посты почитайте)
а вот моё имхо - не правельно это, как так я ребутю сеть и тут ложаться 5 vps с запущеными в них сервисами
Re: Проблемы с рестартом сетевых интерфейсов [message #24832 is a reply to message #24831] Tue, 11 December 2007 08:58 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
Уважаемый in-system,

невозможно разобраться в проблеме не поняв ее причины. Спасибо Вам, Вы помогли разобраться в причинах происходящего -- передергивание сети стирает arp.
Наиболее корректный спосроб восстановления arp (а так же других настроек сети) -- это передергивание сервиса vz, к сожалению другого готового способа решения Вашей проблемы я не знаю.

Что делать дальше?
вариант #1 -- простой и общепринятый -- не рестартить сеть вообще. (не ковыряте гвоздем в ухе -- это чревато)
А если таки зарестартили -- то нужно будет передернуть все VE.

Вариант #2 -- если первый вариант Вас по каким-либо причинам не устраивает а VE перестартовывать не хочется -- то Вы можете попробовать дописать отсутствующую функциональность.

Или ждать пока мы не добавим эту функциональность. Так как подобных запросов мы раньше не встречали -- а проблема на мой взгляд далеко не приоритетная -- то ждать пока мы сами не решим эту задачу Вам вероятно придется достаточно долго.

С уважением,
Василий Аверин
Re: Проблемы с рестартом сетевых интерфейсов [message #24834 is a reply to message #24832] Tue, 11 December 2007 09:21 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
feature request added:
http://bugzilla.openvz.org/show_bug.cgi?id=753

[Updated on: Tue, 11 December 2007 09:21]

Report message to a moderator

Re: Проблемы с рестартом сетевых интерфейсов [message #24858 is a reply to message #24834] Tue, 11 December 2007 12:37 Go to previous messageGo to next message
vaverin is currently offline  vaverin
Messages: 694
Registered: September 2005
Senior Member
From: *sw.ru
Хорошие новости!
обнаружилось что мы эту проблему частично таки порешили, но к сожалению для debian у нас готового решения нет.

Общая идея следующая:
при подъеме каждого интерфейса нужно запускать скрипт, который будет апдейтить arp.
Насколько мне известно на debian-based дистрибутивах этот скрипт надо поместить в директорию /etc/network/if-up.d.

Черновик скрипта приведен в аттаче. На debian он сходу работать не должен, с ним надо разобраться. как минимум вероятно потребутся пути поправить, может еще что-нить.

Попробуйте допилить, если есть желание.

С уважением,
Василий Аверин

  • Attachment: ifup-arp
    (Size: 0.55KB, Downloaded 269 times)
Re: Проблемы с рестартом сетевых интерфейсов [message #24887 is a reply to message #24858] Tue, 11 December 2007 18:01 Go to previous message
in-system is currently offline  in-system
Messages: 15
Registered: November 2007
Junior Member
From: *171.adsl.wplus.ru
спасибо попробую!
Previous Topic: Unknown iptable module: xt_state, skipped
Next Topic: *Resolved* Failcnt увеличивается, хотя maxheld<barrier
Goto Forum:
  


Current Time: Sun Nov 17 07:23:12 GMT 2019