OpenVZ Forum


Home » General » Support » *SOLVED* Xvfb could not open default font 'fixed'
*SOLVED* Xvfb could not open default font 'fixed' [message #24010] Fri, 30 November 2007 00:34 Go to next message
kennethburgener is currently offline  kennethburgener
Messages: 5
Registered: November 2007
Location: U.S.A.
Junior Member
I have Xvfb running on my OpenVZ host OS (CentOS 5), but when I attempt to execute Xvfb within a VE (tried centos-5-i386-minimal and centos-4-i386-minimal OS templates) I receive the same error:

----------------------------------
# export DISPLAY=:1.0
# Xvfb :1 -screen 0 800x600x16 &

Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

Fatal server error:
could not open default font 'fixed'
----------------------------------

I am installing Xvfb using "vzyum 1 install xorg-x11-server-Xvfb" to install Xvfb on the VEs (the package is named slightly different on the centos-4 template).

I tried installing x11-fonts-base package, and several others, but none seem to include this mysterious "fixed" font file.

Any ideas where I can find this default font or how I can install it?

Thanks

[Updated on: Sat, 01 December 2007 19:01] by Moderator

Report message to a moderator

Re: Xvfb could not open default font 'fixed' [message #24019 is a reply to message #24010] Fri, 30 November 2007 07:29 Go to previous messageGo to next message
maratrus is currently offline  maratrus
Messages: 1495
Registered: August 2007
Location: Moscow
Senior Member
Hi,

I'm not sure that it is helps you, because a have no knowledges about Xvfb Embarassed , but try to define the path of the directory containing the fonts manually with -fp option. I mean following:

#export DISPLAY=:1.0
#Xvfb :1 -fp /usr/X11R6/lib/X11/fonts/misc -screen 0 800x600x16 &

Thank You
Re: Xvfb could not open default font 'fixed' [message #24021 is a reply to message #24010] Fri, 30 November 2007 08:11 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

On my Fedora 8 box this is in package named xorg-x11-fonts-misc, so you might try installing x11-fonts-misc package.

'fixed' is defined in fonts.alias file as follows:
fixed -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso885 9-1


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Xvfb could not open default font 'fixed' [message #24071 is a reply to message #24021] Fri, 30 November 2007 16:57 Go to previous messageGo to next message
kennethburgener is currently offline  kennethburgener
Messages: 5
Registered: November 2007
Location: U.S.A.
Junior Member
Well that worked, sort of. I tried using vzyum to install the package and this did not resolve the issue. When I used yum locally on the VE it did. Are there know problems with vzyum? Does using yum locally on a VE cause any corruption?
Re: Xvfb could not open default font 'fixed' [message #24084 is a reply to message #24071] Fri, 30 November 2007 18:28 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 533
Registered: January 2006
Location: Moscow, Russia
Senior Member
i've replied there:
http://forum.openvz.org/index.php?t=msg&goto=24082&# msg_24082


If your problem is solved - please, report it!
It's even more important than reporting the problem itself...

[Updated on: Fri, 30 November 2007 18:28]

Report message to a moderator

Re: *SOLVED* Xvfb could not open default font 'fixed' [message #24298 is a reply to message #24010] Mon, 03 December 2007 18:35 Go to previous messageGo to next message
kennethburgener is currently offline  kennethburgener
Messages: 5
Registered: November 2007
Location: U.S.A.
Junior Member
Okay, thank you for your help!
Re: Xvfb could not open default font 'fixed' [message #25453 is a reply to message #24071] Wed, 26 December 2007 09:12 Go to previous messageGo to next message
kir is currently offline  kir
Messages: 1645
Registered: August 2005
Location: Moscow, Russia
Senior Member

Can you please provide the following information:

1. Which centos5 metadata have you used?
2. Full log of vzyum session.


Kir Kolyshkin
http://static.openvz.org/userbars/openvz-developer.png
Re: Xvfb could not open default font 'fixed' [message #25467 is a reply to message #24071] Wed, 26 December 2007 18:22 Go to previous messageGo to next message
efball is currently offline  efball
Messages: 41
Registered: September 2006
Location: Santa Rosa, California
Member
kennethburgener wrote on Fri, 30 November 2007 11:57

Well that worked, sort of. I tried using vzyum to install the package and this did not resolve the issue. When I used yum locally on the VE it did. Are there know problems with vzyum? Does using yum locally on a VE cause any corruption?


I had the same problem with the fonts not working. I fixed it with:

cd /usr/X11R6/lib/X11/fonts
mkfontdir misc 75dpi 100dpi

The post install scripts aren't working unless you install them like you did.



E Frank Ball efball@efball.com
Re: Xvfb could not open default font 'fixed' [message #25469 is a reply to message #25453] Wed, 26 December 2007 18:32 Go to previous message
kennethburgener is currently offline  kennethburgener
Messages: 5
Registered: November 2007
Location: U.S.A.
Junior Member
kir wrote on Wed, 26 December 2007 02:12

Can you please provide the following information:


Quote:

1. Which centos5 metadata have you used?


Template cache:
http://download.openvz.org/template/precreated/contrib/cento s-5-i386-minimal.tar.gz

CentOS5 Template Metadata package:
http://forum.openvz.org/index.php?t=getfile&id=389&

Quote:

2. Full log of vzyum session.


Where would I find the full log of vzyum session?



Previous Topic: SSH/Apache on Virtual machines
Next Topic: *SOLVED* debian etch ssh problem
Goto Forum:
  


Current Time: Wed Nov 29 05:36:18 GMT 2023

Total time taken to generate the page: 0.02816 seconds