OpenVZ Forum


Home » International » German » veth: custom script wird nicht ausgeführt
veth: custom script wird nicht ausgeführt [message #23839] Tue, 27 November 2007 16:56 Go to next message
Hurlyburly is currently offline  Hurlyburly
Messages: 6
Registered: November 2007
Junior Member
From: *dip0.t-ipconnect.de
Hallo,

ich habe eine VE mit veth nach dieser Anleitung http://wiki.openvz.org/Virtual_Ethernet_device eingerichtet. (Host: Debian Etch; VE: Debian Sarge; vzctl hat die Version 3.0.11.) Es geht soweit - nur dass das Script, mit dem beim Starten das Routing automatisiert eingetragen werden soll, anscheinend nicht ausgeführt wird. Woran kann das liegen? Alle Dateien sind wie beschrieben angelegt worden, das Script ist ausführbar, die VEID.conf stimmt auch, soweit ich sehe. Dennoch läuft der Start einfach so durch, als gäbe es das Custom Script nicht. (Es werden auch keine Fehlermeldungen gezeigt). Außerdem wird in VE jedesmal ein venet0 Interface angelegt, obwohl das, soweit ich die o.g. Anleitung verstanden habe, nicht passieren soll, wenn IP_ADDRESS auskommentiert ist.


Auszug VEID.conf
...
CONFIG_CUSTOMIZED="yes"
VETH_IP_ADDRESS="xx.xx.xx.xx"
EXTERNAL_SCRIPT="/usr/sbin/vznetaddroute"
#IP_ADDRESS="x.xx.xx.xx"
...




Auszug /etc/network/interfaces:
# Auto generated venet0 interfaces
auto venet0 lo
iface venet0 inet static
        address 127.0.0.1
        netmask 255.255.255.255
        broadcast 0.0.0.0
        up route add -net 191.255.255.1 netmask 255.255.255.255 dev venet0
        up route add default gw 191.255.255.1
iface lo inet loopback



Re: veth: custom script wird nicht ausgeführt [message #23843 is a reply to message #23839] Tue, 27 November 2007 21:16 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *bisping.net
Hi,

...
CONFIG_CUSTOMIZED="yes"
VETH_IP_ADDRESS="xx.xx.xx.xx"
EXTERNAL_SCRIPT="/usr/sbin/vznetaddroute" <--
#IP_ADDRESS="x.xx.xx.xx"
...

Lese den genannten wiki Eintrag nochmals durch, "Punkt 2.4 Making a veth-device persistent, Punkt 3" : script /etc/vz/vznet.conf

Re: veth: custom script wird nicht ausgeführt [message #23869 is a reply to message #23843] Wed, 28 November 2007 09:41 Go to previous messageGo to next message
Hurlyburly is currently offline  Hurlyburly
Messages: 6
Registered: November 2007
Junior Member
From: *dip0.t-ipconnect.de
Danke. Manchmal hat man ja Tomaten auf den Augen, aber daran liegt's in diesem Fall wohl ausnahmsweise nicht. Ich hab vznetaddroute wie beschrieben im Verzeichnis /usr/sbin/ angelegt und vznet.conf im Verzeichnis /etc/vz/.

Das EXTERNAL_SCRIPT hatte ich nur später beim Rumprobieren in VEID.conf eingefügt, weil's eben auf die beschriebene Art nicht funktionierte.
Re: veth: custom script wird nicht ausgeführt [message #23917 is a reply to message #23869] Wed, 28 November 2007 20:48 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hi,

einen Blick in den Quellcode offenbart:
diese vzctl version 3.0.11 (etch) basiert auf den Stand vom 07.08.2006;
das vznetcfg script ist erst danach eingeführt worden.

Daher installiere dir nee weit aus aktuellere Version :

a) Debian lenny/testing Repository

b) Debian OpenVZ Repro von http://debian.systs.org/
bzw. vom http://download.openvz/debian-systs/

c) selbstbauen

Danke! [message #24005 is a reply to message #23839] Thu, 29 November 2007 21:23 Go to previous message
Hurlyburly is currently offline  Hurlyburly
Messages: 6
Registered: November 2007
Junior Member
From: *dip0.t-ipconnect.de
Funktioniert einwandfrei mit deiner vzctl-Version. DANKE!
Previous Topic: Netzwerkfragen
Next Topic: VE verschwindet aus dem Netz
Goto Forum:
  


Current Time: Wed Nov 14 09:40:43 GMT 2018