OpenVZ Forum


Home » International » German » *erledigt* Problem mit externen IP Adressen
*erledigt* Problem mit externen IP Adressen [message #13787] Tue, 05 June 2007 10:39 Go to next message
noex is currently offline  noex
Messages: 3
Registered: June 2007
Junior Member
From: *dip0.t-ipconnect.de
Hallo,

Ich bin recht neu was OpenVZ angeht. Ich komme einfach nicht mehr weiter wenn es um externe/public IPs geht.

Folgende Konfiguration:

Debian Etch auf i686
OpenVZ Kernel: 2.6.18-openvz-12-1etch1-686

Entsprechend nach den Tutorials aus dem Wiki vorgegange (sysctl etc.).
OpenVZ Devices sind alle vorhanden (venet0/proc).
Weise ich einer Maschinen *keine* private Adresse zu, funktioniert der Zugriff auf und von der Maschine nicht.
Mit NAT funktioniert zumindest der Zugriff aus der Maschine.

Falls noch Infos fehlen, bitte fragen. Ich bin am verzweifeln.

[Updated on: Mon, 11 June 2007 05:16] by Moderator

Report message to a moderator

Re: Problem mit externen IP Adressen [message #13789 is a reply to message #13787] Tue, 05 June 2007 11:19 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hallo Markus,

ich frage mal nach: Wink

- welche Disti verwendest DU ?
- hat der Srv. schon eine öffentliche IP und Du willst einer VE eine weitere öffentliche IP zuweisen ?
- stimmt das routing?
- irgendwelche iptables filter eingeschalten ?

Re: Problem mit externen IP Adressen [message #13801 is a reply to message #13787] Tue, 05 June 2007 15:36 Go to previous messageGo to next message
noex is currently offline  noex
Messages: 3
Registered: June 2007
Junior Member
From: *dip0.t-ipconnect.de
Ich verwende Gentoo ..aber denke nicht, dass Du das meinst Wink

Distri auf dem Server ist Debian 4 Etch (passend zum Kernel).
Der Server hat eine öffentliche IP.
Die Restlichen IPs (für die VEs) gehören in das gleiche Netz.
Das Netz/die IPs werden korrekt geroutet.
Für das rumprobieren mit NAT haben iptables Regeln existiert, die sind aber natürlich raus.
Re: Problem mit externen IP Adressen [message #14001 is a reply to message #13787] Sat, 09 June 2007 20:17 Go to previous message
noex is currently offline  noex
Messages: 3
Registered: June 2007
Junior Member
From: *dip0.t-ipconnect.de
Der Fehler lag an bereits zugewiesenen IP Adressen auf der gleichen Maschine mit denen ich getestet habe.

Wie so oft: Usererror Wink
Previous Topic: Reboot aus VE
Next Topic: Kernel Problem
Goto Forum:
  


Current Time: Sun Sep 23 21:35:54 GMT 2018