OpenVZ Forum


Home » International » German » Kernel Problem
Kernel Problem [message #12477] Mon, 30 April 2007 21:03 Go to next message
Aldo is currently offline  Aldo
Messages: 7
Registered: April 2007
Junior Member
From: *dip.t-dialin.net
Hallo,

beim Kompilieren des Kernels (2.6.20) erhalte ich folgenden Fehler:
Quote:

kernel/cpt/cpt_process.c: In function `cpt_check_unsupported':
kernel/cpt/cpt_process.c:707: error: structure has no member named `tux_info'
make[2]: *** [kernel/cpt/cpt_process.o] Error 1
make[1]: *** [kernel/cpt] Error 2
make: *** [kernel] Error 2

Hat jemand eine Idee woran es liegen könnte?
Meine Kernel Config findet Ihr hier:
ftp://ftp.rshost.de/linux/kernel/hetzer.ds3000.opti
Re: Kernel Problem [message #12490 is a reply to message #12477] Tue, 01 May 2007 17:21 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
http://bugzilla.openvz.org/show_bug.cgi?id=545

und

http://bugzilla.openvz.org/show_bug.cgi?id=549
Re: Kernel Problem [message #12498 is a reply to message #12490] Tue, 01 May 2007 18:14 Go to previous messageGo to next message
Aldo is currently offline  Aldo
Messages: 7
Registered: April 2007
Junior Member
From: *dip.t-dialin.net
Hallo,

Danke habe es hinbekommen!

[Updated on: Tue, 01 May 2007 18:39]

Report message to a moderator

Re: Kernel Problem [message #12501 is a reply to message #12498] Tue, 01 May 2007 19:33 Go to previous messageGo to next message
Aldo is currently offline  Aldo
Messages: 7
Registered: April 2007
Junior Member
From: *dip.t-dialin.net
Hallo,

nun bekomme ich folgenden Fehler:
Quote:

WARNING: "check_utrace" [kernel/cpt/vzcpt.ko] undefined!
Re: Probleme beim OpenVZ kernel build 2.6.20 [message #12506 is a reply to message #12501] Tue, 01 May 2007 22:45 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hast Du den 2ten Link, Dir angeschaut ?
(-> http://bugzilla.openvz.org/show_bug.cgi?id=549 )

[Updated on: Tue, 01 May 2007 22:47]

Report message to a moderator

Re: Probleme beim OpenVZ kernel build 2.6.20 [message #12556 is a reply to message #12506] Wed, 02 May 2007 17:03 Go to previous messageGo to next message
Aldo is currently offline  Aldo
Messages: 7
Registered: April 2007
Junior Member
From: *dip.t-dialin.net
Hallo,

was hat das mit meinem Problem zu tun? Ich konnte zumindest keine Lösung finden!

Hier nochmal der Fehler:

Quote:

Root device is (9, 0)
Boot sector 512 bytes.
Setup is 4715 bytes.
System is 1506 kB
Kernel: arch/x86_64/boot/bzImage is ready (#6)
Building modules, stage 2.
MODPOST 77 modules
WARNING: "check_utrace" [kernel/cpt/vzcpt.ko] undefined!
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2

[Updated on: Wed, 02 May 2007 17:12]

Report message to a moderator

Re: Probleme beim OpenVZ kernel build 2.6.20 [message #12559 is a reply to message #12556] Wed, 02 May 2007 19:21 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hi,

das Problem liegt im Modul kernel/cpt/cpt_dump.c,welches benötigt wird um vzcpt.ko zusammenzubauen.
Dort wird auf "check_utrace" zurückgegriffen, was aber nicht zuvor definiert ist/wird, d.h das Modul zu kompilieren klappt nicht und wird abgebrochen.
Was anderes steht im Fehler-Report auch nicht drin, evtl. schau Dir die git-commit-Verlinking dazu an, oder schau in den kernel-quellen zu vzcpt nach!

[Updated on: Wed, 02 May 2007 19:22]

Report message to a moderator

Re: Probleme beim OpenVZ kernel build 2.6.20 [message #14021 is a reply to message #12559] Mon, 11 June 2007 08:43 Go to previous message
axel is currently offline  axel
Messages: 1
Registered: June 2007
Junior Member
From: *pool.mediaWays.net
I experienced the same problem when using my custom .config for 2.6.20.

After applying the first patch (mentioned above, the second is already included in the patch-ovz005.1-combined ) and disabling some NFS features in .config, I compared my .config with the ones offered at http://download.openvz.org/kernel/branches/2.6.20/2.6.20-ovz 005.1/configs/
which revealed that

# CONFIG_VZ_CHECKPOINT is not set

is by default disabled. Disabling it also in my custom .config worked. However you wont be able to migrate running vz instances anymore.

ciao, axel
Previous Topic: *erledigt* Problem mit externen IP Adressen
Next Topic: failcnt >0 aber warum?
Goto Forum:
  


Current Time: Fri Dec 14 21:17:20 GMT 2018