OpenVZ Forum


Home » International » German » Kein Internetzugriff aus nem Guest [gelöst]
Kein Internetzugriff aus nem Guest [gelöst] [message #12361] Wed, 25 April 2007 17:00 Go to next message
renegadesworld is currently offline  renegadesworld
Messages: 9
Registered: April 2007
Junior Member
From: *versanet.de
Hiho, hab nen Rootserver auf welchem ich gerade frisch opensuse 10.1 installiert habe. Als Guest nutze ich ein Debian 4 (etch).

Ich nutze den vorgefertigten Kernel und die Toolz von Openvz.org.

Host ifconfig:
eth0      Link encap:Ethernet  HWaddr 00:02:A5:XX:XX:XX
          inet addr:89.XXX.XXX.XXX  Bcast:89.XXX.XXX.XXX  Mask:255.255.255.0
          inet6 addr: fe80::XXX:XXXX:XXXX:XXXX/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:197639 errors:0 dropped:0 overruns:0 frame:0
          TX packets:188547 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15068274 (14.3 Mb)  TX bytes:14600396 (13.9 Mb)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:878 errors:0 dropped:0 overruns:0 frame:0
          TX packets:878 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:86410 (84.3 Kb)  TX bytes:86410 (84.3 Kb)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:116 (116.0 b)  TX bytes:0 (0.0 b)


Guest ifconfig:
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:116 (116.0 b)

venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:64.XXX.XXX.XXX  P-t-P:64.XXX.XXX.XXX  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1


Host sysctl.conf:
# Disable response to broadcasts.
# You don't want yourself becoming a Smurf amplifier.
net.ipv4.icmp_echo_ignore_broadcasts = 1
net.ipv4.ip_forward = 1
net.ipv4.conf.default.proxy_arp = 0
# enable route verification on all interfaces
net.ipv4.conf.all.rp_filter = 1
# enable ipV6 forwarding
#net.ipv6.conf.all.forwarding = 1
kernel.sysrq = 1
net.ipv4.conf.default.send_redirects = 1
net.ipv4.conf.all.send_redirects = 0


Host uname -a:
Linux mail 2.6.16.21_2_ve026test016-1-default #1 Wed Jul 5 21:47:38 MSD 2006 i686 i686 i386 GNU/Linux


Host route:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
64.XXX.XXX.XXX    *               255.255.255.255 UH    0      0        0 venet0
89.XXX.XXX.XXX    *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         89-XXX-XXX-XXX.in 0.0.0.0         UG    0      0        0 eth0


Guest route:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.0.2.1       *               255.255.255.255 UH    0      0        0 venet0
default         192.0.2.1       0.0.0.0         UG    0      0        0 venet0


Guest Pings:
web:/# ping localhost
PING web (127.0.0.1) 56(84) bytes of data.
64 bytes from web (127.0.0.1): icmp_seq=1 ttl=64 time=0.108 ms
64 bytes from web (127.0.0.1): icmp_seq=2 ttl=64 time=0.063 ms
64 bytes from web (127.0.0.1): icmp_seq=3 ttl=64 time=0.103 ms

web:/# ping 89.XXX.XXX.XXX
PING 89.XXX.XXX.XXX (89.XXX.XXX.XXX) 56(84) bytes of data.
64 bytes from 89.XXX.XXX.XXX: icmp_seq=1 ttl=64 time=0.216 ms
64 bytes from 89.XXX.XXX.XXX: icmp_seq=2 ttl=64 time=0.121 ms
64 bytes from 89.XXX.XXX.XXX: icmp_seq=3 ttl=64 time=0.111 ms

web:/# ping www.google.de
ping: unknown host www.google.de

web:/# ping 209.85.135.103       <----(www.google.de IP)
PING 209.85.135.103 (209.85.135.103) 56(84) bytes of data.
--- 209.85.135.103 ping statistics ---
31 packets transmitted, 0 received, 100% packet loss, time 30011ms


Host Pings:
mail:/# ping 84.XXX.XXX.XXX
PING 84.XXX.XXX.XXX (84.XXX.XXX.XXX) 56(84) bytes of data.
--- 84.XXX.XXX.XXX ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5008ms

mail:/# ping www.google.de
PING www.google.com (209.85.135.103) 56(84) bytes of data.
64 bytes from mu-in-f103.google.com (209.85.135.103): icmp_seq=1 ttl=245 time=16.3 ms
64 bytes from mu-in-f103.google.com (209.85.135.103): icmp_seq=2 ttl=245 time=16.4 ms
64 bytes from mu-in-f103.google.com (209.85.135.103): icmp_seq=3 ttl=245 time=16.1 ms


Wer hat ne Idee?

[Updated on: Sun, 20 May 2007 10:27]

Report message to a moderator

Re: Kein Internetzugriff aus nem Guest [message #12363 is a reply to message #12361] Wed, 25 April 2007 17:41 Go to previous messageGo to next message
m.s.tremer is currently offline  m.s.tremer
Messages: 9
Registered: April 2007
Junior Member
From: *versanet.de
Vielleicht solltest du mal überprüfen, ob eine Paketfirewall an ist und diese ggf. ausschalten.

Mitch
Re: Kein Internetzugriff aus nem Guest [message #12364 is a reply to message #12363] Wed, 25 April 2007 17:57 Go to previous messageGo to next message
renegadesworld is currently offline  renegadesworld
Messages: 9
Registered: April 2007
Junior Member
From: *versanet.de
Susefirewall hab ich über yast ausgeschaltet.
Re: Kein Internetzugriff aus nem Guest [message #12389 is a reply to message #12364] Thu, 26 April 2007 11:48 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

From: *systs.org
Hi,

hat die VE korrekte DNS Einstellungen:

* /etc/resolv.conf hat gültige Einträge und die DNS Server sind erreichbar ?

* keine /etc/resolv.conf vorhanden ?
VE_0_# vzctl set <VEID> --nameserver <ip.des.1ten.dns> --nameserver <ip.des.2ten.dns> ... --searchdomain <domain> [--save]

Re: Kein Internetzugriff aus nem Guest [message #12390 is a reply to message #12361] Thu, 26 April 2007 11:58 Go to previous messageGo to next message
renegadesworld is currently offline  renegadesworld
Messages: 9
Registered: April 2007
Junior Member
From: *versanet.de
Vergessen zu posten,

Guest resolv.conf:
web:/# cat /etc/resolv.conf
search xtreme-server.de
nameserver 217.20.116.1


web:/# ping 217.20.116.1
PING 217.20.116.1 (217.20.116.1) 56(84) bytes of data.

--- 217.20.116.1 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 3999ms


Host resolv.conf:
mail:~ # cat /etc/resolv.conf
nameserver 217.20.116.1
nameserver 217.20.115.1
search xtreme-server.de


mail:~ # ping 217.20.116.1
PING 217.20.116.1 (217.20.116.1) 56(84) bytes of data.
64 bytes from 217.20.116.1: icmp_seq=1 ttl=61 time=0.332 ms
64 bytes from 217.20.116.1: icmp_seq=2 ttl=61 time=0.305 ms
64 bytes from 217.20.116.1: icmp_seq=3 ttl=61 time=0.266 ms


mail:~ # ping 217.20.115.1
PING 217.20.115.1 (217.20.115.1) 56(84) bytes of data.
64 bytes from 217.20.115.1: icmp_seq=1 ttl=61 time=0.385 ms
64 bytes from 217.20.115.1: icmp_seq=2 ttl=61 time=0.345 ms
64 bytes from 217.20.115.1: icmp_seq=3 ttl=61 time=0.275 ms
Re: Kein Internetzugriff aus nem Guest [message #12461 is a reply to message #12361] Sun, 29 April 2007 10:42 Go to previous message
renegadesworld is currently offline  renegadesworld
Messages: 9
Registered: April 2007
Junior Member
From: *versanet.de
ARGH, ICH BIN SO EIN BLINDES HUHN.

Man sollte seine zugewiesene IP-Adresse auch richtig eintippen. Hatte nen Zahlendreher drin und nu klappt's auch mit dem Inetzugriff.

Cya
Previous Topic: *erledigt* Netzwerk funktioniert nicht...
Next Topic: userbeancounter zurücksetzen
Goto Forum:
  


Current Time: Thu Jun 21 08:26:22 GMT 2018