OpenVZ Forum


Home » International » German » Problem mit iptables -m owner / ipt_owner
Problem mit iptables -m owner / ipt_owner [message #9911] Mon, 29 January 2007 16:47 Go to next message
Sunrabit is currently offline  Sunrabit
Messages: 2
Registered: January 2007
Location: Germany
Junior Member
Hallo,

ich versuche auf einer VE folgendes iptables-Komando zu verwenden:

/sbin/iptables -A OUTPUT -m owner --uid-owner $uid -m state --state NEW -p TCP --dport 80 -s $ip -j ACCEPT


Leider klappt dies nicht. "iptables: No chain/target/match by that name"

Die Chain OUTPUT gibt es natürlich.

Ich habe dann in der Dokumentation gesucht und ipt_owner in die vz.conf aufgenommen.

IPTABLES="ipt_owner ipt_REJECT ipt_tos ipt_limit ipt_multiport iptable_filter iptable_mangle ipt_TCPMSS ipt_tcpmss ipt_ttl ipt_length"


Das führt zu folgenden Problem:

root:~# vzctl enter 100
Warning: Unknown iptable module: ipt_owner, skipped
entered into VPS 100
root@apache:/#


Jetzt steh ich irgendwie auf dem Schlauch, vielleicht habt ihr einen Tipp.

System ist Debian-pre-4. (Etch)


Re: Problem mit iptables -m owner / ipt_owner [message #9912 is a reply to message #9911] Mon, 29 January 2007 18:31 Go to previous messageGo to next message
curx
Messages: 739
Registered: February 2006
Location: Nürnberg, Germany
Senior Member

Hi Sunrabit,

im Source Code von vzctl liegt das IPTABLES Module "ipt_owner" brach, sprich ist nicht aktiviert.

Näheres hier : http://bugzilla.openvz.org/show_bug.cgi?id=371

BTW, welchen Kernel verwendest Du ?

Gruß,
Thorsten
Re: Problem mit iptables -m owner / ipt_owner [message #9913 is a reply to message #9912] Mon, 29 January 2007 22:06 Go to previous message
Sunrabit is currently offline  Sunrabit
Messages: 2
Registered: January 2007
Location: Germany
Junior Member
Danke für die Antwort, hilft mir leider nur bedingt weil ich eigentlich den vzctl nicht manuell compilieren wollte.

-Edit-
Hatte es falsch gelesen. Kernel-Problem. Da muss ich wohl warten... schade.
-/Edit-

Ich habe im Moment den Kernel aus dem Wiki am laufen:
http://download.openvz.org/kernel/debian/etch/linux-image-2. 6.18-openvz-686_02_i386.deb
Ist zwar ein AMD64 Prozessor, aber ich habe nur 1 GB RAM.

Der Debian-Patch für die Kernel-Sourcen wollte irgendwie nicht laufen. Bin noch unsicher ob das eine gute Wahl ist, weil ich mir kein Ungeziefer durch kernel-exploits einfangen wollte. Und wie schnell und ob überhaupt dann ein neuer Kernel hier zur Verfügung steht ist mir noch nicht ganz klar. Laufen tut aber alles. Server ist eh noch im Testbetrieb wobei openvz wirklich schnell und gut zu konfigurieren war.



[Updated on: Mon, 29 January 2007 22:12]

Report message to a moderator

Previous Topic: SLES9 template
Next Topic: [Erledigt] VPS mit extern IP
Goto Forum:
  


Current Time: Thu Jan 26 22:52:45 GMT 2023

Total time taken to generate the page: 0.00798 seconds