OpenVZ Forum


Home » International » German » Problem mit Speicherzuteilung
Problem mit Speicherzuteilung [message #8071] Mon, 06 November 2006 20:28 Go to next message
pennywize is currently offline  pennywize
Messages: 7
Registered: November 2006
Junior Member
From: *adsl.alicedsl.de
Hallo,

ich habe zum testen openVZ auf folgender Testumgebung erstellt:

P4 mit 256MB RAM (sollte laut Hersteller genügen) und Kernel 2.6-9

Nun habe ich eine VE angelegt mit eigenem Debian Sarge image und wollte nun einstellen das dieser VE 128MB Arbeitsspeicher und 4GB Festplattenspeicher zugesichert wird. Letzteres hat wunderbar geklappt. Meine Englischkenntnisse sind leider nicht so alles im Handbuch zu verstehen. Es geht um die Zuteilung für kmemsize, vmguarpages für den zugesicherten Speicher. Aus dem Handbuch hab ich entnommen das 4kB eine Page sind, also 256=1MB Arbeitsspeicher.
Nehme ich 256*128 und trage das ein als
vzctl set 101 --vmguarpages 32768:33024 –-save

Beim Aufruf von vzctl exec 101 cat/proc/meminfo wird folgendes ausgegeben:

vzctl exec 101 cat /proc/meminfo
MemTotal:       273668 kB
MemFree:        210152 kB
Buffers:         19452 kB
Cached:          22004 kB
SwapCached:          0 kB
Active:          32240 kB
Inactive:        13972 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:       273668 kB
LowFree:        210152 kB
SwapTotal:      377488 kB
SwapFree:       377488 kB
Dirty:               8 kB
Writeback:           0 kB
Mapped:           9380 kB
Slab:            14116 kB
CommitLimit:    514320 kB
Committed_AS:    51860 kB
PageTables:        820 kB
VmallocTotal:   737272 kB
VmallocUsed:      1680 kB
VmallocChunk:   735376 kB


vzctl exec 101 cat /proc/user_beancounters
Version: 2.5
       uid  resource           held    maxheld    barrier      limit    failcnt
       101: kmemsize         607833     631416    2752512    2936012          0
            lockedpages           0          0         32         32          0
            privvmpages        3217       3508      16384      16384          0
            shmpages              0          0       8192       8192          0
            dummy                 0          0          0          0          0
            numproc               9          9         65         65          0
            physpages           612        741          0 2147483647          0
            vmguarpages           0          0      32768      33024          0
            oomguarpages        612        741       6144 2147483647          0
            numtcpsock            2          2         80         80          0
            numflock              2          2        100        110          0
            numpty                0          0         16         16          0
            numsiginfo            0          1        256        256          0
            tcpsndbuf             0          0     319488     524288          0
            tcprcvbuf             0          0     319488     524288          0
            othersockbuf       2236       2936     132096     336896          0
            dgramrcvbuf           0          0     132096     132096          0
            numothersock          2          4        120        120          0
            dcachesize            0          0    1048576    1097728          0
            numfile             219        219       2048       2048          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            dummy                 0          0          0          0          0
            numiptent            10         10        128        128          0


Installiere ich jetzt den Apache2 im VE 101 und versuche ihn anschließend zu starten passiert nichts. Es wird noch nicht mal ein Eintrag in die error.log vorgenommen.
Hat jemand eine Vorlage wie man das einstllen kann bzw. kann mir kurz erklären wie sich die Werte ergeben bzw. einzutragen sind?
Weiss jetzt echt nicht mehr weiter... Sad
Re: Problem mit Speicherzuteilung [message #8109 is a reply to message #8071] Tue, 07 November 2006 16:30 Go to previous messageGo to next message
rookie is currently offline  rookie
Messages: 12
Registered: October 2006
Location: CH
Junior Member
From: *tg.ch
Du kannst die Einstellungen auch direkt in der Konfigdatei machen. Dann hast du auch eine Übersicht über alle Parameter die du anpassen kannst und es geht schneller (Geschmackssache Wink ).

Die Konfigdateien der VPS's sind unter:
/etc/sysconfig/vz-scripts/
In deinem Fall wäre es diese:
/etc/sysconfig/vz-scripts/101.conf


Ich würde versuchen alle Parameter massiv zu erhöhen. Falls du zu hoch gehst mit einem Parameter sagt dir das vzctl wenn du z.B. den VPS startest oder stopst. Das ist sicher nicht die beste Vorgehensweise aber so hab ich meine VPS auch zum laufen gebracht in der Testumgebung. Rolling Eyes

RAM und Festplattenplatz sind nur 2 Einstellungsmöglichkeiten. DISKINODES z.B. definiert wieviele Dateien im VPS sein können. Andere Parameter definieren die max.Anzahl der Prozesse etc...

Eigentlich sollte die Spalte 'failcnt' in /proc/user_beancounters anzeigen wenn ein Wert an die Grenze kam.
Re: Problem mit Speicherzuteilung [message #8132 is a reply to message #8071] Thu, 09 November 2006 08:27 Go to previous messageGo to next message
Antarion is currently offline  Antarion
Messages: 17
Registered: December 2005
Location: Huerth
Junior Member
From: *intergenia.de
Hallo,

lass dich von der Ausgabe von /proc/meminfo nicht stören, im Kernel den du verwendest ist das _nicht_ virtualisiert. Du siehst also hier _immer_ den gesamten RAM der Hostnode.

privvmpages        3217       3508      16384      16384          0
[...]
vmguarpages           0          0      32768      33024          0
oomguarpages        612        741       6144 2147483647          0


was mir hier noch auffällt:

vmguarpages ist eine _Untermenge_ von privvmpages, es macht also wenig Sinn den Wert von privvmpages _niedriger_ als den Wert der vmguarpages zu setzen.

Versuche einmal beide Werte (privvmpages/vmguarpages) auf 32768:33024 zu setzen.

-Torsten

[Updated on: Thu, 09 November 2006 08:30]

Report message to a moderator

Re: Problem mit Speicherzuteilung [message #8186 is a reply to message #8071] Thu, 09 November 2006 20:58 Go to previous messageGo to next message
pennywize is currently offline  pennywize
Messages: 7
Registered: November 2006
Junior Member
From: *adsl.alicedsl.de
Hallo,

vielen Dank erstmal für Eure Antworten. Ich bin gerade dabei weiter zu testen und werde mal die Einstellungen von Antarion vornehmen.
Mal sehen ob es dann klappt. Habe zur Zeit noch Xen auf der Maschine und bin gerade dabei FreeBSD als Image zu erstellen.

Melde mich dann mit Ergebnissen.

Gruss Jasmin
Re: Problem mit Speicherzuteilung [message #8257 is a reply to message #8186] Sun, 12 November 2006 12:26 Go to previous message
pennywize is currently offline  pennywize
Messages: 7
Registered: November 2006
Junior Member
From: *adsl.alicedsl.de
Hallo,

ich habe nun ein bischen mit den privvmpages und vmgurarpages rumgespielt. Mir ist dabei aufgefallen:

Installiere ich zum Bleistift mit

apt-get install apache2-common apache2-mpm-prefork
wird alles installiert, nach dem starten allerdings fällt er im wahrsten Sinn des Wortes auseinander. Der user_beancounters zeigt einige failures bei den privvmpages an.

ABER, führe ich ein base-config aus und installiere den Webserver darüber, werden dutzende Pakete installiert, die meisten bräuchte ich gar nicht,läuft alles problemlos...

Zuerst war der Verdacht da, mein eigenes Image könnte fehlerhaft erstellt worden sein. Neues erstellt - erneut installiert den Apachen und selber Fehler.
Mit dem Image das OpenVZ mitliefert eine VE erstellt, selbiges vorgehen mit dem Apachen2, mit dem base-config und den tausenden Paketen klappt es, aber bei dem simplen apt-get install... s.o. steigt mir der Indianer beim starten aus und user_beancounters ist voll von failures bei privvmpages.

Eigentlich müsste es IMHO und nach logischem Denken umgekehrt sein...
Ich bin zwar erst 16, blond aber eigentlich nicht blöd... Laughing

Nochmals zu meiner Testumgebung:

1. Rechner mit 512MB RAM
2. installiertes Debian auf VMWare als Testumgebung mit 256MB RAM
3. VE Debian Sarge mit den besagten 128MB

Evtl. sollte ich doch auf den lighty umsteigen oder gleich Apache2 aus den Quellen bauen.

Frage nochmals, kann mir jemand entweder das Phänomen mit dem base-config erklären bzw. noch Ratschläge zur Optimierung von OpenVZgeben?

Neben openVZ läuft noch eine Testumgebung Debian + XeN 3.0.3 drauf, um den Unterschied zwischen einer Pseudo- und wirklicher Virtualisierung kennen zu lernen. Dort reicht 128MB für eine XM mit Apache2+MySQL+Postfix+PHP5 ohne "ruckeln" zum laufen zu bringen.
Sicherlich kann man beides nicht miteinander vergleichen, das mit dem openVZ halte ich für eine bessere Alternative, doch ist die Sache mit dem Speicher mir noch ein Rätsel..

Danke für weitere Hinweise von Vorschläge im Voraus

Gruss Jasmin

[Updated on: Sun, 12 November 2006 12:40]

Report message to a moderator

Previous Topic: vzyum hinter proxy mit user/passwort
Next Topic: Brauche eine Kleine hilfe
Goto Forum:
  


Current Time: Mon Aug 19 16:53:32 GMT 2019