OpenVZ Forum


Home » General » Support » Breaking OpenVZ7 on CentOS with latest update 7.0.14 (Factory repo is enabled by default and this caauses it to break)
Breaking OpenVZ7 on CentOS with latest update 7.0.14 [message #53650] Wed, 24 June 2020 00:40 Go to next message
dmc_dtc is currently offline  dmc_dtc
Messages: 8
Registered: May 2014
Location: Serbia
Junior Member
From: *adsl.eunet.rs
So, for anyone who is using OpenVZ7 on Centos7 (unofficially like me and i know there are many others) .. latest release 7.0.14 broke everything since factory.repo is enabled by deafult so if you just do yum update it will update it to 7.0.14 and then when you type yum update again it will have more updates (this time from factory repo)

Continuing at this point will break your system in a way that it boots and works for 5 minutes and then VPS stops and nothing.

If anyone gets to this point - just disable factory.repo in /etc/yum.repos.d/factory.repo (enabled=0)

and type

yum history undo $NUMBER (last update with which you broke it)

Then it will be fine again using 7.0.14 without factory repo


Hope this helps someone



>> dmc / dtc <<
Re: Breaking OpenVZ7 on CentOS with latest update 7.0.14 [message #53651 is a reply to message #53650] Mon, 29 June 2020 07:21 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 527
Registered: January 2006
Location: Moscow, Russia
Senior Member
From: *qwerty.ru
Hi,

thank you very much for noticing this!

We've uploaded another build to OpenVZ ( https://download.openvz.org/virtuozzo/releases/openvz-7.0.14 -136)
which has factory yum repo disabled by default, so it should be OK now.

As a benefit, there is an updated kernel vz7.151.14 in the build which contains a fix for memory corruption
which we were digging for a long time. Smile

Have a nice day!


If you problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: Breaking OpenVZ7 on CentOS with latest update 7.0.14 [message #53652 is a reply to message #53651] Mon, 29 June 2020 17:10 Go to previous message
dmc_dtc is currently offline  dmc_dtc
Messages: 8
Registered: May 2014
Location: Serbia
Junior Member
From: *adsl.eunet.rs
I can confirm that it is ok now, and that factory.repo is disabled in openvz-release-7.0.14-3 and that this update works perfectly on this configuration!

-Vladimir


>> dmc / dtc <<

[Updated on: Mon, 29 June 2020 17:10]

Report message to a moderator

Previous Topic: How to enable swap for CT when swap on OpenVZ 7 host machine is disabled?
Next Topic: vzpkg clean error
Goto Forum:
  


Current Time: Wed Dec 02 19:19:23 GMT 2020