OpenVZ Forum


Home » General » Support » Ploop not compacting
Ploop not compacting [message #53602] Wed, 11 December 2019 16:46 Go to next message
creiss is currently offline  creiss
Messages: 7
Registered: February 2015
Location: Germany
Junior Member

From: *dip0.t-ipconnect.de
Hey folks,

I encountered this fault on several distinct servers on several versions (all VZ7): When I create a CT and set the hdd to a large size (1-2TB) and fill it up aall is well. If I decrease the used space slowly and manually trigger a pcompact, the ploop-file gets reduced in space.

if however, I delete lots of content inside the CT, dropping the used space from 1900GB (out of 2000GB avail) to 100 or less, pcompact will fail to deflate the ploop file, leaving it at 2tb in size.

Doing things like decrease/ increase the virtual disk size did not help. Filling the container with a huge "Zero-File" and deleting it does not help either.
The only thing that will reclaim space is to create a new virtual hdd and rsync the files over.

How can I deflate a ploop-file thats empty in reality?
Re: Ploop not compacting [message #53603 is a reply to message #53602] Thu, 12 December 2019 09:33 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 523
Registered: January 2006
Location: Moscow, Russia
Senior Member
From: *virtuozzo.com
Hi creiss,

please a bug at https://bugs.openvz.org

Put there info about the latest system which suffers from the issue (vzkernel, ploop, pcompact versions),
a bit more details on how you fill the Container - 1-2Tb: approximate number of files, approximate size of files.

we'll try to reproduce the issue locally, but if we fail, we return to you for reproduction or for the CT image which cannot be deflated.

Thank you.


If you problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: Ploop not compacting [message #53604 is a reply to message #53603] Thu, 12 December 2019 09:58 Go to previous message
creiss is currently offline  creiss
Messages: 7
Registered: February 2015
Location: Germany
Junior Member

From: *dip0.t-ipconnect.de
Hey,

allright: https://bugs.openvz.org/browse/OVZ-7152

Cheers Smile
Previous Topic: OpenVZ 7.0.12 packages missing from repo
Next Topic: OpenVZ Maximum Virtual Servers Capacity
Goto Forum:
  


Current Time: Mon Jul 13 08:18:05 GMT 2020