OpenVZ Forum


Home » General » Support » Nat table is not able to access (adding NAT rules in iptables getting error )
Nat table is not able to access [message #53395] Thu, 05 July 2018 08:35 Go to next message
arunksasi is currently offline  arunksasi
Messages: 4
Registered: June 2018
Location: Bangalore
Junior Member
From: 103.61.12*
Hi ,


I have installed CentOS 6 + SolusVM OpenVZ and while adding NAT rules in iptables I am getting error below

root@cpu-6109 tmp]#iptables -t nat -nvL
iptables v1.4.7: can't initialize iptables table `nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


Please help me on this

Arun
Re: Nat table is not able to access [message #53396 is a reply to message #53395] Thu, 05 July 2018 10:06 Go to previous messageGo to next message
arunksasi is currently offline  arunksasi
Messages: 4
Registered: June 2018
Location: Bangalore
Junior Member
From: *55.83.202.asianet.co.in
Any reply to be appreciated
Re: Nat table is not able to access [message #53399 is a reply to message #53396] Fri, 06 July 2018 02:50 Go to previous message
vaverin is currently offline  vaverin
Messages: 682
Registered: September 2005
Senior Member
From: *2com.net
Dear arunksasi,
could you please clarify -- is it happen inside container or on host?

If this observed on host -- please check state of ip_conntrack_disable_ve0 option of nf_conntrack module.
(in Vz6 we disable conntracks on host by default, but in openvz6 it should be enabled)

If this happen inside container -- please check state of NETFILTER option in conainer's config file
NETFILTER="full" should enable using of NAT rules.

https://openvz.org/Using_NAT_for_container_with_private_IPs
https://openvz.org/Setting_up_an_iptables_firewall
Previous Topic: net.ipv4.ip_forward
Next Topic: conntrack in OpenVZ 7
Goto Forum:
  


Current Time: Wed Nov 14 04:57:12 GMT 2018