OpenVZ Forum


Home » General » Support » Openvz 7.07, yum upgrade failed
Openvz 7.07, yum upgrade failed [message #53290] Sat, 19 May 2018 02:09 Go to next message
akiyuki is currently offline  akiyuki
Messages: 3
Registered: May 2018
Junior Member
From: *dhcp.mtpk.ca.charter.com
I'm trying to do a yum update on openvz 7.07 new installation and I get the following error:
anybody knows how to fix this error?


Error: Package: libvzctl-7.0.479-1.vz7.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-network-3.6.0-1.vz7.43.x86_6
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-nwfilter-3.6.0-1.vz7.43.x86_
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-lxc-3.6.0-1.vz7.43.x86_64 (f
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-libs-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Re: Openvz 7.07, yum upgrade failed [message #53291 is a reply to message #53290] Sat, 19 May 2018 13:09 Go to previous messageGo to next message
TomvB is currently offline  TomvB
Messages: 25
Registered: July 2017
Location: Netherlands
Junior Member
From: 185.92.69*
Same here with a standard production installation.

Error: Package: libvzctl-7.0.479-1.vz7.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-network-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-nwfilter-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-daemon-driver-lxc-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: libvirt-libs-3.6.0-1.vz7.43.x86_64 (factory)
Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Re: Openvz 7.07, yum upgrade failed [message #53292 is a reply to message #53290] Sat, 19 May 2018 13:11 Go to previous messageGo to next message
alenco is currently offline  alenco
Messages: 6
Registered: August 2014
Junior Member
From: *xs4all.nl
Same issue here, clean installation done with previous version.
Re: Openvz 7.07, yum upgrade failed [message #53293 is a reply to message #53290] Sat, 19 May 2018 16:07 Go to previous messageGo to next message
alenco is currently offline  alenco
Messages: 6
Registered: August 2014
Junior Member
From: *xs4all.nl
I've downloaded the latest release openvz-iso-7.0.8-138.iso (factory) at https://download.openvz.org/virtuozzo/factory/x86_64/iso/

Clearly some packages are missing from the repo.

dbus.x86_64 1:1.10.24-7.vl7 / dbus-1.10.24-7.vl7.x86_64.rpm
dbus-libs.x86_64 1:1.10.24-7.vl7 /dbus-libs-1.10.24-7.vl7.x86_64.rpm

Have installed them from the ISO and now yum update works like it should.

* have notified Virtuozzo support team about this, they are going to take a look at repo correction.

[Updated on: Sat, 19 May 2018 16:08]

Report message to a moderator

Re: Openvz 7.07, yum upgrade failed [message #53294 is a reply to message #53293] Sat, 19 May 2018 16:51 Go to previous messageGo to next message
TomvB is currently offline  TomvB
Messages: 25
Registered: July 2017
Location: Netherlands
Junior Member
From: 185.92.69*
Thanks Alenco,

I will wait for the fix.

Tom
Re: Openvz 7.07, yum upgrade failed [message #53295 is a reply to message #53290] Mon, 21 May 2018 04:52 Go to previous messageGo to next message
akiyuki is currently offline  akiyuki
Messages: 3
Registered: May 2018
Junior Member
From: *dhcp.mtpk.ca.charter.com
Thanks Alenco
I searched forum
found following article

is this issue related "factory repo enabled by default"?

https://forum.openvz.org/index.php?t=msg&th=13492&st art=0&S=f6a34abb70a0a1213dbee4dc2f22487b

Re: Openvz 7.07, yum upgrade failed [message #53296 is a reply to message #53295] Mon, 21 May 2018 10:01 Go to previous messageGo to next message
TomvB is currently offline  TomvB
Messages: 25
Registered: July 2017
Location: Netherlands
Junior Member
From: 185.92.69*
akiyuki wrote on Mon, 21 May 2018 06:52
Thanks Alenco
I searched forum
found following article

is this issue related "factory repo enabled by default"?

https://forum.openvz.org/index.php?t=msg&th=13492&st art=0&S=f6a34abb70a0a1213dbee4dc2f22487b




# These repositories are for internal use by developers only
# Enable them on your own risk!!!

[factory]
name=Build Factory packages for Containers
mirrorlist=http://download.openvz.org/virtuozzo/mirrorlists/7.0/factory-os.mirrorlist
#baseurl=http://download.openvz.org/virtuozzo/factory/x86_64/os/
priority=49
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Virtuozzo-7

[factory-debuginfo]
name=Debug packages for Containers from Build Factory
mirrorlist=http://download.openvz.org/virtuozzo/mirrorlists/7.0/factory-debug.mirrorlist
#baseurl=http://download.openvz.org/virtuozzo/factory/x86_64/debug/
priority=49
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Virtuozzo-7

[virtuozzolinux-openvz-factory]
name=VirtuozzoLinux Factory
mirrorlist=http://repo.virtuozzo.com/vzlinux/mirrorlist/mirrors-7-factory
#baseurl=http://repo.virtuozzo.com/vzlinux/7/$basearch/factory/
priority=90
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/VZLINUX_GPG_KEY

[virtuozzolinux-openvz-factory-debuginfo]
name=VirtuozzoLinux Factory debug packages
mirrorlist=http://repo.virtuozzo.com/vzlinux/mirrorlist/mirrors-7-factory-debug
#baseurl=http://repo.virtuozzo.com/vzlinux/7/$basearch/factory-debug/
priority=90
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/VZLINUX_GPG_KEY


Disabled it with:
yum-config-manager --disable factory
yum-config-manager --disable virtuozzolinux-openvz-factory


Are components broken down in the past period? What is the impact for machines with the factory updates?
All my installations were set up in this way.

[Updated on: Mon, 21 May 2018 10:06]

Report message to a moderator

Re: Openvz 7.07, yum upgrade failed [message #53314 is a reply to message #53296] Mon, 28 May 2018 08:43 Go to previous messageGo to next message
akiyuki is currently offline  akiyuki
Messages: 3
Registered: May 2018
Junior Member
From: *dhcp.mtpk.ca.charter.com
Thanks TomvB
Re: Openvz 7.07, yum upgrade failed [message #53361 is a reply to message #53290] Fri, 22 June 2018 15:40 Go to previous messageGo to next message
TomvB is currently offline  TomvB
Messages: 25
Registered: July 2017
Location: Netherlands
Junior Member
From: *ip-037-017-220-003.dds.nl
Factory repo is still enabled in https://download.openvz.org/virtuozzo/releases/7.0/x86_64/is o/openvz-iso-7.0.7-361.iso Crying or Very Sad
Be careful and disable the 'factory' repo!

yum-config-manager --disable factory
yum-config-manager --disable virtuozzolinux-openvz-factory
Re: Openvz 7.07, yum upgrade failed [message #53368 is a reply to message #53361] Mon, 25 June 2018 09:41 Go to previous message
vaverin is currently offline  vaverin
Messages: 682
Registered: September 2005
Senior Member
From: *virtuozzo.com
Yes, you're right, factory repo is still enabled by default in last published openvz ISO.
I've pushed developers, but did not checked it by myself before last update and was misinformed by collegians.

I've escalated this problem again and hope it helps this time.
Previous Topic: vzmigrate failing with 'Can not create connection to...'
Next Topic: Add second HDD Custom Location / Partition
Goto Forum:
  


Current Time: Mon Oct 22 03:17:06 GMT 2018