OpenVZ Forum


Home » General » Support » Unable to open pty: No such file or directory | Centos 7 VPS cotainers (It is happening only for virtual servers running on Centos 7)
Unable to open pty: No such file or directory | Centos 7 VPS cotainers [message #53277] Sat, 12 May 2018 05:18 Go to next message
victorw is currently offline  victorw
Messages: 1
Registered: May 2018
Location: India
Junior Member
From: 117.206.16*
Hey all,

We are facing the following issue with few of our Centos 7 VPS containers on our OpenVZ nodes.

The main point is it is only happening for Centos 7 virtual servers on the node, rest Centos 6 and 5 containers are working fine without any issues on the same OpenVZ nodes.
Node002 # vzctl enter 300
enter into CT 300 failed
Unable to open pty: No such file or directory

Node002 # vzctl exec 300 cat /etc/redhat-release
CentOS Linux release 7.5.1804 (Core)

Other details like:
Node002 # uname -r
2.6.32-042stab104.1
~
Node002 # vzctl --version
vzctl version 4.5.1

I tried the following fix already.
Node002 # vzctl exec 300 /sbin/MAKEDEV tty
/bin/bash: /sbin/MAKEDEV: No such file or directory
~
Node002 # vzctl exec 300 /sbin/MAKEDEV pty
/bin/bash: /sbin/MAKEDEV: No such file or directory

But no luck, seems MAKEDEV not present for Centos7 containers, the same is present for Cento6.

Centos6 VPS:
Node002 # cat /vz/private/298/etc/redhat-release
CentOS release 6.9 (Final)
~
Node002 # ll /vz/private/298/sbin/MAKEDEV
-rwxr-xr-x 1 root root 24376 Nov 10  2010 /vz/private/298/sbin/MAKEDEV

Centos7 VPS:
Node002 # cat /vz/private/300/etc/redhat-release
CentOS Linux release 7.5.1804 (Core)
~
Node002 # ll /vz/private/300/sbin/MAKEDEV
ls: cannot access /vz/private/300/sbin/MAKEDEV: No such file or directory

Could you advise what needs to be done here to fix these Centos 7 containers?.


Re: Unable to open pty: No such file or directory | Centos 7 VPS cotainers [message #53278 is a reply to message #53277] Mon, 14 May 2018 05:38 Go to previous message
vaverin is currently offline  vaverin
Messages: 682
Registered: September 2005
Senior Member
From: *virtuozzo.com
On my test node vzctl enter into centos7.5 container works correctly, it though uses /dev/pts/0.
On my container /dev/ is tmpfs partition, and most part of devices are created automatically by udev, i.e. /sbin/MAKEDEV is not required here.

Also I would note that 042stab104.1 kernel is quite old, it was released 3+ years ago, 29-Jan-2015.
I would like advice you to update kernel on your node, probably it fixes the problem.

Thank you,
Vasily Averin
Previous Topic: No arp entry on vlan interface
Next Topic: Update error 7.5.1804
Goto Forum:
  


Current Time: Tue Nov 13 16:47:07 GMT 2018