OpenVZ Forum


Home » General » Support » No arp entry on vlan interface (container arp proxy entry is not created on vlan interfaces)
No arp entry on vlan interface [message #53267] Thu, 10 May 2018 17:52 Go to next message
openvzrv is currently offline  openvzrv
Messages: 1
Registered: May 2018
Junior Member
From: *adsl.proxad.net
When I upgrade from openv 7.0.6 to 7.0.6, I was unable to communicate from container to outside.
I use vlan interface on HN :
em1 -- br0 -- vlan18

On previous releases, arp entry are created on any interfaces. Now, the arp entry is added only on virbr0 interface:
apr -en
Address                  HWtype  HWaddress           Flags Mask            Iface
....
192.168.18.239           *       <from_interface>    MP                    virbr0
192.168.18.239           *       <from_interface>    MP                    vlan18
...


And now
apr -en
Address                  HWtype  HWaddress           Flags Mask            Iface
....
192.168.18.239           *       <from_interface>    MP                    virbr0
...



I found the filter on /usr/libexec/libvzctl/scripts/vz-functions line 642 (function vzgetnetdev) :
Quote:
[ -e "/sys/class/net/$dev/device" -o -e "/sys/class/net/$dev/bridge" ] || continue


Can you change this line to enable vlan interfaces ?
Re: No arp entry on vlan interface [message #53276 is a reply to message #53267] Fri, 11 May 2018 15:37 Go to previous message
vaverin is currently offline  vaverin
Messages: 682
Registered: September 2005
Senior Member
From: *virtuozzo.com
Thank you for reporting the problem,
I've submitted
https://bugs.openvz.org/browse/OVZ-7024

Please create bug in openvz jira next time!
Previous Topic: vps-create ERROR
Next Topic: Unable to open pty: No such file or directory | Centos 7 VPS cotainers
Goto Forum:
  


Current Time: Mon Dec 17 01:16:07 GMT 2018