OpenVZ Forum


Home » General » Support » ploop mount failed (Invalid argument)
ploop mount failed [message #53199] Wed, 07 March 2018 10:22
manimi is currently offline  manimi
Messages: 1
Registered: March 2018
Location: RUSSIAN
Junior Member
From: 94.233.207*
I copied the containers from the private directory to the backup server.
Now we need the data from the container. I try to mount and get an error. How to solve this problem???

[12:28 ]-[root@h2]-[~/backup_s1]
#ploop mount private/105_back/root.hdd/DiskDescriptor.xml
Opening delta /root/backup_s1/private/105_back/root.hdd/root.hdd
Opening delta /root/backup_s1/private/105_back/root.hdd/root.hdd
Adding delta dev=/dev/ploop59803 img=/root/backup_s1/private/105_back/root.hdd/root.hdd (rw)
Error in add_delta (ploop.c:1495): Can't open file /root/backup_s1/private/105_back/root.hdd/root.hdd: Invalid argument

[12:29 ]-[root@h2]-[~/backup_s1]
#mount -t ploop /root/backup_s1/private/105/root.hdd/DiskDescriptor.xml /root/backup_s1/root/105
Opening delta /root/backup_s1/private/105/root.hdd/root.hdd
Opening delta /root/backup_s1/private/105/root.hdd/root.hdd
Adding delta dev=/dev/ploop59803 img=/root/backup_s1/private/105/root.hdd/root.hdd (rw)
Error in add_delta (ploop.c:1495): Can't open file /root/backup_s1/private/105/root.hdd/root.hdd: Invalid argument
ploop mount -m /root/backup_s1/root/105 /root/backup_s1/private/105/root.hdd/DiskDescriptor.xml command failed

[01:02 ]-[root@h2]-[~/backup_s1]
#ls -l /root/backup_s1/private/105/root.hdd/
итого 12694536
-rw-r--r-- 1 1003 1003 790 дек 3 2016 DiskDescriptor.xml
-rw------- 1 1003 1003 0 фев 28 2014 DiskDescriptor.xml.lck
-rw------- 1 1003 1003 12999196672 мар 2 22:35 root.hdd
drwx------ 1 1003 1003 4096 фев 28 2014 root.hdd.mnt/
Previous Topic: How to install kernel headers with a different name?
Next Topic: openvz6 ploop backups and mysql innodb corruption
Goto Forum:
  


Current Time: Thu Apr 26 13:16:22 GMT 2018