OpenVZ Forum


Home » General » Support » KVM console (KVM console being removed after install)
icon8.gif  KVM console [message #53168] Fri, 09 February 2018 17:55
netmonky is currently offline  netmonky
Messages: 1
Registered: February 2018
Location: UK
Junior Member
From: 193.38.100*
Hi All,

New to OpenVZ7. Initially I want to move some KVM's onto my node before having a play with templates. When I try and build a new KVM with the below basic virt-install, I am able to configure the the install via console, see the serial and console in a dumpxml, but as soon as the server reboots to finish install, the below is removed from the xml.

<serial type='pty'>
<source path='/dev/pts/1'/>
<target port='0'/>
<alias name='serial0'/>
</serial>
<console type='pty' tty='/dev/pts/1'>
<source path='/dev/pts/1'/>
<target type='serial' port='0'/>
<alias name='serial0'/>
</console>


dirt-install commands:
virt-install --virt-type kvm --name centos7 --ram 2048 \
--disk centos-7.qcow2,format=qcow2,size=30 \
--os-type=linux --os-variant=rhel7 \
--boot menu=on,useserial=on --serial pty \
--console pty,target_type=serial \
--nographics
--accelerate
--extra-args "console=tty0 console=ttyS0,115200n8 serial" \
--location=/vz/iso/CentOS-7-x86_64-Minimal-1708.iso \
--network network=Bridged


# virsh list
Id Name State
----------------------------------------------------
13 centos7 running

# virsh console centos7
Connected to domain centos7
Escape character is ^]
error: internal error: cannot find character device <null>


can the above be achieved by prlctl ? I do not want to use vnc consoles, standard text console is much easier for none GUI server instances Smile. Any help is greatly appreciated
Previous Topic: venet cannot listen on ip address specified
Next Topic: Unable to access vz.repo from VM, but works on host node
Goto Forum:
  


Current Time: Wed May 23 12:36:17 GMT 2018