OpenVZ Forum


Home » General » Support » Container root disk is not configured
Container root disk is not configured [message #52966] Sat, 09 September 2017 15:20 Go to next message
mangust is currently offline  mangust
Messages: 34
Registered: April 2008
Location: Spain
Member
From: *red.226.225.212.procono.es
Starting container, it is not started with "Container root disk is not configured"

Mounted ploop, did fsck. Fixed and problem. Mounted manually ploop . can see my files.

Unmounted, trying start. Getting error.

This is what I like in ploop. You have huge files, and it is damaged. I am missing stable simfs.

Trying to mount like this:
ploop mount /vz/private/102/root.hdd/root.hds
mount -o rw,relatime,lazytime,data=ordered,balloon_ino=12,pfcache_csu m /dev/ploop28816p1 /vz/root/102

I can access disk, but container refuse to start. I tried to create another container and copy disk over. No luck.

[Updated on: Sat, 09 September 2017 15:43]

Report message to a moderator

Re: Container root disk is not configured [message #52973 is a reply to message #52966] Mon, 11 September 2017 09:12 Go to previous message
mangust is currently offline  mangust
Messages: 34
Registered: April 2008
Location: Spain
Member
From: *red.226.225.212.procono.es
Found issue. It was related with my experiments with additional disks within container, I've added few, then removed few. Till configuration for container got NO_ROOT options that I didn't noticed.
Error was in a container config, not image or its XML description.
Previous Topic: Baremetal graphical installation Black Screen IPMI
Next Topic: configure iptables on VZ7 host
Goto Forum:
  


Current Time: Fri Nov 24 05:42:00 GMT 2017