OpenVZ Forum


Home » General » Support » yum update SPICE_SERVER_0.12.5 (dependency error on qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64)
yum update SPICE_SERVER_0.12.5 [message #52959] Fri, 08 September 2017 05:08 Go to next message
madboyprice is currently offline  madboyprice
Messages: 3
Registered: September 2017
Junior Member
From: *194.255.49.in-addr.VOCUS.net.au
I have been trialing openvz 7 for a few months now and just ran the latest yum update. This has resulted in a dependency error on qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64.

--> Processing Dependency: libspice-server.so.1(SPICE_SERVER_0.12.5)(64bit) for package: 10:qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64
--> Finished Dependency Resolution
Error: Package: 10:qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64 (factory)
Requires: libspice-server.so.1(SPICE_SERVER_0.12.5)(64bit)


The current installed version of qemu-kvm-vz is qemu-kvm-vz-2.6.0-28.3.10.vz7.75.x86_64.

In the repos it looks like SPICE_SERVER_0.12.4 is the newest available ( http://repo.virtuozzo.com/vzlinux/7/x86_64/os/Packages/s/spi ce-server-0.12.4-20.vl7.x86_64.rpm)

Has anyone else come across this and is there a work around?

Re: yum update SPICE_SERVER_0.12.5 [message #52960 is a reply to message #52959] Fri, 08 September 2017 08:56 Go to previous messageGo to next message
khorenko is currently offline  khorenko
Messages: 479
Registered: January 2006
Location: Moscow, Russia
Senior Member
From: *virtuozzo.com
https://bugs.openvz.org/browse/OVZ-6924

If you problem is solved - please, report it!
It's even more important than reporting the problem itself...
Re: yum update SPICE_SERVER_0.12.5 [message #52961 is a reply to message #52960] Sat, 09 September 2017 07:05 Go to previous messageGo to next message
madboyprice is currently offline  madboyprice
Messages: 3
Registered: September 2017
Junior Member
From: *pie.co.nz
Cool, I did not find that in my Google searching.

I have now done the following:

>rpm -q vzlinux-release
 vzlinux-release-7-1.vl7.38.x86_64
>yum update vzlinux-release
Updated:
  vzlinux-release.x86_64 3:7-1.vl7.38.1 

>yum update
Error: Package: 10:qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64 (factory)
           Requires: libspice-server.so.1(SPICE_SERVER_0.12.5)(64bit)

Then tried:

>yum clean all
>yum update
Error: Package: 10:qemu-kvm-vz-2.9.0-16.3.vz7.6.x86_64 (factory)
           Requires: libspice-server.so.1(SPICE_SERVER_0.12.5)(64bit)



Looks like I still am having the same problem.
>rpm -q vzlinux-release
vzlinux-release-7-1.vl7.38.1.x86_64

What have I missed?

3.10.0-514.26.1.vz7.33.22 #1 SMP Sat Jul 29 14:57:34 MSK 2017 x86_64 x86_64 x86_64 GNU/Linux
Re: yum update SPICE_SERVER_0.12.5 [message #52962 is a reply to message #52961] Sat, 09 September 2017 09:26 Go to previous messageGo to next message
mangust is currently offline  mangust
Messages: 34
Registered: April 2008
Location: Spain
Member
From: *red.226.225.212.procono.es
solved updater issue by
yum update ftp://195.220.108.108/linux/fedora/linux/updates/22/x86_64/s /spice-server-0.12.6-1.fc22.x86_64.rpm

Ugly, but yum update start working for me after that.

If not confident with this RPM search on rpmfind 0.12.6-1 it is from fedora 22
Re: yum update SPICE_SERVER_0.12.5 <SOLVED> [message #52969 is a reply to message #52962] Sun, 10 September 2017 01:10 Go to previous messageGo to next message
madboyprice is currently offline  madboyprice
Messages: 3
Registered: September 2017
Junior Member
From: *pie.co.nz
Thanks mangust

That seems to have solved the issue. I did as you suggested update spice-server, after that I did a 'yum update' which completed successfully.


Thanks again.

Re: yum update SPICE_SERVER_0.12.5 [message #52980 is a reply to message #52961] Mon, 11 September 2017 12:24 Go to previous message
mangust is currently offline  mangust
Messages: 34
Registered: April 2008
Location: Spain
Member
From: *red.226.225.212.procono.es
Just update spice to fedora package as I described. Till official solution comes.

Previous Topic: Unable to connect OpenVZ 7 via virsh
Next Topic: pcompact can't see additional disks
Goto Forum:
  


Current Time: Mon Nov 20 07:31:58 GMT 2017