OpenVZ Forum


Home » General » Support » How to boot from openvz .iso?
How to boot from openvz .iso? [message #52901] Thu, 27 July 2017 08:48
slrslr is currently offline  slrslr
Messages: 10
Registered: April 2014
Junior Member
From: 188.213.49*
Hello,

on CentOS 7.3.1611 (core) (3.10.0-514.26.2) i am trying to create working boot menu entry so the server will run the netinstall .iso image @ boot time. I do not know more simple / better way to run it being unable to upload via IPMI.

The ISO is: /boot/openvz-iso-7.0.4-698-netinstall.iso (in /dev/sda2), its structure:

EFI
-BOOT (BOOTx64.efi, grub.cfg, grubx64.efi)
images (efiboot.img)
-grub (grub.cfg)
--i386-pc (...)
--themes (...)
---virtuozzo (...)
--x86_64-efi (...)
-pxeboot (initrd.img, upgrade.img, vmlinuz)
LiveOS (osmin.img, squashfs.img)

i edited /etc/grub.d/40_custom

Quote:
menuentry 'Install OpenVZ 7.0.4 (698)' --class fedora --class gnu-linux --class gnu --class os {
linux /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=openvz-iso-7.0.4-698 quiet ip=dhcp
initrd /images/pxeboot/initrd.img
}

(i also tried: set isofile="/boot/openvz-iso-7.0.4-698-netinstall.iso")

and then saved by "grub2-mkconfig" and reboot, but i never see the menu entry, i see only default ones.

Please what should i add into /etc/grub.d/40_custom or what is the most simple way to mount that netinstall iso @ boot?

I do not have physical access, just SSH and IPMI where IPMI somehow can't upload the iso (speed too slow).

Thank You
Previous Topic: "Thin pool volumes cannot be reduced in size yet."
Next Topic: Poor container performance with load above 1
Goto Forum:
  


Current Time: Wed Oct 18 03:36:57 GMT 2017