OpenVZ Forum


Home » General » Support » Update Issue (Requires: kernel-firmware >= 2.6.32-642.6.1.el6) (Trying to update my OpenVZ)
icon4.gif  Update Issue (Requires: kernel-firmware >= 2.6.32-642.6.1.el6) [message #52737] Fri, 17 February 2017 08:32 Go to next message
armanmisdar is currently offline  armanmisdar
Messages: 4
Registered: March 2014
Junior Member
From: *peninsulargroup.com
Hi Guys,

My OpenVZ current version is 2.6.32-042stab111.12. I would like to update it using 'yum update' command but I encountered messages below:

Error: Package: vzkernel-2.6.32-042stab120.18.x86_64 (openvz-kernel-rhel6)
Requires: kernel-firmware >= 2.6.32-642.6.1.el6
Installed: kernel-firmware-2.6.32-573.7.1.el6.noarch (@updates)
kernel-firmware = 2.6.32-573.7.1.el6


How do I fulfil the requirement for 2.6.32-642.6.1.el6?

Thanks in advance for your help!
Re: Update Issue (Requires: kernel-firmware >= 2.6.32-642.6.1.el6) [message #52745 is a reply to message #52737] Tue, 21 February 2017 09:14 Go to previous messageGo to next message
armanmisdar is currently offline  armanmisdar
Messages: 4
Registered: March 2014
Junior Member
From: *peninsulargroup.com
I figured it out, simply remove the current kernel (kernel-firmware-2.6.32-573.7.1.el6.noarch.rpm) then download and install the kernel-firmware-2.6.32-642.6.1.el6.noarch.rpm manually.

Then yum update works just fine!
Re: Update Issue (Requires: kernel-firmware >= 2.6.32-642.6.1.el6) [message #52750 is a reply to message #52737] Fri, 24 February 2017 16:23 Go to previous message
Ales is currently offline  Ales
Messages: 326
Registered: May 2009
Senior Member
From: *dynamic.sbb.rs
The kernel-firmware issue is one of the most often encountered by the new users, it has been addressed often.

Should you have a problem with the next update, I strongly recommend searching the Wiki and the numerous past threads about this.
Previous Topic: template ubuntu 16 and network
Next Topic: OpenVZ7 - VE Migration fails
Goto Forum:
  


Current Time: Fri Oct 20 18:02:44 GMT 2017