OpenVZ Forum

Home » General » Support » vzctl can not start container in legacy kernel (in Fedora 25 it is not possible to start a container with the normal fedora kernel, whereas it worked in Fedora 24)
vzctl can not start container in legacy kernel [message #52730] Tue, 07 February 2017 21:11 Go to next message
thadden is currently offline  thadden
Messages: 2
Registered: February 2017
Junior Member
From: *

I am using vzctl on a normal lagacy kernel on Fedora 25. Since FC25 I can not start any containers any more:

[root@jo-laptop ~]# vzctl start rhel-7.2
Directory /proc/vz not found, assuming non-OpenVZ kernel
Starting container...
Mounting root: /var/lib/vz/root/999 /var/lib/vz/private/999
Container is mounted
WARNING: Running container unprivileged. USER_NS not supported, or runtime disabled
Setting iptables mask 0x1c000007
Setting features mask 0000000000000001/0000000000000001
Running container script: /etc/vz/dists/scripts/
Running container script: /etc/vz/dists/scripts/
Running container script: /etc/vz/dists/scripts/
Container start failed (try to check kernel messages, e.g. "dmesg | tail")
Killing container ...
Container was stopped
Container is unmounted

The return code is 79 which should mean "Container action script returned an error", but the above scripts all run without an error. Also an strace of the process did not result in any ideas what happens.

Until some half year ago (was Fedora 24, then) it worked fluently and I used it quiet frequently - which I wanted to do again with the above results. So my question is: Is that error known? Are there any changes I can make to the config to get better results or debug deeper?

[root@jo-laptop ~]# uname -r
[root@jo-laptop ~]# rpm -q vzctl-core

Re: vzctl can not start container in legacy kernel [message #52752 is a reply to message #52730] Mon, 27 February 2017 15:24 Go to previous message
jbirck is currently offline  jbirck
Messages: 1
Registered: February 2017
Location: Zuerich
Junior Member
From: *
Hello Joachim,

had the same problem in Fedora 24, updated to kernel 4.9.x.
Solved by:
dnf install kernel-4.5.5
somehow updated to death.
Hope this helps

Previous Topic: OpenVZ7 - VE Migration fails
Next Topic: kernel 3.10 stable
Goto Forum:

Current Time: Wed Jun 28 05:27:35 GMT 2017