OpenVZ Forum

Home » General » Support » OpenVZ 7 prlctl fails with proxies.
icon13.gif  OpenVZ 7 prlctl fails with proxies. [message #52713] Fri, 13 January 2017 14:54
DanielGA is currently offline  DanielGA
Messages: 1
Registered: January 2017
Location: Germany
Junior Member
From: 89.106.185*
Hello everyone,

I have installed yesterday OpenVZ 7 with the ISO in a new machine behind a firewall and configured a http_proxy in yum.conf and in the bash env variable.

I was able to install and update OpenVZ 7 and access all possible websites with curl/wget from the machine but I was not able to create a machine with prlctl using the follwing command:

# prlctl create ContCOS7 --vmtype ct --ostemplate centos-7-x86_64

The error was always the same, prctl was trying to fech some template information defined on a "base0-4" repo and not being able to reach

I thought all the time that the templates where already there:

# rpm -qa | grep ez

After reading I realize that prlctl in fact was failing while fetching the container because it is ignoring the proxy information in the machine.

The only way to fetch a container behind a proxy seems to be using vzpkg:

# vzpkg create appcache --ostemplate centos-6-x86_64 --apptemplate devel
# prlctl create 100 --vmtype ct --ostemplate centos-7-x86_64

None of these is documented on the openvz_installation_guide.pdf or openvz_installation_guide.pdf and it seems to me a wrong behaviour.

All binaries involved in the installation and fetching from machines/templates should behave the same.


Previous Topic: ovztransfer
Next Topic: Ploop Backup
Goto Forum:

Current Time: Wed Mar 21 18:52:16 GMT 2018